Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1938 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  [RESOLU] Imprimante port parallele

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[RESOLU] Imprimante port parallele

n°1014972
doudouyam
Posté le 25-02-2008 à 23:17:07  profilanswer
 

Salut,
 
J'ai une imprimante sur mon port parallele (HP laserjet 2100) qui est normalement bien supporté sous linux (d'après linuxprinting.org).
Mais je n'arrive pas a ajouter une imprimante connecté sur le port parallèle.
Je charge le module 'parport' et 'lp' mais quand je fais ajouter une imprimante dans l'interface web de cups, mais au moment de choisir le matériel, je ne peux pas précisée que l'imprimante est connectée au port parallèle.
 
Avez-vous une idée du problème ?
Mon noyau est mal configuré pour pouvoir supporter une imprimante sur le port parallèle ?
 
Merci.


Message édité par doudouyam le 29-02-2008 à 08:46:10
mood
Publicité
Posté le 25-02-2008 à 23:17:07  profilanswer
 

n°1014982
fighting_f​alcon
Posté le 26-02-2008 à 00:01:30  profilanswer
 

alors ...
1/ distrib et version
2/ version du noyau
3/ version de CUPS
4/ résultat de la commande lsmod
5/ tu allumes ton imprimante avant de vouloir l'installer dans CUPS ?

n°1015017
doudouyam
Posté le 26-02-2008 à 07:58:54  profilanswer
 

Excuse de pas voir mis plus de précision:
 
1/ Debian lenny
 
2/ 2.6.23.13
 
3/ CUPS 1.3.5
 
4/
nvidia               3929228  22  
lp                     10948  0  
parport                24768  1 lp
fan                     5124  0  
ac                      5636  0  
battery                12296  0  
loop                   18052  0  
snd_emu10k1_synth       7168  0  
snd_emux_synth         33536  1 snd_emu10k1_synth
snd_seq_virmidi         6656  1 snd_emux_synth
snd_seq_midi_emul       6784  1 snd_emux_synth
snd_emu10k1           136384  3 snd_emu10k1_synth
firmware_class          9856  1 snd_emu10k1
snd_ac97_codec         97056  1 snd_emu10k1
ac97_bus                2432  1 snd_ac97_codec
snd_util_mem            4864  2 snd_emux_synth,snd_emu10k1
snd_hwdep               9348  2 snd_emux_synth,snd_emu10k1
snd_pcm_oss            40224  0  
snd_pcm                69256  3 snd_emu10k1,snd_ac97_codec,snd_pcm_oss
snd_page_alloc         10504  2 snd_emu10k1,snd_pcm
snd_mixer_oss          16640  1 snd_pcm_oss
snd_seq_dummy           3972  0  
snd_seq_oss            31488  0  
snd_seq_midi            8480  0  
snd_rawmidi            23840  3 snd_seq_virmidi,snd_emu10k1,snd_seq_midi
snd_seq_midi_event      7424  3 snd_seq_virmidi,snd_seq_oss,snd_seq_midi
snd_seq                48080  9 snd_emux_synth,snd_seq_virmidi,snd_seq_midi_emul,snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer              22020  3 snd_emu10k1,snd_pcm,snd_seq
snd_seq_device          8460  8 snd_emu10k1_synth,snd_emux_synth,snd_emu10k1,snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
uhci_hcd               24460  0  
snd                    51940  17 snd_emux_synth,snd_seq_virmidi,snd_emu10k1,snd_ac97_codec,snd_hwdep,snd_pcm_oss,snd_pcm,snd_mixer_oss,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
8250_pnp                9856  0  
8250                   23284  1 8250_pnp
serial_core            20992  1 8250
3c59x                  43304  0  
mii                     5632  1 3c59x
ide_cd                 39456  0  
rtc                    12056  0  
thermal                15388  0  
button                  8336  0  
usbcore               132120  2 uhci_hcd
processor              20896  1 thermal
cdrom                  36640  1 ide_cd
soundcore               7648  1 snd
amd_k7_agp              8844  1  
agpgart                33200  2 nvidia,amd_k7_agp
 
5/Oui j'allume l'imprimante avant de vouloir l'installé (en fait j'ai essayé les deux manières mais ça change rien)
 

n°1015202
fighting_f​alcon
Posté le 26-02-2008 à 13:59:40  profilanswer
 

tes modules lp et parport sont chargés au démarrage de ta machine ou pas ?
 
Si non, c'est que tu les charges à la main je pense, et dans ce cas, tu redémarres CUPS après avoir chargé tes modules ?

n°1015665
doudouyam
Posté le 27-02-2008 à 17:48:16  profilanswer
 

Oui j'ai relancé CUPS apès avoir chargé mais modules lp et parport.
Avec la commande : /etc/init.d./cupsys restart

n°1016207
doudouyam
Posté le 28-02-2008 à 22:08:04  profilanswer
 

Quelqu'un peut m'aider ?
Peut être qu'il faut configurer CUPS pour qu'il propose l'installation d'imprimante sur port parallèle.

n°1016222
doudouyam
Posté le 28-02-2008 à 23:23:46  profilanswer
 

C bon j'ai trouvé mon problème.
Pour ceux que ça intéresse, je n'avais pas activer toutes les option dans le noyau et plus précisément les sous option "PC-style" de "Parallele port support" et "IEEE 1284 transfer modes)" de "Parallel printer support"


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  [RESOLU] Imprimante port parallele

 

Sujets relatifs
[Mandriva] erreur avec Xdialog [résolu][ RESOLU] tri sur la date
[RÉSOLU] coment root lance un programme sous l'identité d'un user[RÉSOLU] serveur de screenshot avec mozembed : désactiver le son
ubuntu : recharger un module usb [RESOLU]Debian testing sur VMware[Résolu]
[Debian] - Pb port 80 pour 2 ip & Port forwarding[Résolu] VirtualBox et XP : écran noir au démarrage
Impossible demarrer en mode graphique mandriva 2008 (resolu)[Linux] OpenLDAP PosixGroup + Proftpd
Plus de sujets relatifs à : [RESOLU] Imprimante port parallele


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR