Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
2167 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  Grub et plein de beep au boot

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Grub et plein de beep au boot

n°328027
burgergold
5$? va chez l'diable!
Posté le 21-09-2003 à 03:12:11  profilanswer
 

Javais un disque avec linux dessus. Je démarre la machine, en haut a gauche ya GRUB et le pc speakers beep a fond
 
je me dis: ah... jdevais avoir foutu en l'air l'installation. Alors jme reclaque une install de red hat 8.0 mais la! meme probleme apres l'installation. Je comprends pas trop...


---------------
http://www.boincstats.com/signature/user_664861.gif
mood
Publicité
Posté le 21-09-2003 à 03:12:11  profilanswer
 

n°328065
avv
Posté le 21-09-2003 à 11:16:53  profilanswer
 

1) Verifie le jumper du hdd (master) et qu'il soit bien connect sur le ide primaire  
2) Verifie dans le bios que le HDD soit reconnu correctement
3) As-tu une partition Windows ? est-elle correctement identifiée (hda1) lors de l'install ?
 

n°328138
burgergold
5$? va chez l'diable!
Posté le 21-09-2003 à 14:08:04  profilanswer
 

1) jai 1hd master et 1 hd slave
2) jai 2 dd reconnu correctement, 1 en primary master, lautre en primary slave
3) quand j'ai installé redhat 8.0, jai détruit toute les partitions que j'avais
 
up :D


---------------
http://www.boincstats.com/signature/user_664861.gif
n°328170
burgergold
5$? va chez l'diable!
Posté le 21-09-2003 à 15:34:23  profilanswer
 

:cry:  
 
sérieusement je comprends vraiment pas :sweat:


---------------
http://www.boincstats.com/signature/user_664861.gif
n°328188
axey
http://www.00f.net
Posté le 21-09-2003 à 16:11:12  profilanswer
 

Plein de bips ?
 
Vi a été intégré à Grub ?

n°328194
burgergold
5$? va chez l'diable!
Posté le 21-09-2003 à 16:18:16  profilanswer
 

axey a écrit :

Plein de bips ?
 
Vi a été intégré à Grub ?


 
 :??:  
 
c vraiment avant de loader linux, ya grub écrit en haut a gauche et mon pc speaker beep très vite


---------------
http://www.boincstats.com/signature/user_664861.gif
n°328241
axey
http://www.00f.net
Posté le 21-09-2003 à 18:36:02  profilanswer
 

burgergold a écrit :


mon pc speaker beep très vite


 
Ca doit être Vim alors.

n°328252
burgergold
5$? va chez l'diable!
Posté le 21-09-2003 à 19:10:00  profilanswer
 

axey a écrit :


 
Ca doit être Vim alors.


 
vim? ca te dirait d'etre un peu plus précis svp :D


---------------
http://www.boincstats.com/signature/user_664861.gif
n°328477
burgergold
5$? va chez l'diable!
Posté le 22-09-2003 à 03:54:58  profilanswer
 
n°328513
burgergold
5$? va chez l'diable!
Posté le 22-09-2003 à 11:51:29  profilanswer
 
mood
Publicité
Posté le 22-09-2003 à 11:51:29  profilanswer
 

n°328531
PinG
Rooteur
Posté le 22-09-2003 à 12:53:33  profilanswer
 

axey faisait de l'humour, parcequ'il trouve que /^vi(m)?$/ est imbitable, que dès que tu fait un truc, ca bip et modifies ton texte alors que tu n'as rien demandé. En bref, une sorte de ed...
 
D'après Axey lui même, pour quitter vim, le plus simple est de lancer un deuxième term et de killer vim :D
 
Donc sa réponse était une blague...
 
PS : pour ceux qui ne conaissent pas ed :
 
les sources (en asm, ed est optimisé à mort) :

Code :
  1. [ORG 0x100]
  2. top:  mov ah,0x0a
  3.       mov dx, buffer
  4.       int 0x21
  5.       mov ah, 0x09
  6.       mov dl,message
  7.       int 0x21     
  8.       jmp short top
  9. message:
  10.          db 10,'?',13,10,'$'
  11. buffer:


 
 
Et la doc officielle de ed :

When I log into my Xenix system with my 110 baud teletype, both vi
*and* Emacs are just too damn slow.  They print useless messages like,
'C-h for help' and '"foo" File is read only'.  So I use the editor
that doesn't waste my VALUABLE time.
 
Ed, man!  !man ed
 
ED(1)               UNIX Programmer's Manual                ED(1)
 
NAME
     ed - text editor
 
SYNOPSIS
     ed [ - ] [ -x ] [ name ]
DESCRIPTION
     Ed is the standard text editor.
---
 
Computer Scientists love ed, not just because it comes first
alphabetically, but because it's the standard.  Everyone else loves ed
because it's ED!
 
"Ed is the standard text editor."
 
And ed doesn't waste space on my Timex Sinclair.  Just look:
 
-rwxr-xr-x  1 root          24 Oct 29  1929 /bin/ed
-rwxr-xr-t  4 root     1310720 Jan  1  1970 /usr/ucb/vi
-rwxr-xr-x  1 root  5.89824e37 Oct 22  1990 /usr/bin/emacs
 
Of course, on the system *I* administrate, vi is symlinked to ed.
Emacs has been replaced by a shell script which 1) Generates a syslog
message at level LOG_EMERG; 2) reduces the user's disk quota by 100K;
and 3) RUNS ED!!!!!!
 
"Ed is the standard text editor."
 
Let's look at a typical novice's session with the mighty ed:
 
golem$ ed
 
?
help
?
?
?
quit
?
exit
?
bye
?
hello?  
?
eat flaming death
?
^C
?
^C
?
^D
?
 
---
Note the consistent user interface and error reportage.  Ed is
generous enough to flag errors, yet prudent enough not to overwhelm
the novice with verbosity.
 
"Ed is the standard text editor."
 
Ed, the greatest WYGIWYG editor of all.
 
ED IS THE TRUE PATH TO NIRVANA!  ED HAS BEEN THE CHOICE OF EDUCATED
AND IGNORANT ALIKE FOR CENTURIES!  ED WILL NOT CORRUPT YOUR PRECIOUS
BODILY FLUIDS!!  ED IS THE STANDARD TEXT EDITOR!  ED MAKES THE SUN
SHINE AND THE BIRDS SING AND THE GRASS GREEN!!
 
When I use an editor, I don't want eight extra KILOBYTES of worthless
help screens and cursor positioning code!  I just want an EDitor!!
Not a "viitor".  Not a "emacsitor".  Those aren't even WORDS!!!! ED!
ED! ED IS THE STANDARD!!!
 
TEXT EDITOR.
 
When IBM, in its ever-present omnipotence, needed to base their
"edlin" on a UNIX standard, did they mimic vi?  No.  Emacs?  Surely
you jest.  They chose the most karmic editor of all.  The standard.
 
Ed is for those who can *remember* what they are working on.  If you
are an idiot, you should use Emacs.  If you are an Emacs, you should
not be vi.  If you use ED, you are on THE PATH TO REDEMPTION.  THE
SO-CALLED "VISUAL" EDITORS HAVE BEEN PLACED HERE BY ED TO TEMPT THE
FAITHLESS.  DO NOT GIVE IN!!!  THE MIGHTY ED HAS SPOKEN!!!
 
?



---------------
-- NO SLACKERS - violators will be fsck'd & tar'd
n°328533
avv
Posté le 22-09-2003 à 13:15:22  profilanswer
 

burgergold a écrit :

1) jai 1hd master et 1 hd slave
2) jai 2 dd reconnu correctement, 1 en primary master, lautre en primary slave
3) quand j'ai installé redhat 8.0, jai détruit toute les partitions que j'avais
 
up :D


 
J'ai eu cela aussi mais avec une RH7.3, le problème provenait d'une mauvaise reconnaissance par RH de la géo du HDD, j'avais pu le voir lors de l'install, a un moment il donnait la geo reconnue qui n'était pas du tout celle du BIOS.  
La solution a été  
BIOS : Plug-Play OS -> NO
Boot install : passer en param la géo du HDD
 
Z'aurais pu le dire tout de suite .....


Message édité par avv le 22-09-2003 à 13:16:06
n°328970
burgergold
5$? va chez l'diable!
Posté le 23-09-2003 à 00:39:46  profilanswer
 

avv a écrit :


 
J'ai eu cela aussi mais avec une RH7.3, le problème provenait d'une mauvaise reconnaissance par RH de la géo du HDD, j'avais pu le voir lors de l'install, a un moment il donnait la geo reconnue qui n'était pas du tout celle du BIOS.  
La solution a été  
BIOS : Plug-Play OS -> NO
Boot install : passer en param la géo du HDD
 
Z'aurais pu le dire tout de suite .....


 
pour le bios jvais voir, mais sinon le param?
 
"Boot install : passer en param la géo du HDD"
 
c quoi la géo du dd? le nombre de cylindre et de sector et tout?!?


---------------
http://www.boincstats.com/signature/user_664861.gif
n°329047
bugsan
Posté le 23-09-2003 à 10:04:19  profilanswer
 

il semble que le stage1 de grub ne trouve plus son stage2 (ou stage1_5)  :pt1cable:  
il ne te reste plus qu'à réinstaller grub  :sweat:  
 
grub> root (hd0,0)
grub> setup (hd0)

n°329066
burgergold
5$? va chez l'diable!
Posté le 23-09-2003 à 11:43:08  profilanswer
 

bugsan a écrit :

il semble que le stage1 de grub ne trouve plus son stage2 (ou stage1_5)  :pt1cable:  
il ne te reste plus qu'à réinstaller grub  :sweat:  
 
grub> root (hd0,0)
grub> setup (hd0)


 
cest parce que avant ca marchait et la ca marche plus (avec la meme install de redhat)


---------------
http://www.boincstats.com/signature/user_664861.gif
n°330062
burgergold
5$? va chez l'diable!
Posté le 24-09-2003 à 22:49:14  profilanswer
 
n°330082
MemphisRai​nes187
Mon eleanor - Je t aurais :)
Posté le 24-09-2003 à 23:45:37  profilanswer
 

Debranche le Speaker :D :wahoo:  
 


---------------
Quelque fois il vaut mieux se taire et passer pour un con plutot que de l ouvrir et de le confirmer.
n°330091
burgergold
5$? va chez l'diable!
Posté le 25-09-2003 à 00:02:39  profilanswer
 

MemphisRaines187 a écrit :

Debranche le Speaker :D :wahoo:  
 
 


 
ouais mais la machine bootera pas plus  :D


---------------
http://www.boincstats.com/signature/user_664861.gif
n°330118
MemphisRai​nes187
Mon eleanor - Je t aurais :)
Posté le 25-09-2003 à 08:45:39  profilanswer
 

burgergold a écrit :


 
ouais mais la machine bootera pas plus  :D  


 :pt1cable:  
 
Plus serieusement verifie juste une chose ( et je suis presque sur que ca viens de la ) que ta pas uen carte pci qui deconne ( voir deplace en une ) si ca le fait toujours verifie tes fils de boitier certaine carte mere bip lorsqu un fil est pas au bon endroit !!


---------------
Quelque fois il vaut mieux se taire et passer pour un con plutot que de l ouvrir et de le confirmer.
n°330130
bugsan
Posté le 25-09-2003 à 09:31:42  profilanswer
 

Si ca peut t'aider, mon grub plantait juste apres que j'ai mis à jour le bios de ma carte mere :)
j'ai été dans le bios, j'ai fais un save & quit, et j'ai éteind le pc. apres ca marchait...
 
Nan je ne vois qu'une chose c'est que ton grub soit mal installé :/ tu as voulu réinstaller derriere, tu as peut etre oublié de le réinstaller avec lors de l'install. Ou tu t'es trompé de DD pour le bootloader. Oublie pas que le stage1 de grub (qui est situé sur le masterboot) va chercher le stage2 dans /boot/grub/stage2, si celui a bougé de secteur (par exemple écrasé par la nouvelle install de red hat) ben il ne le trouvera plus... => bloqué
 
les commandes que je t'ai filé permettent de réinstaller le stage1 avec les bons parametres du stage2. voila

n°330183
burgergold
5$? va chez l'diable!
Posté le 25-09-2003 à 11:41:52  profilanswer
 

MemphisRaines187 a écrit :


 :pt1cable:  
 
Plus serieusement verifie juste une chose ( et je suis presque sur que ca viens de la ) que ta pas uen carte pci qui deconne ( voir deplace en une ) si ca le fait toujours verifie tes fils de boitier certaine carte mere bip lorsqu un fil est pas au bon endroit !!


 
2 carte pci, réseau et video bien placé
 
pour les fils, bin c'est pas la carte mere qui beep justement, windows boot a merveille, jai meme pu installé redhat, c'est grub qui beep :D


---------------
http://www.boincstats.com/signature/user_664861.gif
n°331296
burgergold
5$? va chez l'diable!
Posté le 27-09-2003 à 13:58:39  profilanswer
 

bon up à ce topic car jdois régler ca ce weekend
 
donc redhat 8.0 installé avec grub
 
le pc boot, grub en haut à gauche et le pc speaker qui sonne
 
pourtant jai suivi la meme procédure d'installation de redhat que sur mon autre machine (p1 166)
 
plug and play OS désactivé dans le bios
 
par contre, jai quelques emmerde avec ce pc: la cm ne détecte plus les cd-rom. J'en ait tenté 3 qui fonctionne mais jamais reconnu sur la cm, alors que les dd sont reconnu
 
ca pourrait venir de la?


---------------
http://www.boincstats.com/signature/user_664861.gif
n°331380
MemphisRai​nes187
Mon eleanor - Je t aurais :)
Posté le 27-09-2003 à 17:41:45  profilanswer
 

burgergold a écrit :

bon up à ce topic car jdois régler ca ce weekend
 
donc redhat 8.0 installé avec grub
 
le pc boot, grub en haut à gauche et le pc speaker qui sonne
 
pourtant jai suivi la meme procédure d'installation de redhat que sur mon autre machine (p1 166)
 
plug and play OS désactivé dans le bios
 
par contre, jai quelques emmerde avec ce pc: la cm ne détecte plus les cd-rom. J'en ait tenté 3 qui fonctionne mais jamais reconnu sur la cm, alors que les dd sont reconnu
 
ca pourrait venir de la?


 
 
Ba tu sais quoi verifie si ta pas une pate sur tes port ide qui s est barrer ... si ca se trouve ca sort de ca !!


---------------
Quelque fois il vaut mieux se taire et passer pour un con plutot que de l ouvrir et de le confirmer.
mood
Publicité
Posté le   profilanswer
 


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  Grub et plein de beep au boot

 

Sujets relatifs
pb dual boot sur mandrake 9.1intéret de faire une partition pour /boot ?
aide sur lilo de linux pour multi bootlancer un script au boot
[Gentoo] [Grub] Pb au boot [Résolu]plein ecran avec mplayer
Installer Windows derrière Linux (pour double-boot)[MDK 9.1] plantée au premier boot -> resolu
Linux et windows xp pro boot 
Plus de sujets relatifs à : Grub et plein de beep au boot


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR