Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
2203 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  Google Earth et carte Nvidia

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Google Earth et carte Nvidia

n°949004
thierryR
J'aime les bretzels
Posté le 01-09-2007 à 22:55:37  profilanswer
 

Bonjour..
Google Earth ne veut plus démarrer depuis que je fonctionne avec le driver nvidia de chez nvidia. Bien sur on y trouve un lien mais ça conduit à d'éventuelles solutions win sans importance. Par contre je ne sais pas comment remèdier au problème avec linux....
Si quelqu'un à eu ce tour......
Merci. :jap:


---------------
Penguin online qui ne fait que des conneries, et qui aime ça. Membre du http://www.fonacon.net/
mood
Publicité
Posté le 01-09-2007 à 22:55:37  profilanswer
 

n°949006
LoninoL
Posté le 01-09-2007 à 23:05:43  profilanswer
 

thierryR a écrit :

Bonjour..
Google Earth ne veut plus démarrer depuis que je fonctionne avec le driver nvidia de chez nvidia. Bien sur on y trouve un lien mais ça conduit à d'éventuelles solutions win sans importance. Par contre je ne sais pas comment remèdier au problème avec linux....
Si quelqu'un à eu ce tour......
Merci. :jap:


Bonjour,
 
C'est étrange, en tout cas ça doit pouvoir fonctionner. Est-ce que tu peux nous en dire un peu plus sur le probléme, les messages d'erreurs éventuels...

n°949007
thierryR
J'aime les bretzels
Posté le 01-09-2007 à 23:19:27  profilanswer
 

Le message n'est pas compliqué. Avant l'instal du soft, une fenetre dit:

Complèter la connexion si elle apparait au premier plan
Google Earth n'a pas pu identifier votre carte graphique. Le pilote correspondant n'a probablement pas été installé. Vous pouvez continuer.......


Et en continuant on a une belle fenetre noir au lieu de l'appli.


---------------
Penguin online qui ne fait que des conneries, et qui aime ça. Membre du http://www.fonacon.net/
n°949008
Zzozo
Modérateur
Un peu, passionément, à la fol
Posté le 01-09-2007 à 23:26:36  profilanswer
 

thierryR a écrit :

Le message n'est pas compliqué. Avant l'instal du soft, une fenetre dit:

Complèter la connexion si elle apparait au premier plan
Google Earth n'a pas pu identifier votre carte graphique. Le pilote correspondant n'a probablement pas été installé. Vous pouvez continuer.......


Et en continuant on a une belle fenetre noir au lieu de l'appli.


Un glxinfo | grep -i vendor donne quoi ?
 
C'est quoi ta cg exactement ?


---------------
« Ce qui ne vous tue pas vous rend plus fort » F. Nietzsche | « Vise_ la Lune. Si tu rates, au pire, t'es dans la merde » Un poète disparu dans le cercle
n°949010
thierryR
J'aime les bretzels
Posté le 01-09-2007 à 23:37:52  profilanswer
 

Ouh la la  je crois que tu as mis la main dessus.
glxinfo | grep -i vendor

Xlib:  extension "GLX" missing on display ":1.0".
Xlib:  extension "GLX" missing on display ":1.0".
Xlib:  extension "GLX" missing on display ":1.0".
Error: couldn't find RGB GLX visual
Xlib:  extension "GLX" missing on display ":1.0".
Xlib:  extension "GLX" missing on display ":1.0".


 
Ma cg est une NVidia NV18 [GeForce4 MX 4000]

Message cité 1 fois
Message édité par thierryR le 01-09-2007 à 23:40:12

---------------
Penguin online qui ne fait que des conneries, et qui aime ça. Membre du http://www.fonacon.net/
n°949013
LoninoL
Posté le 01-09-2007 à 23:51:30  profilanswer
 

thierryR a écrit :

Ouh la la  je crois que tu as mis la main dessus.
glxinfo | grep -i vendor

Xlib:  extension "GLX" missing on display ":1.0".
Xlib:  extension "GLX" missing on display ":1.0".
Xlib:  extension "GLX" missing on display ":1.0".
Error: couldn't find RGB GLX visual
Xlib:  extension "GLX" missing on display ":1.0".
Xlib:  extension "GLX" missing on display ":1.0".


 
Ma cg est une NVidia NV18 [GeForce4 MX 4000]


 
Voilà le problème, glx n'est pas chargé. Il faut ajouter  

Load       "glx"


dans la section Module du fichier de configuration de xorg (/etc/X11/xorg.conf).
 
 

n°949015
thierryR
J'aime les bretzels
Posté le 02-09-2007 à 00:05:49  profilanswer
 

Voici un extrai de mon fichier:

Section "Module"
    Load "dbe" # Double-Buffering Extension
    Load "v4l" # Video for Linux
    Load "extmod"
    Load "type1"
    Load "freetype"
    Load "glx" # 3D layer
EndSection


Je précise que je n'ai touché à rien, mais visiblement c'est déja inscrit.


---------------
Penguin online qui ne fait que des conneries, et qui aime ça. Membre du http://www.fonacon.net/
n°949057
LoninoL
Posté le 02-09-2007 à 13:39:55  profilanswer
 

Effectivement, le fichier de conf est correct.
Est-ce qu'il y a des messages d'erreurs dans le fichier de log de xorg (/var/log/Xorg.0.log).
Quelle distribution utilises-tu ?
Pour vérifier que glx est bien installé, on peut plus simplement utiliser la commande glxinfo.
Avec nvidia-settings il y a aussi pas mal d'infos sur la configuration dont glx.

n°949062
thierryR
J'aime les bretzels
Posté le 02-09-2007 à 14:11:24  profilanswer
 

Dans un 1er temps voici ce que m'a donné la commande nvidia-settings dans une console:


nvidia-settings
 
ERROR: NV-CONTROL extension not found on this Display.
 
 
ERROR: Unable to determine number of NVIDIA GPUs on ':1.0'.
 
 
ERROR: Unable to determine number of NVIDIA Frame Lock Devices
       on ':1.0'.
 
 
ERROR: Unable to determine number of NVIDIA VCSCs on ':1.0'.
 
Fontconfig warning: "~/.fonts.conf", line 10: invalid constant used : full
Fontconfig warning: "~/.fonts.conf", line 18: invalid constant used : full

Message cité 1 fois
Message édité par thierryR le 02-09-2007 à 14:24:59

---------------
Penguin online qui ne fait que des conneries, et qui aime ça. Membre du http://www.fonacon.net/
n°949065
Zzozo
Modérateur
Un peu, passionément, à la fol
Posté le 02-09-2007 à 14:40:40  profilanswer
 

AMHA, tu as du avoir une couille lors de l'installation des drivers proprios Nvidia.
Je sais que ça arrive, et qu'il foire complètement l'install de toute la partie OpenGL (il installe pas/pas correctement les DLL liées, notamment)
 
Quelle distrib utilises tu et comment as tu installé ces drivers (quelle version de ceux ci ? ) ?


---------------
« Ce qui ne vous tue pas vous rend plus fort » F. Nietzsche | « Vise_ la Lune. Si tu rates, au pire, t'es dans la merde » Un poète disparu dans le cercle
mood
Publicité
Posté le 02-09-2007 à 14:40:40  profilanswer
 

n°949070
thierryR
J'aime les bretzels
Posté le 02-09-2007 à 15:12:49  profilanswer
 

ce n'est pas compliqué: j'ai une mandriva 2007.1
J'ai installé les RPM tout bètement. Ceux-ci font la compil du kernel et voila tout.....


---------------
Penguin online qui ne fait que des conneries, et qui aime ça. Membre du http://www.fonacon.net/
n°949080
Zzozo
Modérateur
Un peu, passionément, à la fol
Posté le 02-09-2007 à 16:14:15  profilanswer
 

Nvidia propose deux séries de drivers proprios pour ses cartes graphiques :
- Les "normaux", qui supportent les cg à partir du GeForce FX (les séries 5xxx en gros quoi) jusqu'au derniers gpus sortis
- Les "legacy" pour tous les gpus "plus vieux", cad jusqu'à la série GeForce 4xx, et notamment ton GeForce 4 MX
 
Comment Mandrake gère t'il celà ?  Es tu sur que c'est bien la bonne version qui est installée (la dernière version pour les "legacy" est de la série 1.0-9639, en archi 32 bits) ?
 
sources : ici et
 
EDIT : A tout hasard, les RPMs en question contiennent bien aussi la partie "GLX" du driver Nvidia (pas juste le module pour le noyau) ?
 
EDIT2 : Un peu le bordel la numérotation pour les legacy ...


Message édité par Zzozo le 02-09-2007 à 16:26:47

---------------
« Ce qui ne vous tue pas vous rend plus fort » F. Nietzsche | « Vise_ la Lune. Si tu rates, au pire, t'es dans la merde » Un poète disparu dans le cercle
n°949082
Riot
Buy me a riot
Posté le 02-09-2007 à 16:20:48  profilanswer
 

thierryR a écrit :

Dans un 1er temps voici ce que m'a donné la commande nvidia-settings dans une console:


nvidia-settings
 
ERROR: NV-CONTROL extension not found on this Display.
 
 
ERROR: Unable to determine number of NVIDIA GPUs on ':1.0'.
 
 
ERROR: Unable to determine number of NVIDIA Frame Lock Devices
       on ':1.0'.
 
 
ERROR: Unable to determine number of NVIDIA VCSCs on ':1.0'.
 
Fontconfig warning: "~/.fonts.conf", line 10: invalid constant used : full
Fontconfig warning: "~/.fonts.conf", line 18: invalid constant used : full



Pourquoi parle-t-il du DISPLAY :1.0 ?


---------------
Be the one with the flames.
n°949083
Zzozo
Modérateur
Un peu, passionément, à la fol
Posté le 02-09-2007 à 16:24:44  profilanswer
 

Riot a écrit :


Pourquoi parle-t-il du DISPLAY :1.0 ?


ha oui   bonne question ...


---------------
« Ce qui ne vous tue pas vous rend plus fort » F. Nietzsche | « Vise_ la Lune. Si tu rates, au pire, t'es dans la merde » Un poète disparu dans le cercle
n°949086
thierryR
J'aime les bretzels
Posté le 02-09-2007 à 17:09:47  profilanswer
 

Je pense que ça peut être du au fait que j'ouvre dans une console et que l'appli s'est ouverte en mode graphique en dehors de ma console..


Message édité par thierryR le 02-09-2007 à 17:11:10

---------------
Penguin online qui ne fait que des conneries, et qui aime ça. Membre du http://www.fonacon.net/
n°949088
Riot
Buy me a riot
Posté le 02-09-2007 à 17:30:45  profilanswer
 

Non, aucun rapport.
 
Tu as XGl par hasard ?


---------------
Be the one with the flames.
n°949090
mikala
Souviens toi du 5 Novembre...
Posté le 02-09-2007 à 17:46:43  profilanswer
 

a mon humble avis il a du activé xgl, un DISPLAY=:0 googleearth en ligne de commande devrait permettre une fonctionnement correct ;)


---------------
Intermittent du GNU
n°949091
thierryR
J'aime les bretzels
Posté le 02-09-2007 à 17:54:21  profilanswer
 

Hmm..... Il faut m'excuser de mon peu de compétence.
Riot: Comment verifie t-on XGI ?
mikala: un DISPLAY=:0 googleearth en ligne de commande  à mettre où ?


---------------
Penguin online qui ne fait que des conneries, et qui aime ça. Membre du http://www.fonacon.net/
n°949111
thierryR
J'aime les bretzels
Posté le 02-09-2007 à 19:48:52  profilanswer
 

J'ai trouvé:
J'ai supprimer l'effet 3D


---------------
Penguin online qui ne fait que des conneries, et qui aime ça. Membre du http://www.fonacon.net/
n°949112
mikala
Souviens toi du 5 Novembre...
Posté le 02-09-2007 à 19:55:17  profilanswer
 

thierryR a écrit :

Hmm..... Il faut m'excuser de mon peu de compétence.
Riot: Comment verifie t-on XGI ?
mikala: un DISPLAY=:0 googleearth en ligne de commande  à mettre où ?


soit tu désires garder les effets 3D et tu édites le menu pour modifier la ligne de lancement comme j'ai indiqué
soit tu supprimes l'effet 3D et tu n'as rien a modifié ( c'est le second choix que tu as fais).


---------------
Intermittent du GNU
n°949127
thierryR
J'aime les bretzels
Posté le 02-09-2007 à 21:52:47  profilanswer
 

en fait; je n'ai pas le cube, mais j'ai encore le reste.
Donc le compromis me semblant correct, je reste comme ça.
Merci à tous.


---------------
Penguin online qui ne fait que des conneries, et qui aime ça. Membre du http://www.fonacon.net/
mood
Publicité
Posté le   profilanswer
 


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  Google Earth et carte Nvidia

 

Sujets relatifs
quel carte Tv turner pour ordi sous Linux ??Installation carte rseéau sous Linux Red Hat
XORG: carte/chipset disposant du meilleur supportXorg et NVidia TwinView Mode Clone
Probleme installation Nvidia driverCarte réseau super lente
Nvidia: freeze temporaire lors du scrolling (firefox, konqueror, ...)carte pci wifi hercules HWGPCI-54 et ubuntu
pilotes NVidia GeForce 7950 GT pour Mandriva free edition 2007Debian etch - GDM - nvidia - Beryl
Plus de sujets relatifs à : Google Earth et carte Nvidia


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR