Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
1232 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Hardware

  Problème reconnaissance boîtier externe scanlogic USBIDE SL11R

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Problème reconnaissance boîtier externe scanlogic USBIDE SL11R

n°566469
toly
Posté le 05-10-2004 à 10:41:03  profilanswer
 

Bonjour, j'utilise un systeme linux mandrake.
Mon problème est le suivant :
Avec l'ancien noyau de la Mandrake 9.2 ( Kernel 2.4.22-10 ), mon boîtier externe USB-IDE était parfaitement reconnu dès l'installation.
J'ai mis à jour vers Mandrake 10.0 et là, mon boîtier externe n'est plus reconnu par le système.
 
Les ref de mon boîtier sont : Scanlogic macpower IDE2USB SL11R
Il est piloté par le module usb-storage et mon disque IDE qui est à l'intérieur du boîtier est /dev/sda ( émulation SCSI ? )
Avec Le noyau 2.6.3-4 de Mandrake 10, /dev/sda n'existe pas, cat /proc/bus/USB/devices ne fait pas référence au boîtier externe.
 
Quelqu'un a-t'il déjà eu ce problème?
Quelle est la solution ?
Je peux vous fournir à la demande toute info de mon systeme ( cat /proc... ).
Merci d'avance.

mood
Publicité
Posté le 05-10-2004 à 10:41:03  profilanswer
 

n°566477
arghbis
salops de dauphins
Posté le 05-10-2004 à 10:59:03  profilanswer
 

usb-storage est chargé? les bons modules sont chargés?

n°566969
toly
Posté le 05-10-2004 à 21:29:18  profilanswer
 

Merci Arghbis de prendre le temps de m'aider.
Oui, usb-storage est chargé, les OHCI et UHCI aussi !!
La config est la même sous kernel 2.4.22-10 que sous kernel 2.6.3-4 ( dual boot ) sauf que les chemins des modules sont relatifs aux kernels.
Peut-être sont-ce les modules du kernel 2.6 qui ne reconnaissent pas bien mon matériel ?
Je crois savoir que l'émulation SCSI a changé depuis la version 2.6, est-ce là que se trouve la cause ?
Voici mon cat /proc/scsi/usb-storage
[root@portable root]# cat /proc/scsi/usb-storage/0
   Host scsi0: usb-storage
       Vendor: MacPower  USBIDE
      Product: MacPower  USBIDE
Serial Number: None
     Protocol: Transparent SCSI
    Transport: Bulk
       Quirks:
 
Et voici un extrait de mon lsmod :
usb-storage            63136  0
scsi_mod              114744  2 sg,usb-storage
usblp                  12256  0
uhci-hcd               29104  0
ehci-hcd               24196  0
ohci-hcd               18692  0
usbcore                99132  13 pwc,pl2303,usbserial,usbkbd,usbmouse,hid,usb-storage,usblp,uhci-hcd,ehci-hcd,ohci-hcd
 
Merci de ton aide

n°567130
arghbis
salops de dauphins
Posté le 06-10-2004 à 09:56:28  profilanswer
 

fais péter ton fstab (/etc/fstab) et regardes si tu as un périphérique /dev/sda1 ou sdb (etc...) et essaye de le monter à la main

n°569442
toly
Posté le 10-10-2004 à 00:55:24  profilanswer
 

Dans /etc/fstab, il n'y a de référence à aucun périphérique sd* et mount /dev/sda1 me donne un message d'erreur " impossible de trouver /dev/sda dans fstab".
Je te redis que mon périph est bien reconnu par le noyau 2.4.22-10 ( dès le démarrage, un message " sda was added" me l'indique et je peux y accéder ensuite en Read et Write) tandis que rien ne marche avec le noyau 2.6.3-4 ( aucun message de démarrage lors de la recherche automatique de périphériques, pas de référence dans /proc/devices, hardrake2 ne le voit plus ....)
Pourquoi y a-t-il une différence entre 2.4 et 2.6 ?
Je crois savoir que le noyau 2.6 ne gère plus l'émulation SCSI de la même façon que 2.4. Est-ce la raison ?
J'ai déjà recompilé mon noyau 2.6.3-4 sans succes malgré les mêmes options que mon noyau 2.4.22-10.
Comment configurer mon 2.6 pour qu'il reconnaisse le périph ?( paramètre de boot, module configuré, patch ...) ?
Comment configurer 2.6 pour qu'il reconnaisse mon périph ?

n°570049
arghbis
salops de dauphins
Posté le 11-10-2004 à 10:12:22  profilanswer
 

toly a écrit :


Pourquoi y a-t-il une différence entre 2.4 et 2.6 ?
 
beaucoup de choses ont changé entre les deux
 
Je crois savoir que le noyau 2.6 ne gère plus l'émulation SCSI de la même façon que 2.4. Est-ce la raison ?
 
non
 
Comment configurer mon 2.6 pour qu'il reconnaisse le périph ?( paramètre de boot, module configuré, patch ...) ?
 
il faut voir si tu utilises udev ou devfs en mandrake 10. EN 9.2, je suis pratiquement sûr que c'est devfs, en 10, je sais pas trop. LA mise à jour (au lieu d'une nouvelle installation) peut avoir causé ce problème


 
tu as un utilitaire qui s'appelle lsusb (ou usbview en graphique). Regardes s'il ne te donne pas d'infos utiles. Regarde aussi dans harddrake


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Hardware

  Problème reconnaissance boîtier externe scanlogic USBIDE SL11R

 

Sujets relatifs
Probleme spdif[debian] Problème DNS
Probleme avec exprProbleme internet
probleme pour lire des vidéos sous firefox[Mandrake] Install ok, Mais problème démarrage !
Probleme de police sur mandrakeproblème réseau avec samba serveur
problème graphique sur mandrakeprobleme de francisation de enlightenment
Plus de sujets relatifs à : Problème reconnaissance boîtier externe scanlogic USBIDE SL11R


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR