Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1838 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Codes et scripts

  Problème SQUID et DNS

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Problème SQUID et DNS

n°156315
SwiTDUDE
Posté le 13-09-2002 à 12:55:53  profilanswer
 

J'ai un petit problème avec SQUID, je m'explique :
 - Structure de mon réseau :
Internet---Routeur1---Réseau1(192.168.0.0)---Routeur2---Réseau2(192.168.1.0)
 - Serveur DNS-cache sur le routeur2 qui forward vers le serveur DNS de mon prestataire d'accès
 - SQUID sur le routeur2
 - Routeur1 laisse passer toutes les connections (entrantes comme sortantes) et masquerade les réseaux 1 et 2
 - Routeur2 lie les réseaux 1 et 2 et préroute tous ce qui vient de Réseaux2:80 vers lui-même sur le port 3128
 
SEULEUMENT CA NE MARCHE PAS !!!!
 
Il semblerait que SQUID n'arrive pas à utiliser le server DNS -cache...
 
A votre bon coeur Messieurs Dames ...


Message édité par SwiTDUDE le 13-09-2002 à 13:05:47
mood
Publicité
Posté le 13-09-2002 à 12:55:53  profilanswer
 

n°156362
Buchu
Posté le 13-09-2002 à 15:17:58  profilanswer
 

Que se passe t'il quand tu fais une requette sur ton proxy du type host www.hardware.fr ip_routeur2 ?


Message édité par Buchu le 13-09-2002 à 15:18:32
n°156367
SwiTDUDE
Posté le 13-09-2002 à 15:25:57  profilanswer
 

Il me donne l'adresse IP de harware.fr.
Je donne à titre indicatif mon squid.conf :
 
http_port 3128
hierarchy_stoplist cgi-bin ?
acl QUERY urlpath_regex cgi-bin \?
acl all src 0.0.0.0/0.0.0.0
acl manager proto cache_object
acl reseau src 192.168.0.0/255.255.255.0
acl localhost src 127.0.0.1/255.255.255.255
acl Safe_ports port 80  # http
acl purge method PURGE
acl CONNECT method CONNECT
http_access allow manager localhost
http_access deny manager
http_access allow purge localhost
http_access deny purge
http_access deny !Safe_ports
http_access allow localhost
http_access allow reseau
http_access deny all
icp_access allow all

n°156372
Buchu
Posté le 13-09-2002 à 15:40:43  profilanswer
 


dans squid.con tu peux directement lui spécifier un dns avec
 
dns_nameservers ip_du_dns

n°156377
SwiTDUDE
Posté le 13-09-2002 à 15:51:43  profilanswer
 

ça marche toujours pas...
voila mon script iptables pour le routeur2 :
 
#!/bin/sh
echo 1 > /proc/sys/net/ipv4/ip_forward
iptables -t nat -F
iptables -t nat -X
iptables -F
iptables -X
iptables -P INPUT ACCEPT
iptables -P OUTPUT ACCEPT
iptables -P FORWARD ACCEPT
iptables -t nat -A PREROUTING -i eth0 -p tcp --dport 80 -j DNAT --to-destination 192.168.1.1:3128
 
-> couldn't retrieve URL

n°156380
Mjules
Modérateur
Parle dans le vide
Posté le 13-09-2002 à 15:57:36  profilanswer
 

t'es sur que c'est dport 80 et pas sport 80 ?


---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°156392
SwiTDUDE
Posté le 13-09-2002 à 16:11:33  profilanswer
 

Je pense que le problème ne vient pas d'iptables  puisque j'accède à SQUID -> il me répond : invalid URL.
 
De plus je peux y accéder en configurant directement mon navigateur -> même réponse, sauf sur le routeur !!!
 
Je ne sais plus quoi faire  ...

n°156462
aurelboiss
Posté le 13-09-2002 à 18:58:23  profilanswer
 

essaye plutot cette commande dans iptables:
 
iptables -t nat -A PREROUTING -i eth0 -p tcp --dport 80  
        -j REDIRECT --to-port 3128


Message édité par aurelboiss le 13-09-2002 à 18:58:51
n°156477
SwiTDUDE
Posté le 13-09-2002 à 19:12:52  profilanswer
 

Toujours rien ...
 
A propos, quand le fichier resolv.conf est-il lu ??

n°156542
el_loco
Plus on de fous plus on ri
Posté le 13-09-2002 à 20:45:05  profilanswer
 

Lance squid avec les options qui te permette de voir ce qu'il fait dans la console je crois que c -D ou un truc comme ca ou regarde ton cache.log pour voir s'il trouve bien les dns.

mood
Publicité
Posté le 13-09-2002 à 20:45:05  profilanswer
 

n°156551
SwiTDUDE
Posté le 13-09-2002 à 21:02:58  profilanswer
 

Je viens de faire passer SQUID sur le Routeur1.
 
Résultat de cache.log :
 
Navigateur>proxy sur le routeur1:3128>pas de problème
 
Navigateur>iptables>pas de DNS
 
je ne comprend rien du tout !!!
 
[edit]Pour simplifier les choses, je n'ai plus de DNS-cache sur Routeur2, tout pointe directement vers le serveur DNS de wanadoo.


Message édité par SwiTDUDE le 13-09-2002 à 21:10:19

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Codes et scripts

  Problème SQUID et DNS

 

Sujets relatifs
p'tit probleme avec dhcpdMandrake SNF probleme de gateway thks
[slackware 8.1] probleme Qt[PengAol] Probleme de connection
[Mdk] Probleme de gravageProblème avec Clavier USB :(
problème de zip usb sur mdk8.2 [résolu]Probleme d'install de mon modem speedtouch usb...
[Kernel] probleme a la compil (modules)Probleme lors d un make : /usr/bin/ld: cannot find -lsasl
Plus de sujets relatifs à : Problème SQUID et DNS


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR