Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1532 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Codes et scripts

  Problème de caractère

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Problème de caractère

n°851189
coolben
http://www.starbusiness.fr
Posté le 13-10-2006 à 13:01:45  profilanswer
 

Bonjour
 
J'ai remarqué que lorsque j'édite un fichier html sous linux les accents et autres caracteres spéciaux sont remplacés par de mauvais caractères (illisible) après être parsé par Apache.
Bizarement lorsque le fichier est edité sous Windaube, ces caracteres resortent bien.  
 
Y a t il une otpion d'encodage ?
Avez vous déjà eu ce problème et si oui comment le corriger ?
 
merci de votre aide

mood
Publicité
Posté le 13-10-2006 à 13:01:45  profilanswer
 

n°851226
thierryR
J'aime les bretzels
Posté le 13-10-2006 à 14:12:50  profilanswer
 

Il y a bien une option tu es sous quel bureau et avec quel navigateur.


Message édité par thierryR le 13-10-2006 à 14:14:00

---------------
Penguin online qui ne fait que des conneries, et qui aime ça. Membre du http://www.fonacon.net/
n°851232
coolben
http://www.starbusiness.fr
Posté le 13-10-2006 à 14:17:17  profilanswer
 

Je suis sous gnome et mon navigateur est firefox.
Je ne comprend pas bien le rapport avec le navigateur ?

n°851237
Dark_Schne​ider
Close the World, Open the Net
Posté le 13-10-2006 à 14:20:32  profilanswer
 

utilises le codepage/l'encodage de caractère iso8859-1 ou iso8859-15 dans ton éditeur de texte sous Linux.
 
À mon avis il édite ton texte par défaut en UTF8.


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°851252
thierryR
J'aime les bretzels
Posté le 13-10-2006 à 14:54:43  profilanswer
 

coolben a écrit :

firefox.
Je ne comprend pas bien le rapport avec le navigateur ?


parce que j'ai le même problème. Firefox me donne des caractères utf8 sur certains sites comme celui-ci.
http://abs.traduc.org/abs-3.5-fr/index.html
J'ai pas encore trouvé le paramètre.


---------------
Penguin online qui ne fait que des conneries, et qui aime ça. Membre du http://www.fonacon.net/
n°851262
Dark_Schne​ider
Close the World, Open the Net
Posté le 13-10-2006 à 15:14:43  profilanswer
 

moi je n'ai pas de problème sur ce site, mais en même temps mon système n'est pas en UTF8.
 
Mon firefox est conf sur Occiendatl ( iso8859-1 ) : Affichage -> Encodage des caractères -> Occidental


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°851265
thierryR
J'aime les bretzels
Posté le 13-10-2006 à 15:19:23  profilanswer
 

Merci de l'info j'ai dépanné mon site. En fait j'étais comme toi, mais en ouvrant l'URL le codage a changé.  J'ai l'impression qu'il s'adapte à ce qu'il trouve en gardant un historique.


---------------
Penguin online qui ne fait que des conneries, et qui aime ça. Membre du http://www.fonacon.net/
n°851270
Mjules
Modérateur
Parle dans le vide
Posté le 13-10-2006 à 15:32:37  profilanswer
 

thierryR > il semble que le site ne précise pas l'encodage de ses pages, ni dans les entêtes serveurs ni sur la page elle même (spabien du tout d'ailleurs), donc il utilise l'encodage par défaut de FF, si c'est utf8 chez toi, il sort utf8. Pour ma part, vu que la majorité de ce type de page est faite par des windowsien, j'ai collé windows-1252 comme encodage par défaut et ça se passe pas trop mal.


Message édité par Mjules le 04-11-2006 à 19:44:26

---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°851282
thierryR
J'aime les bretzels
Posté le 13-10-2006 à 15:57:21  profilanswer
 

Salut Mjules Pour l'histoire comme je suis avec firefox que je viens de réparer, j'ai constaté que je suis en ISO 8859-1 si je prends le site sité, j'étais en UTH8 je l'ai remis en ISO 8859-15 J'ai fermé firefox, l'ai ré-ouvert, suis retourné sur le site et constate que mes modifs sont enregistrées. ISO 8859-15 alors que sur ce forum, je suis toujours en ISO 8859-1. :whistle:


---------------
Penguin online qui ne fait que des conneries, et qui aime ça. Membre du http://www.fonacon.net/
n°851288
Mjules
Modérateur
Parle dans le vide
Posté le 13-10-2006 à 16:05:11  profilanswer
 

normal, le forum déclare son encodage


---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
mood
Publicité
Posté le 13-10-2006 à 16:05:11  profilanswer
 

n°851291
thierryR
J'aime les bretzels
Posté le 13-10-2006 à 16:10:11  profilanswer
 

Mjules a écrit :

normal, le forum déclare son encodage


J'en était sur :D


---------------
Penguin online qui ne fait que des conneries, et qui aime ça. Membre du http://www.fonacon.net/
n°859078
coolben
http://www.starbusiness.fr
Posté le 04-11-2006 à 11:50:41  profilanswer
 

Comment on declare on encodage ?
c'est sur les page web ou dans le serveur ?

n°859096
mirtouf
Light is right !
Posté le 04-11-2006 à 13:26:47  profilanswer
 

Code :
  1. <head><title>Problème de caractère....</title><meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1" />


Message édité par mirtouf le 04-11-2006 à 13:27:07

---------------
-~- Libérez Datoune ! -~- Camarade, toi aussi rejoins le FLD pour que la flamme de la Révolution ne s'éteigne pas ! -~- A VENDRE
n°859160
coolben
http://www.starbusiness.fr
Posté le 04-11-2006 à 15:40:26  profilanswer
 

je ne comprend pas meme en ajoutant cette ligne, cela ne change rien mes pas sont par défaut en UTF-8 lorsque je suis sur mon site et pourtant les préférence de FF sont a ISO-8859-1
 
Qu'esc qui cloche ?

n°859246
Mjules
Modérateur
Parle dans le vide
Posté le 04-11-2006 à 19:44:04  profilanswer
 

vérifie que le serveur n'envoie pas l'encodage de ta page dans les entête http :

[jules@tue-amour ~]$ lynx -dump -head http://www.airpur-industries.com
HTTP/1.1 200 OK
Date: Sat, 04 Nov 2006 18:43:32 GMT
Server: Apache
Connection: close
Content-Type: text/html; charset=iso-8859-15
Content-Language: fr



---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°859252
Mjules
Modérateur
Parle dans le vide
Posté le 04-11-2006 à 20:12:57  profilanswer
 

coolben a écrit :

Comment on declare on encodage ?
c'est sur les page web ou dans le serveur ?


l'un ou l'autre


---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°859359
coolben
http://www.starbusiness.fr
Posté le 05-11-2006 à 10:22:44  profilanswer
 

je ne comprend pas  :

Code :
  1. coolben@sempron-coolben:~$ lynx -dump -head http://localhost/~coolben/star_busin ess
  2. HTTP/1.1 301 Moved Permanently
  3. Date: Sun, 05 Nov 2006 00:40:24 GMT
  4. Server: Apache/2.2.3 (Debian) PHP/5.1.6-5 mod_perl/2.0.2 Perl/v5.8.8
  5. Location: http://localhost/~coolben/star_business/
  6. Connection: close
  7. Content-Type: text/html; charset=iso-8859-1
  8. X-Pad: avoid browser bug
  9. coolben@sempron-coolben:~$ lynx -dump -head http://localhost/~coolben/star_busin ess/index.php
  10. HTTP/1.1 200 OK
  11. Date: Sun, 05 Nov 2006 09:17:02 GMT
  12. Server: Apache/2.2.3 (Debian) PHP/5.1.6-5 mod_perl/2.0.2 Perl/v5.8.8
  13. X-Powered-By: PHP/5.1.6-5
  14. Set-Cookie: PHPSESSID=667c899be5af1760550723c6addc78f6; path=/
  15. Expires: Thu, 19 Nov 1981 08:52:00 GMT
  16. Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
  17. Pragma: no-cache
  18. Connection: close
  19. Content-Type: text/html; charset=UTF-8


mon serveur renvois bien du code ISO-8859-1 pour le repertoire mais UTF-8 pour l'index ?
Hors dans l'inde, y a cette ligne :

Code :
  1. <html>
  2. <head>
  3. <meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1">
  4. <META NAME="ROBOTS" CONTENT="index,follow">
  5. <title>Star Business</title>
  6. <link rel="stylesheet" href="style.css" type="text/css">
  7. </head>
  8. <body>


d'ou peux venir le probleme alors ?
Es ce que cela peux venir du fait que des données qui sont affichées proviennent d'une base mysql contenant des caracteres en UTF8-1 ?

Message cité 1 fois
Message édité par coolben le 05-11-2006 à 10:25:53
n°859702
Dark_Schne​ider
Close the World, Open the Net
Posté le 06-11-2006 à 01:34:12  profilanswer
 

on peut aussi définir l'encodage dans le php.ini :)
 

Citation :


[root@info1 ~]# grep charset /etc/php.ini
; the Content-type: header.  To disable sending of the charset, simply
default_charset = "iso-8859-15"


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°859717
coolben
http://www.starbusiness.fr
Posté le 06-11-2006 à 07:30:58  profilanswer
 

C'est bon du cote de php.ini
 

Code :
  1. sempron-coolben:/usr/share# grep charset /etc/php5/apache2/php.ini
  2. ; the Content-type: header.  To disable sending of the charset, simply
  3. ;default_charset = "iso-8859-1"
  4. ; If empty or not set the client charset from freetds.comf is used
  5. ;mssql.charset = "ISO-8859-1"
  6. sempron-coolben:/usr/share#


n°860008
Dark_Schne​ider
Close the World, Open the Net
Posté le 06-11-2006 à 16:58:07  profilanswer
 

faux, ton option est mis en commentaire ( ;default_charset ), donc non utilisée. Je soupçonne alors php de se baser sur les locales du système, et comme la plupart des distros sont en UTF8, php balance en UTF8


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°861074
imarune
Posté le 09-11-2006 à 00:50:54  profilanswer
 

coolben a écrit :


mon serveur renvois bien du code ISO-8859-1 pour le repertoire mais UTF-8 pour l'index ?


 
Peut-être sans rapport (et peut-être as-tu trouvé une solution), mais tu peux avoir le contenu des fichiers en utf8 et le nom des fichiers en iso-8859 (ou vice-versa) , ce qui expliquerait l'affichage bizarroïde pour les indexs (basés sur noms fichiers dans l'OS).
 
Cela m'est arrivé récemment en récupérant une vieille archive: obligé de passer par convmv pour m'en sortir...


Message édité par imarune le 09-11-2006 à 00:58:22
n°861210
Dark_Schne​ider
Close the World, Open the Net
Posté le 09-11-2006 à 14:10:09  profilanswer
 

c'est PHP qui envoie les données en UTF8


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°861734
coolben
http://www.starbusiness.fr
Posté le 10-11-2006 à 22:14:20  profilanswer
 

merci effectivement le probleme venaiT de PHP

mood
Publicité
Posté le   profilanswer
 


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Codes et scripts

  Problème de caractère

 

Sujets relatifs
Problème Wifi avec Ubuntu Live 6.06chtit probleme caractere openoffice
Problème de caractère (avec xmms entre autres)Problème de police de caractère ...
[emacs] probleme de suppression de caractere[Debian]Probleme de caractere en console[Résolu]
probleme de caractere particulier sur partition monté'tit problème de caractère accentué avec Mozilla...
Probleme de police de caractère sous KDE[xine] problème avec la police de caractère
Plus de sujets relatifs à : Problème de caractère


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR