Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
362 connectés 

  FORUM HardWare.fr
  Hardware
  Disque SSD

  SSD Plextor M5P - Formatage NTFS impossible car en mode RAW -Need help

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

SSD Plextor M5P - Formatage NTFS impossible car en mode RAW -Need help

n°9051635
syntaxx_er​ror
Posté le 11-02-2014 à 13:02:52  profilanswer
 

Hello,
 
Je rencontre un probleme récent avec mon SSD Plextor M5 Pro. J'ai commencé par avoir des plantages sous Windows 8 alors que tout marchait nickel. J'ai donc décidé de réinstaller une image disque histoire déradiquer tout probleme de virus éventuel. Sauf que c'est impossible puisque le M5P refuse tout formatage en NTFS, que ce soit avec le DVD d'install de Windows ou tout soft alternatif de gestion de disque. Le SSD est en mode RAW désormais. Impossible de s'en débarrasser. Ce qui est zarb est que seule la partition Windows systeme de 350mo arrive à être créée, le reste de l'espace disque reste en "non alloué" avec plantage au formatage NTFS. Je précise que le SDD est bien reconnu par le bios et Windows.
 
Pour avancer, j'ai donc utilisé le soft Plextool pour faire un diagnostique. Visiblement aucun probleme niveau write/read. CrystalDisk Info me dit aussi que tout est OK. En revanche le soft de flashage du M5P me dit qu'il y a plein d'erreurs dans la table de partition. Je soupçonne que c'est ça qui fout la merde. La MBR est peut etre elle aussi touchée. C'est peut etre lié à un virus. Mais le SSD a l'air physiquement OK.
 
Du coup j'ai téléchargé Avast "aswMBR" pour corriger tout mais le soft plante en plein milieu du scan :/
http://public.avast.com/~gmerek/aswMBR.htm
 
Questions :
- Y a-t-il des softs alternatifs pour corriger la MBR/Table de partition d'un SDD ?
- Le soft Plextool propose un "Secure format" (cf ci-dessous, juste à titre d'illustration, le résultats ne sont pas ceux de mon M5P). Est-ce la meilleure solution pour tout remettre en ordre et virer les éventuels virus ?
 
http://images.anandtech.com/doci/5851/Plextool1.PNG
 
Merci d'avance pour votre aide  :jap:


Message édité par syntaxx_error le 12-02-2014 à 14:58:16
mood
Publicité
Posté le 11-02-2014 à 13:02:52  profilanswer
 

n°9051647
kit-et-kat
Posté le 11-02-2014 à 13:20:44  profilanswer
 

Il a fallut que je relise, on te parle de table de partition et toi tu dérives sur la mbr. C'est pas la même chose.
 
Tu as pas de problème de mbr, qui sera de tout façon remis en ordre lors de l'installation de Windows. Tu as un problème avec le formatage visiblement, mais pourquoi ?
Tu fais toutes ces manip depuis le DVD d'installation ?
 
Tu peux installer ton ssd sur un autre ordi pour le partitionner et le formater ?

Message cité 1 fois
Message édité par kit-et-kat le 11-02-2014 à 13:45:41

---------------
Mon feed back: http://forum.hardware.fr/hfr/Achat [...] 6100_1.htm
n°9051690
syntaxx_er​ror
Posté le 11-02-2014 à 13:58:41  profilanswer
 

kit-et-kat a écrit :

Il a fallut que je relise, on te parle de table de partition et toi tu dérives sur la mbr. C'est pas la même chose.
 
Tu as pas de problème de mbr, qui sera de tout façon remis en ordre lors de l'installation de Windows. Tu as un problème avec le formatage visiblement, mais pourquoi ?
Tu fais toutes ces manip depuis le DVD d'installation ?
 
Tu peux installer ton ssd sur un autre ordi pour le partitionner et le formater ?

Meme probleme de formatage sur un autre ordi. Je pense que je vais tenter le "secure format" via plextool. On verra bien. Si le probleme persiste ça sera un RMA pour Plextor. Le bidule est garanti 5 ans, je vais pas me priver.


Message édité par syntaxx_error le 11-02-2014 à 14:00:06
n°9051719
kit-et-kat
Posté le 11-02-2014 à 14:17:13  profilanswer
 

J'aurais tenté un effacement de la table des partition avec diskpart, mais c'est un peu technique.


---------------
Mon feed back: http://forum.hardware.fr/hfr/Achat [...] 6100_1.htm
n°9051727
syntaxx_er​ror
Posté le 11-02-2014 à 14:24:23  profilanswer
 

kit-et-kat a écrit :

J'aurais tenté un effacement de la table des partition avec diskpart, mais c'est un peu technique.

Ah ok, bon à savoir, on sait jamais.

Message cité 1 fois
Message édité par syntaxx_error le 11-02-2014 à 14:28:40
n°9051756
kit-et-kat
Posté le 11-02-2014 à 14:45:51  profilanswer
 

syntaxx_error a écrit :

Ah ok, bon à savoir, on sait jamais.


le plus simple en mode administrateur sous Windows 8, pas utile sous Windows 7 (il me semble bien), depuis l'invite de commande tu lances diskpart puis tu tapes la commande /? pour obtenir la liste des commandes disponibles
De mémoire... tu utilises list pour lister les disques, les partions, les volumes, et select pour les sélectionner.
par exemple select disk 0 puis select partition 1 pour sélectionner la partition 1 du disque 0.
La commande qui nous intéresse c'est clean.
il faut au moins sélectionner le disque cible et pas se planter surtout de disque ;)
Possible que d'effacer les partitions une par une avant aide.
Avec cet utilitaire tu peux virer des partitions non Windows ce qui est pas possible depuis le gestionnaire de disque. C'est peut être ça qui créé le problème, une partition mal marquée suit à un problème.
 
Ou alors tu fais ça en lançant la console de récupération depuis le DVD d'installation ou d'un dvd de réparation, ton ssd étant le seul installé, comme ça pas de risque de faire des bêtises ;)


---------------
Mon feed back: http://forum.hardware.fr/hfr/Achat [...] 6100_1.htm
n°9052216
syntaxx_er​ror
Posté le 11-02-2014 à 20:49:46  profilanswer
 

bon, j'ai tout essayé. J'ai bien utilisé la commande "clean" sous diskpart. Ca a fonctionné. Idem pour le "Secure format" sous plextool mais toujours impossible de formater. Sous l'utilitaire de formatage win8.1 ça échoue également pour le formatage en NTFS. Seul le systeme de fichier RAW est appliqué. Je ne comprends vraiment pas ce qui se passe  :cry:  
 
J'ai cru me souvenir que j'avais eu une fois sous Windows un message comme quoi mon SSD était locké. Super mais j'ai rien fait de spécial. Et si c'est le cas, ça expliquerait l'impossibilité de formater en NTFS ? Et comment délocker ?

n°9052317
kit-et-kat
Posté le 11-02-2014 à 21:55:45  profilanswer
 

Tu as quoi comme message d'erreur lors du formatage ?


---------------
Mon feed back: http://forum.hardware.fr/hfr/Achat [...] 6100_1.htm
n°9052358
syntaxx_er​ror
Posté le 11-02-2014 à 22:20:28  profilanswer
 

Dans le soft de gestion des disques Win8.1 j'ai le message "L'assistant ne s'est pas terminé correctement" (pas très français) et du coup le SSD est en RAW. J'ai utilisé d'autres soft comme Parted Magic, Gparted...Toujours la meme chose. Là j'utilise TestDisk http://www.cgsecurity.org/wiki/TestDisk_FR


Message édité par syntaxx_error le 11-02-2014 à 22:20:51
n°9052471
kit-et-kat
Posté le 12-02-2014 à 00:19:51  profilanswer
 

Ca m'est déjà arrivé cette erreur. Faut que je réfléchisse, la nuit porte conseil ;)
 


---------------
Mon feed back: http://forum.hardware.fr/hfr/Achat [...] 6100_1.htm
mood
Publicité
Posté le 12-02-2014 à 00:19:51  profilanswer
 

n°9052473
kit-et-kat
Posté le 12-02-2014 à 00:24:14  profilanswer
 

Tu as pas le moyen de le formater sous Windows 7 ?
 
j'ai trouvé ça : http://forum.hardware.fr/hfr/Hardw [...] 5373_1.htm


---------------
Mon feed back: http://forum.hardware.fr/hfr/Achat [...] 6100_1.htm
n°9052684
syntaxx_er​ror
Posté le 12-02-2014 à 10:46:35  profilanswer
 

Visiblement faudrait une autre machine sous Windows 7. Je n'ai malheureusement pas ça sous la main. Installer Win7 sur la meme machine, je suis pas certain que ça marchera.
 
Très honnêtement je suis au bout du rouleau. J'ai testé gavé de truc, je me suis couché super tard. Total à la rue au taff today :/. J'ai fait des recherches sur les problèmes de RAW. Ca peut etre au choix un probleme de MBR ou partition ou virus ou droit d'accès au lecteur sous Windows...Etc

n°9052702
kit-et-kat
Posté le 12-02-2014 à 11:00:46  profilanswer
 

J'ai oublié de réfléchir ;) Mais j'ai eu le problème une fois, je sais plus comment j'ai débloqué le truc.  
Tu peux essayer de contacter le support technique de plextor que j'imagine performant.*
Bon courage et si tu trouves une solution, manque pas de la communiquer c'est toujours bon à savoir ;)


---------------
Mon feed back: http://forum.hardware.fr/hfr/Achat [...] 6100_1.htm
n°9052737
syntaxx_er​ror
Posté le 12-02-2014 à 11:36:20  profilanswer
 

Merci pour ton aide. Je vais continuer mes investigations. Yes, contacter plextor c'est pas con, ils ont peut etre un utilitaire special qu'ils ne mettent pas en ligne.
 
A suivre !

n°9052919
syntaxx_er​ror
Posté le 12-02-2014 à 14:28:30  profilanswer
 

Bon j'ai appelé plextor. Ils n'ont pas de solution specifique. Je vais devoir me débrouiller seul. J'ai d'autres truc à tester notamment avec diskpart. J'ai déjà utilisé la fonction Clean mais pas celle consistant à créer une partition NTFS. HDD generator semble également tout indiqué pour repérer les erreurs disque.

n°9052931
kit-et-kat
Posté le 12-02-2014 à 14:38:18  profilanswer
 

As tu fais cette manip ?
Eteindre le système, déconnecter ton ssd, relancer le système, l'éteindre, rebrancher le ssd et retenter un formatage. Je crois que c'est ça qui me l'avait débloqué.
Vérifie peut être s'il est pas configuré en hot swap dans ton bios. me demande pas pourquoi ;)
 
Je n'y crois pas mais on sait jamais...


---------------
Mon feed back: http://forum.hardware.fr/hfr/Achat [...] 6100_1.htm
n°9052936
Profil sup​primé
Posté le 12-02-2014 à 14:42:56  answer
 

Que donne un bête formatage de bas niveau en ligne de commande depuis une distribution Linux ?
 
dd if=/dev/zero of=/dev/sdX # (remplacer sdX par le nom du SSD, ça peut être sda, sdb, etc... attention à ne pas se tromper)
cfdisk /dev/sdX # créer une partition
 
Ensuite reboot et tenter de formater cette partition en NTFS depuis un disque d'installation Windows. :)

n°9052948
syntaxx_er​ror
Posté le 12-02-2014 à 14:47:31  profilanswer
 

kit-et-kat a écrit :

As tu fais cette manip ?
Eteindre le système, déconnecter ton ssd, relancer le système, l'éteindre, rebrancher le ssd et retenter un formatage. Je crois que c'est ça qui me l'avait débloqué.
Vérifie peut être s'il est pas configuré en hot swap dans ton bios. me demande pas pourquoi ;)
 
Je n'y crois pas mais on sait jamais...

Quand tu dis "relancer le systeme", tu fais tout le process de boot Windows jusqu'au bureau Windows ou tu éteints après les premières secondes de boot ? Je vais essayer en tout cas  :jap:

Message cité 1 fois
Message édité par syntaxx_error le 12-02-2014 à 14:49:29
n°9052952
syntaxx_er​ror
Posté le 12-02-2014 à 14:48:44  profilanswer
 

Ooh là, linux c'est clairement pas mon truc. Bonne idée quand meme  :jap:


Message édité par syntaxx_error le 12-02-2014 à 14:48:57
n°9052999
Jovial
It's clobberin' time
Posté le 12-02-2014 à 15:23:15  profilanswer
 

Plus "user friendly" que Linux avec ça et une clef USB si besoin est.
 
https://www.terabyteunlimited.com/bootit-bare-metal.htm


---------------
Si vous êtes pas contents, c'est le même tarif
n°9053348
kit-et-kat
Posté le 12-02-2014 à 19:47:17  profilanswer
 

syntaxx_error a écrit :

Quand tu dis "relancer le systeme", tu fais tout le process de boot Windows jusqu'au bureau Windows ou tu éteints après les premières secondes de boot ? Je vais essayer en tout cas  :jap:


Oui tu fais tout le processus de boot.


---------------
Mon feed back: http://forum.hardware.fr/hfr/Achat [...] 6100_1.htm
n°9053354
kit-et-kat
Posté le 12-02-2014 à 19:49:54  profilanswer
 

Avec le secure erase tu pourras pas faire mieux, le problème vient donc d'ailleurs, peut être l'os qui a verrouillé ton disque je sais, mais curieux que ça coince à l'installation aussi.
Tu peux toujours demander de l'aide sur le topic Windows 8, comme ça concerne aussi cet OS.
 
En dernier recours tu as l'appel à la radio :D

Message cité 1 fois
Message édité par kit-et-kat le 12-02-2014 à 19:50:31

---------------
Mon feed back: http://forum.hardware.fr/hfr/Achat [...] 6100_1.htm
n°9053611
peremumuch
Posté le 12-02-2014 à 23:31:17  profilanswer
 

j'ai déjà eu ce problème la résolu par  G-PARTED a partir d'un live cd linux


---------------
étant donné que nous vivons dans un monde corrompu par l'argent, tout ce qui est gratuit est bon à prendre
n°9053645
syntaxx_er​ror
Posté le 13-02-2014 à 00:05:43  profilanswer
 

kit-et-kat a écrit :

Avec le secure erase tu pourras pas faire mieux, le problème vient donc d'ailleurs, peut être l'os qui a verrouillé ton disque je sais, mais curieux que ça coince à l'installation aussi.
Tu peux toujours demander de l'aide sur le topic Windows 8, comme ça concerne aussi cet OS.

 

En dernier recours tu as l'appel à la radio :D

J'ai effectivement un message du type "D:\ n'est pas acessible" après chaque tentative de formatage sous l'explorateur windows. J'ai vaguement vu qu'il y avait la commande "icacls" pour modifier les permissions mais j'ai pas tout capté au niveau de la syntaxe :/

 

Pour le reste j'ai scanné mon SSD avec hdd regenerator et pas de secteurs défectueux. C'est déjà ça...

 

Message cité 1 fois
Message édité par syntaxx_error le 13-02-2014 à 00:13:29
n°9053646
syntaxx_er​ror
Posté le 13-02-2014 à 00:06:20  profilanswer
 

peremumuch a écrit :

j'ai déjà eu ce problème la résolu par  G-PARTED a partir d'un live cd linux

J'ai ce soft. Tu te souviens de la manipe exacte ?

n°9053670
kit-et-kat
Posté le 13-02-2014 à 00:41:30  profilanswer
 

syntaxx_error a écrit :

J'ai effectivement un message du type "D:\ n'est pas acessible" après chaque tentative de formatage sous l'explorateur windows. J'ai vaguement vu qu'il y avait la commande "icacls" pour modifier les permissions mais j'ai pas tout capté au niveau de la syntaxe :/  
 
Pour le reste j'ai scanné mon SSD avec hdd regenerator et pas de secteurs défectueux. C'est déjà ça...
 


Un truc que tu peux faire c'est d'aller voir dans les journaux Windows les événement qu'il y a eu concernant le formatage de ton SSD. Ainsi avec le numéro d'erreur et les commentaires tu pourras en savoir plus que gnagna n'est pas accessible et peut être bien comprendre l'origine de l'erreur.


---------------
Mon feed back: http://forum.hardware.fr/hfr/Achat [...] 6100_1.htm
n°9053682
syntaxx_er​ror
Posté le 13-02-2014 à 01:12:08  profilanswer
 

J'ai commencé à bidouiller avec PTEDIT (editeur hexa). En effet après un secure erase le SSD est fatalement rempli de zero. Dans PTEDIT je sais mettre la bonne valeur de partition pour le NTFS : c'est 07 via l'option "Set Type" . Le truc c'est qu'il me manque toutes les autres valeurs (boot/Cyl/Head/etc.. pour Starting/Ending + la partie sectors). Comment obtenir ces valeurs qui correspondent au volume de mon SSD ?

 

En fait windows met le SSD en RAW car à la base il lui manque la valeur de la partition (07 pour le NTFS) dans la colonne "type" pour reconnaitre le SSD correctement et donc faire le formatage. Le probleme est que la valeur "type" est dépendante du starting sector qui doit etre superieur à zero. Je peux pas mettre 07 et laisser toutes les autees valeurs à zero.

 

Explications visuelles ici : http://www.bellamyjc.org/fr/windowsxp2003.html#autochk

 

Je suis pas loin de la solution. Idealement faudrait qu'un mec ayant un M5Pro 128go utilise PTEDIT et me dise qu'elles sont les valeurs pour toutes les cases.

 

Pour les valeurs, j'ai un debut de réponses (cf les infos en haut près de la bande déroulante) :
http://imageshack.com/a/img542/5078/hk3l.png


Message édité par syntaxx_error le 13-02-2014 à 01:21:42
n°9053788
syntaxx_er​ror
Posté le 13-02-2014 à 09:59:02  profilanswer
 

En fait grace à Diskpart j'arrive à remplir la ligne n°1 ci-dessus en créant une partition non formatée. Avec PTEDIT j'arrive à injecté la valeur "07" pour indiquer que c'est du NTFS. Mais malgré tout ça ça ne marche toujours pas. Windows voit toujours ça en RAW  :cry:

n°9055701
syntaxx_er​ror
Posté le 14-02-2014 à 21:30:30  profilanswer
 

Bon, je crois que je me prends la tete pour rien en fait. Mon M5P semble dead, il refuse toute ecriture. Pas étonnant que ça formate pas  :sarcastic:

 

http://imageshack.com/a/img32/5113/ansg.png

 

A voir les commentaires sur le forum plextor US ça fait peur : http://www.plextoramericas.com/ind [...] -brokenrma

 

Je précise que le mien est un des premiers lots mais visiblement c'est pareil sur les plus récents. Etrange quand meme, j'avais jamais eu de probleme avec mon M3P. Décidément c'est vraiment pas fiable le SSD quelque soit la marque :/...Bref, demande de RMA lundi.


Message édité par syntaxx_error le 14-02-2014 à 21:56:14
n°9055851
kit-et-kat
Posté le 14-02-2014 à 23:39:15  profilanswer
 

J'ai jamais eu confiance et heureusement au final, sauf que j'en ai 5 chez moi  :cry:  


---------------
Mon feed back: http://forum.hardware.fr/hfr/Achat [...] 6100_1.htm
n°9055907
syntaxx_er​ror
Posté le 15-02-2014 à 00:22:51  profilanswer
 

Achat d'un Samsung 840 Pro demain pour remplacer mon M5P  :o ...Deg d'avoir perdu autant de temps à trouver une solution alors qu'il est dead. La faute à crystaldisk & co qui me disaient que tout allait bien  :sarcastic:


Message édité par syntaxx_error le 15-02-2014 à 00:25:18
mood
Publicité
Posté le   profilanswer
 


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Hardware
  Disque SSD

  SSD Plextor M5P - Formatage NTFS impossible car en mode RAW -Need help

 

Sujets relatifs
Freeze SSDChoix du SSD suite la mort du HDD ?
SSD + Asus Maximus Formula X38Message d'erreur chrome.exe quand j'installe pilote amd
Compatibilité processeur avec carte mère Asus M4A785D-m Pro?Déplacer la partition C:
Problème erreurs sur SSD Crutial M5002 partitions 1 partition morte (system)
SSD CacheDémarrage lent SSD OCZ
Plus de sujets relatifs à : SSD Plextor M5P - Formatage NTFS impossible car en mode RAW -Need help


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR