Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Shop Recherche
2032 connectés 

  FORUM HardWare.fr
  Hardware
  Matériels & problèmes divers

  Problème étrange avec le port série

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Problème étrange avec le port série

n°3499416
fredasse
Posté le 16-09-2004 à 14:05:28  profilanswer
 

Bonjour à tous, :hello:  
 
J'ai le problème suivant :  :(  :(  
pour mon boulot je dois contrôler un appareil industriel par le port série. Malheureusement il semble que ça ne marche qu'avec les PC portables. Qu'est ce que les portables auraient de différent au niveau du port série par rapport au ordis de bureau ?
 
Si quelqu'un peut m'aider ou me donner des tuyaux, merci d'avance.
 
Fred
 :hello:

mood
Publicité
Posté le 16-09-2004 à 14:05:28  profilanswer
 

n°3499421
crane
Mort de soif !
Posté le 16-09-2004 à 14:06:33  profilanswer
 

Pas normal, c'est les mêmes

n°3499425
Prems
Just a lie
Posté le 16-09-2004 à 14:07:56  profilanswer
 

Ce qui est curieux c'est que justement les PC portables ont plus de problèmes de port série que les PC de bureau.
 
La seule différence que je verrais c'est au niveau de la masse du port. Sur un PC de bureau elle est reliée à la masse du secteur, mais sur un portable...


---------------
Ratures - Cuisine
n°3499433
fredasse
Posté le 16-09-2004 à 14:11:14  profilanswer
 

Mais c'est interressant ça !!  
Tu peux m'en dire plus ???

n°3499435
Prems
Just a lie
Posté le 16-09-2004 à 14:12:03  profilanswer
 

Si toi tu pouvais m'en dire plus sur le "ça ne marche pas".


---------------
Ratures - Cuisine
n°3499458
fredasse
Posté le 16-09-2004 à 14:18:41  profilanswer
 

Hé bien voilà :
je dois contrôler une enceint climatique pour faire des cycles de test. Cela se fait donc par l'intermédiaire d'un PC par le port série. Il s'agit d'échange de trames en ASCII. Les paramètre de la liaison sont 9600 bauds, 8 bits de données, 1 bit de stop, pas de parité, pas de contrôle de flux. Pour le moment, je communique avec la machine avec Hyperterminal. Je lui envoie des trames et je peux aussi lire ce qu'elle me dit.
Ceci marche donc avec des PC portables. Mais rien ne se passe avec des PCs de bureau.

n°3499464
Prems
Just a lie
Posté le 16-09-2004 à 14:21:00  profilanswer
 

Et ton port est pourtant bien configuré.
 
Tu as essayé avec le PC portable relié au secteur (pour confirmer le problème de masse).


---------------
Ratures - Cuisine
n°3499483
fredasse
Posté le 16-09-2004 à 14:27:55  profilanswer
 

Oui, mais il faut que je précise que les alims des portables en question n'ont pas de prise avec la terre, juste la phase, le neutre et basta.

n°3499491
crane
Mort de soif !
Posté le 16-09-2004 à 14:29:22  profilanswer
 

Tu es sur que les paramètres du port série de la tour sont ok ? c'est bien le meme n° de port (com1, com2, ...) ?

n°3499638
fredasse
Posté le 16-09-2004 à 15:14:10  profilanswer
 

Oui, je me suis déjà fait avoir de ce côté-là :  
câble pas branché, requête exécutée sur COM2 alors que c'est COM1 qui est connecté, etc...
 
Pour ce qui est du problème de masse, j'ai déconnecté la masse sur l'alim de mon PC de bureau pour essayer et ça marche pas non plus.

mood
Publicité
Posté le 16-09-2004 à 15:14:10  profilanswer
 

n°3499643
crane
Mort de soif !
Posté le 16-09-2004 à 15:15:45  profilanswer
 

Je sais pas pourquoi mais en plus j'ai l'impression que c'est vraiment un truc tout con...


---------------
Ca vaut pas un pet de lapin!
n°3499663
kaleos
Posté le 16-09-2004 à 15:21:16  profilanswer
 

T'as testé tes ports au moins pour voire si ils fonctionnent correctement avec une autre application.


Message édité par kaleos le 16-09-2004 à 15:21:34
n°3499668
crane
Mort de soif !
Posté le 16-09-2004 à 15:22:06  profilanswer
 

Yep, check aussi l'adresse matériel des ports (dans le bios)


---------------
Ca vaut pas un pet de lapin!
n°3499952
fredasse
Posté le 16-09-2004 à 17:14:45  profilanswer
 

Pour ce qui est du test des ports : oui chacun a été testé par un transfert de fichier avec HyperTerminal.
Pour ce qui est de l'addresse matérielle, je vais aller voir ça dans les BIOS concernés.


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Hardware
  Matériels & problèmes divers

  Problème étrange avec le port série

 

Sujets relatifs
probleme recuperation de donnees sur cd-rwprobleme hercules 9800 pro
probleme carte a7n8x-e deluxeprobleme ram?
probleme disque dur externeprobleme disque dur externe
Probleme dis dur externe TEACProblème au demarrage???
[?] Problème pour lancer un jeux ! Désactivé émulation CD/DVD ???probleme 6800 ultra BFG THEC
Plus de sujets relatifs à : Problème étrange avec le port série


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR