Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
1644 connectés 

  FORUM HardWare.fr
  Hardware
  Matériels & problèmes divers

  problème au démarrage, entre linux et windows

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

problème au démarrage, entre linux et windows

n°4057102
claire2508
Posté le 06-05-2005 à 17:29:06  profilanswer
 

Bonjour,
 
Voilà; j'ai écrit il y a quelques jours, mais mon msg a disparu !!!
Je repose donc ma question : sur mon PC, j'ai windows XP et linux (Mandrake 10,1). J'ai, depuis peu, un nouveau clavier (logitech cordless). Lorsque mon ordinateur démarre,  on me laisse le choix entre windows et linux (linux, par défaut)... Mais, le problème est que mon clavier ne fonctionne qu'une fois que windows a démarré !! Donc, je ne peux plus faire mon choix... N'y aurait-il pas un moyen de configurer mon clavier pour qu'il fonctionne aussi lorsque l'ordinateur est en train de démarrer ? J'ai cherché dans les options des drivers, mais je ne trouve rien... Ou sinon, solution béquille, mais, c'est toujours mieux que rien : n'y aurait-il pas un moyen de faire que windows démarre par défaut, et pas linux ?
 
Merci beaucoup de votre aide...
 
Claire


Message édité par claire2508 le 06-05-2005 à 18:12:57
mood
Publicité
Posté le 06-05-2005 à 17:29:06  profilanswer
 

n°4057246
dwain
Posté le 06-05-2005 à 18:25:40  profilanswer
 

Hello :hello:
 
Ta séquence de démarrage doit se trouver dans le fichier "boot.ini" de ton PC. Si tu l'ouvres, tu dois avoir quelque chose de ce style :
 
[boot loader]  
timeout=10  
default=multi(0)disk(0)rdisk(0)partition(3)\WINDOWS  
[operating systems]  
multi(0)disk(0)rdisk(0)partition(3)\WINDOWS="Microsoft Windows XP Professionnel" /fastdetect  
C:\="Windows 98"
 
Donnes nous ta propre séquence de boot contenue de ce fichier afin de la modifier et de mettre windows par défaut ;)
 
EDIT : Plus d'infos >>>ici<<<
 
(il n'y a rien de tel qu'un bon vieux clavier filaire ! :lol:)


Message édité par dwain le 06-05-2005 à 18:36:59
n°4057305
claire2508
Posté le 06-05-2005 à 18:59:17  profilanswer
 

merci de ta réponse si rapide !!!
voici mon boot.ini :
 
[ boot loader ]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[ operating system ]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP édition familiale" /fastdetect /NoExecute=OptIn
 
Merci beaucoup !!!
 
Claire


Message édité par claire2508 le 06-05-2005 à 23:52:42
n°4057840
dwain
Posté le 06-05-2005 à 23:59:00  profilanswer
 

C'est bizarre, dans ta séquence de boot, il n'y a qu'un seul OS. S'il y en avais plusieurs on aurait pu définir la priorité mais là je ne sais pas.
Il y a certainement quelque chose à modifier du côté de Linux mais je n'en sais rien.
Je te tiens au courant si je trouve plus d'informations ;)
 
EDIT : Sinon je pense à un truc tout bête. Sur quel port est branché ton clavier ? PS/2 ? USB 1 ? USB 2.0 ? USB de la carte mère ? USB d'une carte d'extension ?


Message édité par dwain le 07-05-2005 à 00:02:40
n°4057861
claire2508
Posté le 07-05-2005 à 00:06:08  profilanswer
 

Ben en fait, il est branché sur USB 1, mais, il y avait aussi une prise verte (je pense PS/2)et j'ai donc branché les deux... J'étais obligée de brancher l'usb, car, l'alimentation part aussi de ce fil, mais je pense que la souris est branchée grâce au vert...
 
Pour la séquence et pour linux, je vais me renseigner autour de moi... Si jamais j'obtiens une réponse, je te tiendrai au courant, pour info !!!
 
Merci, en tous cas...
 

n°4057896
dwain
Posté le 07-05-2005 à 00:21:57  profilanswer
 

Ce qui peut se produire c'est que ton clavier est branché sur un USB d'une carte d'extension et non directement sur la carte mère, ce qui pourrai expliquer son fonctionnement seulement sous windows.

n°4057900
claire2508
Posté le 07-05-2005 à 00:24:52  profilanswer
 

pourtant, il est branché derrière... Mais, je suis en train de penser qu'il y a deux endroits où il y a de l'usb.... Hum hum, c'est peut-être bien ça...
 
Je vais essayer (peut-être pas ce soir, car il faudrait tout couper et tout rallumer, mais demain à la premièer heure !!!) et je te tiendrai au courant... Si c'est ça, merci merci merci !!!!
 
Bonne soirée (ou plutôt bonne nuit !!!)
 
Claire

n°4057926
flo37fr
Posté le 07-05-2005 à 00:38:03  profilanswer
 

A mon avis c'est un probleme de clavier : ton clavier doit fonctionner en USB et n'est pas pris en charge avant le chargement de windows. Il te faut surement des drivers ou un module supplementaire. Le fichier boot.ini ne sert qu'a configurer le demarrage des OS microsoft (quand deux windows sont installés). Pour choisir entre windows et linux, il faut un boot loader (LILO par exemple)
Enfin bref, va voir sur OS Alternatifs y'aura surement quelqu'un pour t'aider

n°4057934
claire2508
Posté le 07-05-2005 à 00:42:14  profilanswer
 

J'ai lilo... Mais il est configuré de telle manière que c'est linux qui est par défaut...
Quand au clavier, en effet, il est en usb, mais c'est quand même fou que çe ne soit pris en compte que par windows.... Comment on fait quand on veut se servir de linux, justement ??!!!
 
Donc, j'ai lilo, mais je ne sais pas le configurer pour mettre windows en premier...

n°4057944
dwain
Posté le 07-05-2005 à 00:47:15  profilanswer
 

Ce qu'il est possible de faire (et qui ne couterai que quelques petits €) c'est de trouver un adaptateur USB - PS/2 (il y en a de partout). Comme ça tu branches ton clavier en PS/2 et là il ne devrai plus y avoir de problèmes.

mood
Publicité
Posté le 07-05-2005 à 00:47:15  profilanswer
 

n°4057945
flo37fr
Posté le 07-05-2005 à 00:48:58  profilanswer
 

Ton clavier doit marcher sous linux mais ne marche pas avant que linux ou windows soit chargé. Donc tant que tu n'as pas choisi entre windows et linux pas de clavier. Pour configurer lilo, il faut éditer le fichier /etc/lilo.conf . Mais bon, ca résolvera pas le vrai problème. Va sur OS Alternatifs, y'a surement quelqu'un qui s'y connait qui te dira comment faire pour que ton clavier soit pris en charge dès le demarrage.

n°4057948
uself
Posté le 07-05-2005 à 00:51:20  profilanswer
 

Normalement ton clavier marche et pas seulement sous windows, éssay d'aller dans ton bios et tu seras fixer, si tu y arrives, et suivant le model de ta mobo, tu as une option pr activer les claviers usb hors OS, ton problème peut venir de la.

n°4057949
claire2508
Posté le 07-05-2005 à 00:51:50  profilanswer
 

en effet, je me demande même si je n'en ai pas un qui traine dans un coin !!!  
Si cela (ou le changement de port usb sur un qui soit directement relié à la carte mère) ne résout pas le problème, j'irai effectivement sur OS alternatifs...
 
Merci à tous les deux...
EDIT : pardon tous les trois !!!!
 
Claire


Message édité par claire2508 le 07-05-2005 à 00:53:02
n°4057950
dwain
Posté le 07-05-2005 à 00:52:14  profilanswer
 

>>>Ceci<<< peut peut-être t'aider à configurer Lilo et ainsi démarrer Windows par défaut ;)


Message édité par dwain le 08-05-2005 à 05:16:49

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Hardware
  Matériels & problèmes divers

  problème au démarrage, entre linux et windows

 

Sujets relatifs
Ecran noir au démarrage. MB 648F Neo MSIProblème de démarrage - Compaq Armada
HELP ! Big probleme au boot !Probleme connection USB
Problème de détection disque dur usb 2Problème avec mon lecteur mp3 MuVo
probleme de barbeProbleme pour lire un DVD Video
Plus de sujets relatifs à : problème au démarrage, entre linux et windows


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR