Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
473 connectés 

  FORUM HardWare.fr
  Systèmes & Réseaux Pro
  Poste de travail

  Agent Fusion inventory

 


 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Agent Fusion inventory

n°143952
Micko77666
Posté le 30-12-2016 à 15:37:33  profilanswer
 


 
Bonjour tout le monde,
 
 
 
Alors voilà, nous allons mettre Fusion inventory sur l'ensemble de notre parc informatique. Quand je lance mon script VBS à la mains aucun soucis, ça fonctionne sans soucis. Par contre quand je le fais depuis une GPO je ne peux pas, elle est bien dans le script du démarrage du PC pas de soucis, elle s'applique bien au PC en question (RSOP ok), mais je pense qu'il me manque l’élévation des droits ou l'UAC qui me dérange.
 
Une idée pour contourner ça ? ça doit être tout bête en plus :/
 
 
En vous remerciant par avance,

mood
Publicité
Posté le 30-12-2016 à 15:37:33  profilanswer
 

n°143954
nebulios
Posté le 30-12-2016 à 16:36:10  profilanswer
 

Comment tu lances ton script ?

n°143955
Micko77666
Posté le 30-12-2016 à 16:44:16  profilanswer
 


Alors si je lance en local par exemple aucun soucis. Si depuis un utilisateur lambda je vais dans :
 
\\serveurAD\sysvol\etc.... et que lance le VBS ça marche mais faut que je rentre des infos admin. Et si je suis admin quand je fais ça bas juste accepter à cause de l'UAC.
 
Donc malgré que je le lance via une GPO ordinateur bas l'UAC ou les droits bloquent visiblement. Mais je vois pas en quoi, je publie des imprimantes sans le moindre soucis par exemple.

n°143956
nebulios
Posté le 30-12-2016 à 16:48:45  profilanswer
 

Dans la GPO vérifie que tu appelles ton script avec cscript.exe
Je suppose que ton script n'a pas besoin d'une interaction pour s'exécuter.

n°143957
Micko77666
Posté le 30-12-2016 à 16:59:20  profilanswer
 

Non c'est le VBS du site FusionInventory vraiment rien de bien méchant à la base quoi.
 
Je vérifie comment pour le cscript.exe ?

n°143958
crachkille​r
Posté le 30-12-2016 à 19:10:09  profilanswer
 

Micko77666 a écrit :

Non c'est le VBS du site FusionInventory vraiment rien de bien méchant à la base quoi.
 
Je vérifie comment pour le cscript.exe ?


En fait tu exécutes cscript.exe et tu mets ton fichier vbs en argument. Cscript est un exécutable présent dans les répertoires système de l'os.

n°143959
Micko77666
Posté le 30-12-2016 à 19:38:59  profilanswer
 


Ah OK jamais eu besoin de le faire avant, je testerai ça lundi :)
 
Mais c'est vrai que c'est bizarre  car la GPO est très simple et le VBS aussi.

n°143960
crachkille​r
Posté le 30-12-2016 à 19:49:52  profilanswer
 

Micko77666 a écrit :


Ah OK jamais eu besoin de le faire avant, je testerai ça lundi :)
 
Mais c'est vrai que c'est bizarre  car la GPO est très simple et le VBS aussi.


En fait lorsque tu double clic sur ton fichier vbs ton os utilise l'exécutable cscript.exe pour l'exécuter. C'est pour cela que tu doit lui indiquer avec quoi exécuter ton code, un fichier vbs n'est pas un exécutable.

n°143962
Micko77666
Posté le 31-12-2016 à 10:50:11  profilanswer
 


Et du coup si c'est bien cscript qui ouvre mon VBS, qu'est ce qu'il y a d'autres comme pistes ?
 
Un soucis sur mon VBS ?

n°143963
crachkille​r
Posté le 31-12-2016 à 13:51:46  profilanswer
 

Dans une GPO de type ordinateur tu n'as pas besoin d'élever les droits car le script est exécuté avec les droits systèmes.  
Dans mon AD, le script fusion s'exécute correctement quel que soit la version d'os, et il est exécuté via cscript dans une gpo ordinateur.  
 
Alors a priori je dirais que ça doit fonctionner de cette manière.

mood
Publicité
Posté le 31-12-2016 à 13:51:46  profilanswer
 

n°143964
Micko77666
Posté le 31-12-2016 à 14:29:43  profilanswer
 


Tu as un exemple de ton script pour stp et tu as pas de soucis avec l'UAC ?

n°143965
crachkille​r
Posté le 31-12-2016 à 15:00:10  profilanswer
 

Micko77666 a écrit :


Tu as un exemple de ton script pour stp et tu as pas de soucis avec l'UAC ?


J'utilise le script fourni avec le plugin fusioninventory. Si ça ne fonctionne toujours pas de ton côté lundi, je te file ça. Non aucun soucis

n°143966
nebulios
Posté le 31-12-2016 à 15:02:21  profilanswer
 

Micko77666 a écrit :


Ah OK jamais eu besoin de le faire avant, je testerai ça lundi :)
 
Mais c'est vrai que c'est bizarre  car la GPO est très simple et le VBS aussi.


Le moteur par défaut est wscript qui se comporte différement. Sinon tu balances un package MSI par un GPO ou tu fais un script en Powershell.

n°143984
Micko77666
Posté le 02-01-2017 à 10:56:37  profilanswer
 

Bon j'ai regardé en arrivant au travail, en fait j'ai ce message d'erreur avec un gpresult :
 
" Les objets stratégie de groupe n'ont pas été appliqués
 car ils ont été refusés"
 
Forcément ça aide pas .... par contre je ne vois pas pourquoi il me fait ça. Mon PC est dans la bonne OU, en filtre j'ai mis le nom de mon PC et j'ai bien assez au lecteur réseau avec les sources du logiciel à installer.

Message cité 1 fois
Message édité par Micko77666 le 02-01-2017 à 11:01:54
n°144310
rattrappem​oi
Posté le 19-01-2017 à 17:45:26  profilanswer
 

Micko77666 a écrit :

Bon j'ai regardé en arrivant au travail, en fait j'ai ce message d'erreur avec un gpresult :
 
" Les objets stratégie de groupe n'ont pas été appliqués
 car ils ont été refusés"
 
Forcément ça aide pas .... par contre je ne vois pas pourquoi il me fait ça. Mon PC est dans la bonne OU, en filtre j'ai mis le nom de mon PC et j'ai bien assez au lecteur réseau avec les sources du logiciel à installer.


Quelle est la solution trouvée ?

n°146296
Micko77666
Posté le 28-04-2017 à 15:37:18  profilanswer
 


Je reviens sur mon sujet, j'avais le soucis pour que la GPO s'applique correctement à l'utilisateur, car effectivement je n'avais pas mis utilisateur authentifié dans la délégations.
 
Par contre je rencontre toujours le soucis d'installation de l'agent.
 
 
- En gros avec RSOP.MSC ou gpresult /R je vois bien que ma GPO est ok , que le script est bien au bon endroit.
- Si je lance mon script à la main dans \\srv\sysvol\policies\etc....  l'agent s'installe bien, faut juste entrer un login et un mot de passe pour avoir les droits.
 
Donc mon script tout comme mon agent sont fonctionnent bien.
 
 
Qu'est-ce qu'il pourrait manquer ?


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Systèmes & Réseaux Pro
  Poste de travail

  Agent Fusion inventory

 

Sujets relatifs
Fusion de structures et AD - approche -OCS Inventory : les agents ne trouvent pas le serveur (pas de remontée
GPO Agent OCS Inventoryocs inventory ng - erreur au déploiement
Desinstallation FusionScript d'installation OCS Agent Windows à partir d'un serveur Linux
Base de données d'OCS InventoryOCS Inventory - SSL OK, mais pas de déploiement
Déployer Fusion inventory via GPO 
Plus de sujets relatifs à : Agent Fusion inventory



Copyright © 1997-2016 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR