Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
2138 connectés 

  FORUM HardWare.fr
  Windows & Software
  Stockage/Sauvegarde

  [Résolu] Pourquoi clonage partition windows impossible ?

 


 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[Résolu] Pourquoi clonage partition windows impossible ?

n°3269296
edmond159
Posté le 10-04-2017 à 14:40:42  profilanswer
 

Bonjour,
 
J’ai récemment changé le disque dur de mon pc pour un SSD.
 
J’ai eu un problème pour la migration, que j’ai corrigé depuis. Afin de comprendre ce qui s’est passé, je viens ici pour avoir votre opinion.
 
Je n’ai plus de problème, tout a été corrigé, je partage mon histoire pour avoir votre avis.
 
Système
Windows 7 x64
Système non uefi
Ancien dd : HDD 500 Go
Partition unique de Windows
Table de partition MBR
Nouveau dd : SSD 120 Go
 
Problème rencontré : impossible de démarrer Windows sur le SSD après avoir cloné sa partition. Seul le clonage complet du disque dur a fonctionné.
 
Pourquoi ?
 
 
J’ai utilisé 3 méthodes successives pour cloner mon windows sans réinstaller.
 
Avec GParted, copié-collé partition + flag boot = boot impossible, Windows ne trouvait pas sa partition de boot. J’ai eu l’erreur de windows spécifiant qu’il ne peut pas démarrer.
Avec clonezilla pour la partition Windows = idem
Avec Acronis, clonage du disque dur complet avec table de partition et MBR = boot ok
 
Avec GParted, et clonezilla, j’ai cloné la partition uniquement. J’avais bien créé une table de partition MBR avant et mis le flag boot à la partition copié. La partition a été clonée avec succès. J’ai également vérifié les données copiées avec un linux live. Et pourtant, impossible de démarrer windows sur le SSD qui était le seul disque dur branché sur le 1er sata.
 
Après chaque clonage de la partition Windows (GParted puis Clonezilla), j’ai tenté des réparations.
 
Avec Windows
J’ai tenté 3 réparations avec le dvd de windows avec la fonction réparé le démarrage, par trois fois, sans succès. Il trouvait la partition windows, mais la réparation ne changeait rien au problème.
 
Avec Bootrepair
J’ai également tenté une réparation avec le dvd boot-repair, mais aucun changement.
 
Avec Linux
J’ai également tenté une réparation avec un linux live et les commandes suivantes permettant de corriger la MBR en suivant ce tuto : http://ubuntuhandbook.org/index.ph [...] om-ubuntu/

Code :
  1. $ sudo fdisk -l
  2. $ sudo apt-get update && sudo apt-get install syslinux
  3. $ sudo dd if=/usr/lib/syslinux/mbr/mbr.bin of=/dev/sda


 
Seul la 3è méthode de clonage a réglé le problème. Seul le clonage complet du disque dur avec l’outil d’Acronis a permis de démarrer Windows.
 
Je n’ai plus de problème, tout fonctionne bien sur mon nouveau SSD.
 
Toutefois, j’ai besoin de comprendre.
 
D’après vous, pourquoi Windows du SSD ne pouvait pas démarrer après que sa partition a été clonée ?
 
Je ne comprends pas, pourriez-vous éclairer ma lanterne svp.
 
Solution :
Parce que la partition système réservé de 100 Mo de windows 7 était absente de l'ancien disque dur.


Message édité par edmond159 le 10-04-2017 à 21:52:25
mood
Publicité
Posté le 10-04-2017 à 14:40:42  profilanswer
 

n°3269302
yf38
Posté le 10-04-2017 à 15:14:33  profilanswer
 

Bonjour,
Je peux imaginer les hypotheses suivantes:
1) Il n'y a avait pas de MBR sur le SSD après la restauration de la partition C: mais dans ce cas la réparation avec le media d'installation suffit, ce qui n'a pas été ton cas (sauf mauvaise manip).

 

2) Il y avait cette fichue partition de 100Mo cachée par laquelle passe le boot avant d'aller sur C: et tu ne l'as pas vue. Tu ne l'as pas restaurée, et la partition C: restaurée n'avait pas ce qu'il faut pour booter.

 

Le clonage "du disque" a tout transféré sur le SSD et donc ça fonctionne.
Vérifie avec l'outil de gestion du disque s'il y a ou non cette partition de 100Mo cachée.
On peut éliminer le besoin de cette partition en tapant la commande bcdboot c:\windows /s c: qui transfère une copie des fichiers necessaires au boot sur c: puis en rendant active c:
Ensuite on peut supprimer la partition de 100MO, en particulier quand elle est sur un autre disque et que ça empêche de retirer ce disque.

 

Depuis "toujours" je m'arrange pour ne pas avoir besoin de cette partition, y compris sous windows 8 et 10 en MBR et en évitant que l'installation ne la crée.

Message cité 1 fois
Message édité par yf38 le 10-04-2017 à 15:18:41
n°3269304
edmond159
Posté le 10-04-2017 à 15:24:03  profilanswer
 

yf38 a écrit :

1) Il n'y a avait pas de MBR sur le SSD après la restauration de la partition C: mais dans ce cas la réparation avec le media d'installation suffit, ce qui n'a pas été ton cas (sauf mauvaise manip).
2) Il y avait cette fichue partition de 100Mo cachée par laquelle passe le boot avant d'aller sur C: et tu ne l'as pas vue. Tu ne l'as pas restaurée, et la partition C: restaurée n'avait pas ce qu'il faut pour booter.


1- Avant le clonage de la partition, j'avais créé une table de partition de type MBR sous GParted.
2- Absence de cette partition, je suppose que tu parle de partition EFI. Il n'y avais qu'une seule et unique partition, détecté par GParted.

Message cité 1 fois
Message édité par edmond159 le 10-04-2017 à 15:24:54
n°3269309
nex84
Dura lex, sed lex
Posté le 10-04-2017 à 16:24:06  profilanswer
 

Comme le dit yf38, Windows utilise 2 partitions depuis Windows 7 :
- La partition système (nécessaire pour le boot) de 100Mo (450Mo depuis Windows 10)
- La partition de Windows en tant que tel
 
Pour pouvoir booter,il faut que le bios démarre sur le disque contenant la partition système qui lui dira où se trouve la partition de Windows.
 
Dans le cadre d'un clonage, il faut bien sélectionner les deux.
 
Dans le cadre d'une réinstallation de Windows, il faut faire attention à ce que ces deux partitions soient sur le même disque dur pour éviter les problèmes. Pour cela la meilleure méthode est de débrancher tous les disques sauf ce lui qui recevra le système lors de l'installation de Windows.


---------------
Come to the Dark Side, we have cookies.
n°3269321
yf38
Posté le 10-04-2017 à 17:47:28  profilanswer
 

edmond159 a écrit :


2- Absence de cette partition, je suppose que tu parle de partition EFI. Il n'y avais qu'une seule et unique partition, détecté par GParted.

 

Non, je ne parle pas de la partition EFI, il n'y a pas de partition EFI en MBR, je parle de la partition typiquement de 100Mo générée par l'installation de Windows 7 en MBR sauf si on l'en empêche (comme je fais).
Si cette partition n'est pas là et si on n'a pas fait la manip pour ne pas en avoir besoin, ça ne boote pas.
Je ne sais pas si la réparation du démarrage de Windows est capable de réparer ce cas là (puisque je n'en ai jamais...).

 

En MBR, un outil qui fonctionne bien est Macrium Reflect free.
Récemment j'ai changé un disque dur système Windows 10 (MBR et une partition C: et une D: ) par un autre disque dur formaté avec la partition où je voulais mettre C: et une seconde pour les données, les deux de taille différente à l'original.
Une image de C: de l'original, puis restauration de cette image sur le nouveau disque dans la partition prévue, et création du MBR.
Le nouveau disque remplaçant le précédent boote immédiatement.

Message cité 1 fois
Message édité par yf38 le 10-04-2017 à 18:06:35
n°3269361
edmond159
Posté le 10-04-2017 à 21:51:19  profilanswer
 

yf38 a écrit :


 je parle de la partition typiquement de 100Mo générée par l'installation de Windows 7 en MBR sauf si on l'en empêche (comme je fais).
Si cette partition n'est pas là et si on n'a pas fait la manip pour ne pas en avoir besoin, ça ne boote pas.


Je viens de chercher sur le web cette partition dont tu parle, créé par windows. Je l'ai trouvé facilement sur google. Je confirme qu'elle est absente de mon ancien disque dur : je n'avais qu'une partition. J'ai du empêché sa création, mais comme c'était il y a plusieurs d'année, je ne m'en souviens plus ! En tous cas, vous avez bien éclairé ma lanterne et je comprends maintenant les difficultés que j'ai rencontré, parce qu'il n'y avait pas cette partition système de windows de 100 Mo. Merci à vous, sujet clos.

n°3269378
nex84
Dura lex, sed lex
Posté le 11-04-2017 à 08:53:26  profilanswer
 

C'est typiquement pour ça que je ne conseille pas de tripoter le système pour se passer de cette partition.
Quand on ne sait pas ce qu'on fait, on fini par oublier et on va droit dans le mur, alors qu'elle ne pose pas de problèmes particuliers et est facilement manipulable.
En plus, depuis son apparition dans Windows 7 (datant d'il y a 8 ans) on a eu le temps de s'y faire.


---------------
Come to the Dark Side, we have cookies.

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Windows & Software
  Stockage/Sauvegarde

  [Résolu] Pourquoi clonage partition windows impossible ?

 

Sujets relatifs
Réinitialisation de windows qui tourne en boucleImpossible d'installer les drivers Intel
Partition EFI sur le mauvais disqueDisque C : comment augmenter la partition
Messenger pour Windows ?Quelle taille de partition pour W10 64 Home ?
Impossible de booter sur USB.Freez au démarrage de Windows 10
RAM non utilisable sur windows [AUTO-Résolu-boulet]problème avec Windows Update
Plus de sujets relatifs à : [Résolu] Pourquoi clonage partition windows impossible ?



Copyright © 1997-2016 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR