Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
882 connectés 

  FORUM HardWare.fr
  Programmation
  PHP

  POST ne semble pas fonctionné pour une seul variable

 


 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

POST ne semble pas fonctionné pour une seul variable

n°2292078
magiemacab​re
Posté le 18-11-2016 à 09:51:33  profilanswer
 

Bonjour,
 
Je vous expose le problème, j'ai dans la page machine.php un formulaire paramétré en POST qui renvoi dans la page action.php, toutes les variables POST son rempli sauf une et je n'arrive pas à comprendre pour quelle raison je ne vous cache pas qu'un coup de main serait le bien venue.
 
 
Voila la partie qui nous interesse de la page machine.php, c'est nticket qui refuse de passer en POST.

Code :
  1. <form name="java" class="form-basic" method="post" action="action.php">
  2.             <div class="form-title-row">
  3.                 <h1>Ouvrir un ticket</h1>
  4.             </div>
  5.            
  6.             <div class="form-row">
  7.                 <label name="nticket" value="<?php echo "CAPSA-".date("Y" )."-".$lastID; ?>">
  8.                     <span>N° Ticket</span>
  9.                     <?php echo "CAPIS-".date("Y" )."-".$lastID; ?>
  10.                 </label>
  11.             </div>
  12.            
  13.             <div class="form-row">
  14.                 <label name="date" value="<?php echo date("Y-m-d" ) ?>">
  15.                     <span>Date</span>
  16.                     <?php echo date("d.m.Y" ); ?>
  17.                 </label>
  18.             </div>


Cette ligne renvoi l'erreur suivante "Undefined Index : 'nticket' "

Code :
  1. $nticket = $_POST['nticket'];


 
merci d'avance pour vos réponses.

mood
Publicité
Posté le 18-11-2016 à 09:51:33  profilanswer
 

n°2292080
SICKofitAL​L
Razoreater
Posté le 18-11-2016 à 10:58:28  profilanswer
 

Salut
 
ton name="nticket" est sur un label,
alors qu'il devrait être sur un input je suppose
 
EDIT: et il en va de même je pense pour la value du coup, donc je pense que tu as fusionnés les deux balises ;)


Message édité par SICKofitALL le 18-11-2016 à 10:59:49

---------------
"And at the end it is only YOU, ME AND THE VIOLENCE !"
n°2292082
magiemacab​re
Posté le 18-11-2016 à 11:36:34  profilanswer
 

Ah bon bah du coup je me sens un peu con de pas y avoir pensé moi même, mais oui c'était ça merci beaucoup.

n°2292083
rufo
Pas me confondre avec Lycos!
Posté le 18-11-2016 à 11:44:30  profilanswer
 

Label permet d'associer un libellé de champ au champ de saisie proprement dit. Mais ce n'est pas un élément du formulaire qui est posté ;)
 
Un petit tour sur un tuto des formulaires HTML (genre sur openClassroom) ne serait sans doute pas inutile :o


Message édité par rufo le 18-11-2016 à 11:45:01

---------------
Astres, outil de help-desk GPL : http://sourceforge.net/projects/astres, ICARE, gestion de conf : http://sourceforge.net/projects/icare, Outil Cantine Calandreta : http://sourceforge.net/projects/canteen-calandreta

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  PHP

  POST ne semble pas fonctionné pour une seul variable

 

Sujets relatifs
HTTP POST problèmePHP MSSQL Query qui fonctionne pas toujours
recupérer une chaine de texte d'un variable FOR[PHP/PostGres] fetch_object ne fonctionne pas
faire une somme avec nom d'onglet et ligne variable en VBA'responsive' qui ne fonctionne pas sur iphone?
Select avec variable contenant plusieurs valeurs[Excel 2k7] Liste deroulante ne fonctionne plus
Récupérer une partie du nom de fichier en variable ?Petits calculs pour les crédits, ne fonctionne pas [noob]
Plus de sujets relatifs à : POST ne semble pas fonctionné pour une seul variable



Copyright © 1997-2016 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR