Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
567 connectés 

  FORUM HardWare.fr
  Programmation
  HTML/CSS

  Code HTML interprété différent chez OVH

 


 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Code HTML interprété différent chez OVH

n°2291811
Adesfire1
Couper, démonter, rouler !
Posté le 15-11-2016 à 10:15:13  profilanswer
 

Bonjour à tous,
je développe actuellement une application LAMP, celle-ci fonctionne très bien en local mais lors de sa mise en ligne sur mon serveur OVH (mutualisé) je me retrouve avec un espace blanc d'1cm au sommet de toutes mes pages.
Sur le coup, j'avais pensé à un "echo" perdu quelque part mais en fait, c'est le HTML produit qui semble être différent de celui produit en local....alors qu'ils sont similaire jusqu'à la moindre ligne  :pfff:  
 
Exemple simplifié au maximum :
Ce fichier fonctionne comme attendu, la ligne "test" est bien au sommet de la page
Ce fichier déconne, la ligne "test" est espacé d'environ 1cm.
 
J'ai pensé à un soucis d'encodage, hors il semble d'après sublimetext que les deux soient bien en UTF-8, donc que le soucis ne vienne pas d'ici....
 
Je pense encore à un soucis d'encodage (vous verrez que le mot Elémentaire est mal encodé sur la page qui fonctionne, pourtant les deux fichiers on étaient enregistré en UTF8 (sans BOM))
 
Une idée ?


---------------
http://www.Adesfire.fr
mood
Publicité
Posté le 15-11-2016 à 10:15:13  profilanswer
 

n°2291814
TotalRecal​l
Posté le 15-11-2016 à 10:36:19  profilanswer
 

Sous firefox les deux pages commencent bien tout en haut.
 
Par contre les caractères accentués sont pétés dans le "KO", et dans le moniteur réseau on voit un bidule bizarre au tout début du fichier :  




Ce qui pourrait être un BOM qui s'est violemment retrouvé transformé en caractère lors d'une sauvegarde foireuse. Si le navigateur essaie de l'afficher ça ne doit pas aider.
Et dans le HTML il n'y a aucune spécification nulle part de l'encoding utilisé, c'est mal.


---------------
Réalisation amplis classe D / T      Topic .Net - C# @ Prog
n°2291869
rufo
Pas me confondre avec Lycos!
Posté le 15-11-2016 à 22:54:43  profilanswer
 

Pareil pour moi, sous Firefox, pas de pb d'affichage.


---------------
Astres, outil de help-desk GPL : http://sourceforge.net/projects/astres, ICARE, gestion de conf : http://sourceforge.net/projects/icare, Outil Cantine Calandreta : http://sourceforge.net/projects/canteen-calandreta
n°2291924
David Bori​ng
Posté le 16-11-2016 à 16:53:17  profilanswer
 

Le caractère que tu affiches est  Unicode Character 'ZERO WIDTH NO-BREAK SPACE'  
http://stackoverflow.com/questions [...] in-my-html

n°2291926
TotalRecal​l
Posté le 16-11-2016 à 17:07:27  profilanswer
 

C'est genre un copier coller accidentel plutôt qu'un BOM qui s'est viandé selon toi ? De toute façon ça ne change rien, il faut le virer et sauvegarder le fichier correctement en spécifiant en plus l'encoding dans le html.

 

edit : en cherchant vite fait avec le caractère "visuel" ci-dessus c'est bien un BOM mal traité.


Message édité par TotalRecall le 16-11-2016 à 17:08:32

---------------
Réalisation amplis classe D / T      Topic .Net - C# @ Prog

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  HTML/CSS

  Code HTML interprété différent chez OVH

 

Sujets relatifs
besoin d'un code java EE pour authentifier un login et un passwordSupprimez le fichier image uploded utilisant le code d'ajax
[DM Code]en fait un système permettant de définir des nombres premierslancer vidéos à partir d'une page HTML en local, c'est possible ?
[Aide] HTML/CSS - Réinitialiser une requête[HTML] Open Graph : Facebook ne voit pas mon og:image
Petite idée site HTMLCode php qui saffiche
Coloration de code dans un texte 
Plus de sujets relatifs à : Code HTML interprété différent chez OVH



Copyright © 1997-2016 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR