Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
2024 connectés 

  FORUM HardWare.fr
  Programmation
  C++

  question sur l'instalation de opencv 2.3.1 avec vs2010 et CMake 2.8

 


 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

question sur l'instalation de opencv 2.3.1 avec vs2010 et CMake 2.8

n°2173948
hb2012
Posté le 03-02-2013 à 22:14:28  profilanswer
 

Slt mes amis, j'ai travaillé précédemment avec une version de opencv 2.1.0. Mais au cours de mes besoins, je suis entrain d'installer la version opencv 2.3.1 avec le même démarche de celle de la version bien dit lorsque j'ai utilisé le CMake 2.8. Alors que la version opencv 2.3.1 n'a pas marché comme il faut, parmi les étapes de l'installation au niveau de Cmake lorsque je configure les dossiers de l'opencv. Elle m'a donne les erreurs suivantes :

Citation :

CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
CUDA_cublasemu_LIBRARY (ADVANCED)
    linked by target "opencv_gpu" in directory C:/OpenCV-2.3.1/opencv/modules/gpu
CUDA_cufftemu_LIBRARY (ADVANCED)
    linked by target "opencv_gpu" in directory C:/OpenCV-2.3.1/opencv/modules/gpu
CUDA_npp_LIBRARY (ADVANCED)
    linked by target "opencv_core" in directory C:/OpenCV-2.3.1/opencv/modules/core
    linked by target "opencv_gpu" in directory C:/OpenCV-2.3.1/opencv/modules/gpu


NB: j'ai une version de CUDA 4.0 qu'elle est bien compatible avec ce version d'opencv.

mood
Publicité
Posté le 03-02-2013 à 22:14:28  profilanswer
 

n°2173949
gilou
Modérateur
Modzilla
Posté le 03-02-2013 à 22:53:23  profilanswer
 

Tu dois renseigner ton makefile (ou équivalent) sur la localisation des 3 librairies demandées au vu du message d'erreur.
A+,


---------------
Samantha Fish Rulez!     --    Iyashikei Anime Forever!    --    In umbra igitur pugnabimus. --
n°2173954
hb2012
Posté le 04-02-2013 à 00:02:36  profilanswer
 

merci Gilou, mais il m'a donné une autre version d'erreur:
IPP libs: ippvmmergedem64t.lib;ippvmemergedem64t.lib;ippccmergedem64t.lib;ippccemergedem64t.lib;ippcvmergedem64t.lib;ippcvemergedem64t.lib;ippimergedem64t.lib;ippiemergedem64t.lib;ippsmergedem64t.lib;ippsemergedem64t.lib;ippcoreem64tl.lib
Could NOT find CUDA  (missing:  CUDA_CUDART_LIBRARY)
WARNING, OpenNI library directory (set by OPENNI_LIB_DIR variable) is not found or does not have OpenNI libraries.
WARNING, OpenNI include directory (set by OPENNI_INCLUDE_DIR variable) is not found or does not have OpenNI include files.
WARNING, PrimeSensor Module binaries directory (set by OPENNI_PRIME_SENSOR_MODULE_BIN_DIR variable) is not found or does not have PrimeSensor Module binaries.
Parsing 'cvconfig.h.cmake'
ffmpeg output dir: C:/OpenCV-2.3.1/opencv/build/bin/$(Configuration)

n°2175847
marmotte.t​ranquille
Posté le 14-02-2013 à 22:36:47  profilanswer
 

T'as besoin du module GPU? Il te faut installer CUDA si tu en as besoin. Sinon tu dois pouvoir deselectionner le module avec cmake.


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  C++

  question sur l'instalation de opencv 2.3.1 avec vs2010 et CMake 2.8

 

Sujets relatifs
template matching opencvQuestion ultra débutant Lazarus.
Débutant: besoin d'aide Cmake et VS2012Utilisation de Qt/OpenCV avec Eclipse
Comment avoir une question (set /p) et la confirmation sur même ligne?question sur les tableaux croisé dans ireport
Question d'architecture (decouper ses tables au maximum ?)Allocation dynamique : question vague
rectifier quelque information sur opencvRecherche Excel / Dernier événement
Plus de sujets relatifs à : question sur l'instalation de opencv 2.3.1 avec vs2010 et CMake 2.8



Copyright © 1997-2016 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR