Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Shop Recherche
1661 connectés 

  FORUM HardWare.fr
  Réseaux grand public / SoHo
  Hébergement

  Proxmox GPU Passthrough

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Proxmox GPU Passthrough

n°1115931
isyris
Posté le 26-04-2020 à 21:15:41  profilanswer
 

Salut à tous,
En cette période de confinement, je tente de nouvelle choses, aujourd'hui j'ai donc ajouté un GPU sur mon serveur dont la config est la suivante:
 
- x8dtl-3f
- 1x xeon L5640
- 32Gb RAM
- GeForce GT640
 
Le soucis est le même sous WS2019 et W10 Pro
 
Pour ça j'ai suivi ce tuto: https://www.reddit.com/r/homelab/co [...] ssthrough/
Le problème est que la carte me renvoie un code erreur 43 une fois la config vm faite:
https://pix.milkywan.fr/ZUuFZM27.PNG
J'ai bien installé les drivers NVidia, j'en ai testé plusieurs, 395.X, 425.X, 445.X, la résultante est la même.
 
Voici ma config Proxmox:
/etc/default/grub:

Code :
  1. GRUB_CMDLINE_LINUX_DEFAULT="quiet intel_iommu=on iommu=pt pcie_acs_override=downstream,multifunction nofb nomodeset video=vesafb:off,efifb:off"


 
/etc/modules:

Code :
  1. vfio
  2. vfio_iommu_type1
  3. vfio_pci
  4. vfio_virqfd


 
/etc/modprobe.d/iommu_unsafe_interrupts.conf:

Code :
  1. options vfio_iommu_type1 allow_unsafe_interrupts=1


 
/etc/modprobe.d/kvm.conf:

Code :
  1. options kvm ignore_msrs=1


 
/etc/modprobe.d/blacklist.conf:

Code :
  1. blacklist radeon
  2. blacklist nouveau
  3. blacklist nvidia


 
/etc/modprobe.d/vfio.conf (Il s'agit bien ici de mes valeurs):

Code :
  1. options vfio-pci ids=10de:0fc1,10de:0e1b disable_vga=1


 
Config VM:
 

Code :
  1. args: -cpu 'host,+kvm_pv_unhalt,+kvm_pv_eoi,hv_vendor_id=NV43FIX,kvm=off'
  2. bios: ovmf
  3. boot: dcn
  4. bootdisk: ide0
  5. cores: 6
  6. cpu: host,hidden=1,flags=+pcid,hv-vendor-id=proxmox
  7. efidisk0: datassd01:vm-104-disk-1,size=128K
  8. hostpci0: 03:00,pcie=1,x-vga=1
  9. ide0: datassd01:vm-104-disk-0,size=128G
  10. ide2: local:iso/SW_DVD9_Win_Server_STD_CORE_2019_1809.1_64Bit_French_DC_STD_MLF_X22-02971.ISO,media=cdrom,size=4997002K
  11. machine: q35
  12. memory: 4096
  13. name: Test
  14. net0: e1000=66:6B:D7:67:5C:E2,bridge=vmbr10,firewall=1
  15. numa: 0
  16. ostype: win10
  17. scsihw: virtio-scsi-pci
  18. smbios1: uuid=e7d882e8-87a3-48f6-8b98-1f80f30a7769
  19. sockets: 1
  20. vmgenid: 282bb34c-4a7c-498c-81d3-1060122de1e9


 
Voilà tout, si quelqu'un à déjà expérimenté ça et a de l'expérience, je suis preneur :)  
 
Merci par avance,
Quentin.

mood
Publicité
Posté le 26-04-2020 à 21:15:41  profilanswer
 

n°1115970
isyris
Posté le 27-04-2020 à 10:44:26  profilanswer
 

:hello:
Personne à eu le soucis ici?


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Réseaux grand public / SoHo
  Hébergement

  Proxmox GPU Passthrough

 

Sujets relatifs
Mikrotik - Bridge Mode / IP Passthroughprobleme mise en reseaux serveur proxmox
VirtualSwitch sur ProxMoxCherche carte ethernet 2 ports avec passthrough
ProxMox & Samba - Débit faibleSamba / Windows 7 : sous proxmox
Routage nom de domaine vers machine virtuelle proxmoxCisco 851 et L2TP Passthrough
Plus de sujets relatifs à : Proxmox GPU Passthrough


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR