Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
1775 connectés 

  FORUM HardWare.fr
  Windows & Software
  Stockage/Sauvegarde

  Owncloud : Problème de performances

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Owncloud : Problème de performances

n°3387264
Arjuna
Aircraft Ident.: F-MBSD
Posté le 22-11-2020 à 09:43:44  profilanswer
 

Bonjour,

 

Possesseur d'une Freebox Delta, j'ai monté une VM dessus :
- Ubuntu 20.04.1 LTS (GNU/Linux 5.4.0-53-generic aarch64)
- 957 Mo de RAM
- 2 CPU virtuels

 

Je suis bien conscient que l'architecture est loin d'être véloce, mais je suppose, peut-être à tord que c'est amplement suffisant pour du simple stockage de fichiers.

 

J'ai donc installé Owncloud 10.5.0 dessus, avec la base MySQL.

 

Pendant longtemps il n'y avait pour ainsi dire rien dessus, et c'était parfaitement véloce.

 

Cependant, avec Google Photos qui devient payant, j'ai entrepris de mettre mes 50 Go de photos et vidéos dessus.

 

Et depuis, c'est le drame :
- le client pour Windows 10 upload une image toutes les 5-10 secondes environ
- l'interface web est interminablement lente
- le client pour Android échoue ses transferts 9 fois sur 10

 

Pourtant, si je fais des htop, iotop ou iftop, c'est relativement très calme...
- Les CPU oscillent entre 10% et 30%
- Les accès disques oscillent entre 100 KB/s et 5 MB/s
- Idem pour les accès réseau

 

D'après iftop, je passe bien par mon réseau local pour communiquer avec owncloud, pas de souci de trames qui se baladent sur internet.

 

Si je fais une copie de fichier via le partage réseau sur le disque qui héberge la VM, j'ai un taux de transfert autour de 80 MB/s donc sauf si la technologie de virtualisation est complètement merdique, ça ne vient pas de là.

 

Le truc de malade, c'est que par contre, même en putty ça ramme à mort sur la VM.

 

Côté Owncloud, il râle car j'utilise le mode de transaction basé sur MySQL qui est "le plus lent". Ok, soit, je veux bien. Mais il me propose de passer par d'autres solutions basées sur des caches mémoire, je ne peux pas me le permettre avec les 957 Mo de la VM... Idem, il râle à cause de l'absence d'un cache logiciel... même punition, je doute qu'avec la faible mémoire ça y change grand chose.

 

Des personnes ont-elles remarqués ce genre de dégradation de performances ? Comment les résoudre ?


Message édité par Arjuna le 22-11-2020 à 09:45:22
mood
Publicité
Posté le 22-11-2020 à 09:43:44  profilanswer
 

n°3387268
Arjuna
Aircraft Ident.: F-MBSD
Posté le 22-11-2020 à 10:11:59  profilanswer
 

Bon, je viens de mettre en place le cache (après tout j'avais que 50% de la RAM occupée...)
 
https://doc.owncloud.org/server/10. [...] ation.html
 
Je suis outré par la différence de performances !
 
Maintenant ça m'annonce quelques minutes pour synchroniser les 10 Go restants et le compteur d'image tourne trop vite pour pouvoir être lu...


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Windows & Software
  Stockage/Sauvegarde

  Owncloud : Problème de performances

 

Sujets relatifs
Problème partition disque durProblème Clignotement bureau windows 10
Problème d'écran noir au démarrage windowsBSOD sous Win10 : aidez moi à régler le problème ...
Problème navigateurs internetProblème installation win10 nouveau pc
Problème en lecture écriture sur lecteur de carte SDprobleme contact icloud avec office 2019
probleme pc window 10problème d'accès à 1 seul site (le taff bien entendu)
Plus de sujets relatifs à : Owncloud : Problème de performances


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR