Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1295 connectés 

  FORUM HardWare.fr
  Windows & Software
  Logiciels

  Question pointue sur Excel !!!!!!!!!!!!!!!!!!!

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Question pointue sur Excel !!!!!!!!!!!!!!!!!!!

n°1056577
toufleboss
Posté le 11-02-2003 à 19:23:38  profilanswer
 

voila j'ai n colonnes (disons 4) ou il y a par exemple :
 
4
10
2
23
 
Je voudrais pouvoir donner automatiquement le classement (ordre décroissant) du chiffre en question et mettre ce classement dans la colonne d'à côté.
 
C sûrement super simple et ça donnerais ça :
 
14 4
100 2
58 3
230 1
 
(le plus gros est 230 donc il est le premier, ensuite c'est 100 donc c'est le deuxieme, etc ...)
 
Voila si vous avez une idée ...

mood
Publicité
Posté le 11-02-2003 à 19:23:38  profilanswer
 

n°1057259
toufleboss
Posté le 12-02-2003 à 11:35:58  profilanswer
 

Up

n°1057299
fifiz
Posté le 12-02-2003 à 12:00:01  profilanswer
 

si tu as tes valeurs dans les colonnes A C E G et les classements dans les colonnes B D F H.
 
Colle la formule suivante dans ta cellule B1 puis fait une copie de la cellule dans chacune de tes cellules de classements en ligne 1 et fais une copie incrémenté du tout vers le bas ...
 
Cellule B1 :
 
Si tu ne veux que les cellules strictement supérieures :
=1+ SI($A1>A1;1;0)+SI($C1>A1;1;0)+SI($E1>A1;1;0)+SI($G1>A1;1;0)
 
Sinon supérieures ou égales :
=SI($A1>=A1;1;0)+SI($C1>=A1;1;0)+SI($E1>=A1;1;0)+SI($G1>=A1;1;0)
 
Il y a peut être une fonction qu fait ça directement mais si tu n'as pas deux cents colonnes ça fera l'affaire ...
 
A+
 
Félix


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Windows & Software
  Logiciels

  Question pointue sur Excel !!!!!!!!!!!!!!!!!!!

 

Sujets relatifs
[Excel] Comment arrondir des entiers en 0 ou en 5Question qui n'a rien a voir avec les question habituelles !!
Un handicapé d'excel demande de l'aideComment lire un fichier xls sans excel?
Partitionner sous Windows 2000 -> Question[Question] demander comment on ripp un DVD C'est parler de piratage?
Juste une question générale sur les virus ???Redemarer un serveur W2k - question
Question Outlook 2000question bete,mais sait on jamais (drivers CG)
Plus de sujets relatifs à : Question pointue sur Excel !!!!!!!!!!!!!!!!!!!


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR