Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
891 connectés 

  FORUM HardWare.fr
  Windows & Software
  Logiciels

  [EXCEL] question sur fonction "recherchev"

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[EXCEL] question sur fonction "recherchev"

n°3134984
sbaq
Posté le 05-08-2014 à 18:08:25  profilanswer
 

Bonjour à tous,
 
j'ai besoin d'utiliser la fonction recherchev pour aller chercher des données et d'habitude je l'utilise sans problème.
 
Toutefois ici j'ai un souci avec la plage de données à l'intérieur de laquelle la fonction va chercher les données correspondantes. En effet toutes les semaines la feuille de calcul de la plage de données change.
 
J'aimerais donc m'éviter de retaper toutes les semaines le nouvel onglet au sein duquel la fonction va chercher les données.
 
Je précise que la plage de données reste toujours la même, mais pas l'onglet.
 
Par exemple :

Citation :

=RECHERCHEV(A3;'29 JUILL'!$B$6:$P$39;10;FAUX)


 
A la place de 29 JUILL, j'aimerais simplement faire apparaître 5 AOÛT, j'avais pensé à un INDIRECT (A1), où j'aurais tapé le nom du nouvel onglet en A1, mais ça ne fonctionne pas.
 
Et il y a pas mal de recherchev donc j'aimerais ne pas faire la modif toutes les semaines et à la main...
 
Si quelqu'un a compris mon problème et peux m'aider, je vous écoute :)
 
Merci !

mood
Publicité
Posté le 05-08-2014 à 18:08:25  profilanswer
 

n°3135045
seniorpapo​u
Posté le 06-08-2014 à 10:59:18  profilanswer
 

Bonjour,
=RECHERCHEV(A3;INDIRECT("'"&A1&"'!$b$6:$p$39" );10;FAUX)
 
Attention aux espaces dans le nom des feuilles..
 
Cordialement

n°3135046
olivthill
Posté le 06-08-2014 à 11:01:45  profilanswer
 

Je pense aussi que Indirect est la solution. C'est curieux que ça ne marche pas. C'est peut-être un problème, d'apostrophe, de guillemet ou d'esperluette.
Essayer :

=RECHERCHEV(A3;INDIRECT("'"&A1&"'!$B$6:$P$39" );10;FAUX)


(Je m'inspire de la solution qui est donnée là : http://www.commentcamarche.net/for [...] t-indirect )
 
Edit : seniorpapou a été plus rapide que moi.


Message édité par olivthill le 06-08-2014 à 11:03:15
n°3135076
seniorpapo​u
Posté le 06-08-2014 à 14:38:51  profilanswer
 

bonjour olivthill,
je préfère l'affichage de ta ligne où l'on distingue mieux les " et les '
 
Cordialement


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Windows & Software
  Logiciels

  [EXCEL] question sur fonction "recherchev"

 

Sujets relatifs
création macro excel vers TXTFormule excel
Excel - Fichier avec mot de passe sur USBExcel : fonction INDIRECT sur une colonne et erreur #ref!
Question sur le changement de PcCartes dans excel ??
partager un fichier excelfaire un fichier excel ou word avec mes musiques
Plus de sujets relatifs à : [EXCEL] question sur fonction "recherchev"


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR