Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
2476 connectés 

  FORUM HardWare.fr
  Windows & Software
  Logiciels

  Problème fonction excel

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Problème fonction excel

n°3328349
julialuc
Salut !
Posté le 15-11-2018 à 11:38:57  profilanswer
 

Bonjour à tous !
 
J'ai besoin de votre aide pour une fonction excel !
 
Pour vous expliquer, j'ai un tableau avec une colonne "motif" qui comprend "AT" pour accident de travail ou "ATJ" pour accident de trajet.
J'ai une autre colonne "année de l'accident" qui, vous l'aurez compris, comprend uniquement l'année, par exemple "2012".
Je cherche à faire une fonction qui dirait en gros : Si c'est un AT et qu'il a eu lieu en 2012, alors mettre 1 sinon 0.
J'ai utilisé la fonction suivante :  
=SI(ET(SAISIE_ACCIDENTS!H4:H8="AT";SAISIE_ACCIDENTS!J4:J8="2012" );"1";"0" ).
Mais cela me met "0" alors que l'accident est bien un AT et qu'il a bien eu lieu en 2012. Ce qui logiquement devrait me mettre "1".
 
Peut-être ma formule n'est-elle pas la bonne ??
 
Merci d'avance pour votre aide !

mood
Publicité
Posté le 15-11-2018 à 11:38:57  profilanswer
 

n°3328350
mbl
Posté le 15-11-2018 à 14:35:47  profilanswer
 

Quel rapport avec l'actualité ?


---------------
-3dB
n°3328351
fdaniel
Have you got a 27B/6 ?
Posté le 16-11-2018 à 10:46:54  profilanswer
 

Ce sujet a été déplacé de la catégorie Discussions vers la categorie Windows & Software par Fdaniel


---------------
Topic des restos / Topic des boutiques gastronomiques
n°3328370
satoshi
Posté le 16-11-2018 à 12:21:05  profilanswer
 

:hello:
 
une chose toute bête, mais l'année est considérée comme un chiffre, donc la condition logique ne requiert pas de "" :)
 
essaie plutôt:
=SI(ET(SAISIE_ACCIDENTS!H4:H8="AT";SAISIE_ACCIDENTS!J4:J8=2012 );"1";"0" )
 
note: tu n'es pas obligé de déclarer ton tableau entier dans la formule et simplement utiliser un $ pour bloquer la colonne
 
=SI(ET(SAISIE_ACCIDENTS!$H4="AT";SAISIE_ACCIDENTS!$J4=2012 );"1";"0" )
 
quand tu glisseras la formule dans la colonne, ça se mettra à jour automatiquement:
=SI(ET(SAISIE_ACCIDENTS!$H5="AT";SAISIE_ACCIDENTS!$J5=2012 );"1";"0" )
 
puis
=SI(ET(SAISIE_ACCIDENTS!$H6="AT";SAISIE_ACCIDENTS!$J6=2012 );"1";"0" )
 
etc... :)


Message édité par satoshi le 16-11-2018 à 12:21:45
n°3328404
DjiDji5943​0
Posté le 16-11-2018 à 16:19:51  profilanswer
 

Bonjour,
 
on met 1 ou 0, pas avec des guillemets car ça devient un texte  (par exemple, si tu veux faire la somme des at en 2012, tu ne peux pas faire la somme de tes "1", ça va te donner #valeur!
 
Crdlmt


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Windows & Software
  Logiciels

  Problème fonction excel

 

Sujets relatifs
Problème de démarrage Windows 10Recherche classeurs Excel avec liaisons
[EXCEL 2016] Ajouter une condition à plusieurs formules en meme tempsProblème "écran principal"
probleme de fonction sous excelProblème Excel 2011 / Fonction Solver (MAC)
[Excel] Problème pour des courbes en fonction d'un pourcentageprobleme en utilisant un fonction word : tableau excel
[Excel] probleme fonctionprobleme sous Excel (fonction SI ?? fonction filtre ??)
Plus de sujets relatifs à : Problème fonction excel


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR