Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
765 connectés 

  FORUM HardWare.fr
  Windows & Software
  Logiciels

  Faire réagir fonction personnelle VBA Excel comme les fonctions native

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Faire réagir fonction personnelle VBA Excel comme les fonctions native

n°2977798
magiczorro​1
Posté le 17-01-2011 à 13:55:17  profilanswer
 

Bonjour,
Concernant les fonctions natives EXCEL qui font référence à des cellules, vous l'avez sans doute remarqué lors de leur utilisation, on peut rentrer :
sur la cellule B1 par exemple : =A1 (fonction la plus simple)
                        puis en B2 :  =A2
 
Et ainsi de suite... jusqu'à Bxxxx : =Axxxx
 
Cette façon d'écrire les fonctions peut être remplacée de manière strictement identique quant au résultat par :
En B1: =A:A
Jusqu'à Bxxxx : =A:A
 
Cela permet de gagner en mémoire utilisée et aussi en confort de lecture par exemple pour une fonction comme celle-ci :
=RECHERCHEV($D:$D;$D$1:F$140;F$142;FAUX)/RECHERCHEV($D:$D;$D$1:$E$140;2;FAUX)*$E:$E
 
Ma question est donc la suivante : je souhaiterais faire la même chose avec une fonction personnelle, par exemple celle-ci :
 
Public Function FPERSO(nombre)
FPERSO = (nombre+2)
End Function
 
Quelle est l'astuce pour y arriver.
 
Merci pour votre réponse

mood
Publicité
Posté le 17-01-2011 à 13:55:17  profilanswer
 

n°2977958
billgatesa​nonym
Posté le 18-01-2011 à 12:24:48  profilanswer
 

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Windows & Software
  Logiciels

  Faire réagir fonction personnelle VBA Excel comme les fonctions native

 

Sujets relatifs
Formule sous Excel...Excel, ne pas entrer une info 2 fois.
Excel 98 - modifier liste déroulanteexcel bloqué
[Excel] - windows searchTravailler à 2 à distance sur un meme fichier Excel
Réalisation d'un graphique sous Excelenvoie de fax à partir d'une liste excel
Fonction ajustement fenêtres marche plusbesoin d'aide pour un tableau excel
Plus de sujets relatifs à : Faire réagir fonction personnelle VBA Excel comme les fonctions native


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR