Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1493 connectés 

  FORUM HardWare.fr
  Windows & Software
  Logiciels

  Excel : fonction si et *

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Excel : fonction si et *

n°2490396
goran
Posté le 16-08-2006 à 17:34:06  profilanswer
 

Bonjour,
 
Sous Excel, dans une une fonction si je voudrais lui faire utiliser un caractère générique. Par exemple je lui dis que si dans la cellule b2 il me trouve Michel ou Marchel il me met "lettre M"
 
UN truc du genre:  =SI(B2="M*";"Lettre M";"PAs lettre M)
 
Sauf qu'avec ça il m'affiche lettre M seulement si je le dans B2 j'ai M*.
 
Merci de votre aide.

mood
Publicité
Posté le 16-08-2006 à 17:34:06  profilanswer
 

n°2490517
Prozac
Tout va bien
Posté le 16-08-2006 à 19:21:18  profilanswer
 

Tu veux seulement spécifier la 1ere lettre ou n'importe quelle lettre dans la cellule ? Ou même une chaine de caractère ?


---------------
La ligne droite n'est en aucun cas le plus court chemin entre deux points. Sauf, bien sûr, si les deux points sont bien alignés l'un en face de l'autre
n°2490554
goran
Posté le 16-08-2006 à 19:51:45  profilanswer
 

seulement la première lettre

n°2490561
Prozac
Tout va bien
Posté le 16-08-2006 à 20:06:05  profilanswer
 

alors tu peux essayer un
=SI(GAUCHE(B2,1)="M","M","" )


---------------
La ligne droite n'est en aucun cas le plus court chemin entre deux points. Sauf, bien sûr, si les deux points sont bien alignés l'un en face de l'autre
n°2490601
goran
Posté le 16-08-2006 à 20:54:47  profilanswer
 

Merci Beaucoup Prozac ça marche !!

n°2490616
TAM136
Posté le 16-08-2006 à 21:36:43  profilanswer
 

Bonsoir
 
Ça m'intéresse mais j'ai du louper quelque chose parce que ça ne marche pas chez moi.Vous pouvez me dire comment vous faites?
 
Merci

n°2490878
Prozac
Tout va bien
Posté le 17-08-2006 à 10:28:44  profilanswer
 

ben à part vérifier que tu as bien une version française et que le séparateur des arguments des fonctions est "," et non pas ";" (ce qui arrive parfois), il suffit d'appliquer la formule que j'ai écrite, 0 mystères
 
sinon il va falloir décrire comment ça ne marche pas

n°2491030
TAM136
Posté le 17-08-2006 à 12:32:19  profilanswer
 

Je ne fais qu'un copier/coller de ta formule.Par contre, peut-être que je me trompe de cellule quand je colle.Si Michel est en B2, où est-ce que je dois coller la formule?
 
Merci
 
 

n°2491068
Prozac
Tout va bien
Posté le 17-08-2006 à 13:08:50  profilanswer
 

Ben n'importe où
si tu as ta liste de noms dans la colonne a:a, tu peux la coller en B1 et recopier vers le bas, ça marche


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Windows & Software
  Logiciels

  Excel : fonction si et *

 

Sujets relatifs
Publipostage entre Excel et WordExcel : Fonction SI() imbriquée supérieure à 7 !!
[excel] Valeur majoritaire, non numérique[Excel] Cellules invisibles
GRAPHIQUE SOUS EXCEL 2003[Excel] nb de valeurs distinctes apres filtrage
excel et ses couleursExcel cellule verouillé
[Excel] Double liste déroulante 
Plus de sujets relatifs à : Excel : fonction si et *


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR