Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1027 connectés 

  FORUM HardWare.fr
  Windows & Software
  Logiciels

  [EXCEL] Comparer dans excel

 


 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[EXCEL] Comparer dans excel

n°2711898
bobludovic
Posté le 10-08-2007 à 11:54:27  profilanswer
 

Bonjour
Je viens de faire une extraction LDAP de l'annuaire de l'entreprise dans une feuille excel avec le nom du compte et leur identifiant de compte.
De l'autre côté j'ai une seconde feuille avec les comptes de messagerie avec leur identifiants
 
Et donc j'aimerais faire une comparaison de cellules afin de trouver les messageries sans compte dans excel
 
Je ne sais pas comment faire
Je me suis penché sur le VBA et j'en ai jamais fait de ma vie, donc ca me parait compliqué de premiere abord
Quelqu'un aurait il une solution?
Je vous remercie d'avance


Message édité par bobludovic le 10-08-2007 à 11:54:54
mood
Publicité
Posté le 10-08-2007 à 11:54:27  profilanswer
 

n°2712124
seniorpapo​u
Posté le 11-08-2007 à 07:12:09  profilanswer
 

Bonjour,
peux-tu donner deux extraits (réels ou non) de chaque feuille, et la manière dont tu veux récupérer ton information: liste, couleur, croix dans une case, etc...
Cordialement

n°2712727
bobludovic
Posté le 13-08-2007 à 09:03:13  profilanswer
 

BOnjour
Alors sur mon premier classeur j'ai :
- Login
- mail
- nom d'utilisateur
- nom agence
 
Sur le second classeur j'ai :
- mail
- nom d'utilisateur
 
Et j'aimerais en faites qu'il me mette en vert ceux qu'il aura retrouvé dans chaque feuille et en rouge ceux qu'il n'a pas trouvé de correspondance

n°2712738
Bazile
Posté le 13-08-2007 à 10:09:03  profilanswer
 

Salut,
 
Regarde l'aide excel sur les fonctions "recherche" et "recherchev" et tu devrais t'en sortir.

n°2713131
bobludovic
Posté le 14-08-2007 à 13:37:44  profilanswer
 

salut
Justement j'avais déjà regardé et pour l'instant j'ai fait chou blanc


Message édité par bobludovic le 14-08-2007 à 13:38:00
n°2713143
seniorpapo​u
Posté le 14-08-2007 à 14:47:01  profilanswer
 

Bonjour,
a) en  C1 de feuil2, par exemple, tu mets la formule: = feuil1!b1 et tu étends.
 
b) selection de la colonne A de feuil2  , format conditionnel
la formule est : =RECHERCHEV(A1;C:C;1;FAUX)=A1
format tu choisis la couleur pour existe
puis Ajouter
la formule est :=RECHERCHEV(A1;A:A;1;FAUX)=A1
format...la couleur par défaut  
 
un inconvénient: les cases vides sont de la couleur existe
Cordialement
edit : pour éviter le pb, il suffit de mettre en première condition: valeur de la cellule     inférieure à    =" "


Message édité par seniorpapou le 14-08-2007 à 14:58:36
n°2875086
marccolson
Posté le 09-07-2009 à 16:54:39  profilanswer
 

bobludovic,
je suppose que depuis le temps, tu as trouvé une solution à ton problème.
Néanmoins, je suis sûr que le site XLComparator répondrait parfaitement à ce type de problématique.
C'est un outil gratuit qui permet de comparer 2 feuilles Excel dans macro ni installation d'outil sur l'ordinateur.


---------------
Marc - L'annuaire des stations GPL - http://stations.gpl.online.fr/

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Windows & Software
  Logiciels

  [EXCEL] Comparer dans excel

 

Sujets relatifs
Excel, fichier qui ne s'ouvre plus aprés déplacementfonction excel
Filtrer les * dans un tableau excel [résolu][Urgent] Recuperer un fichier excel corrompu
Excel - Classement automatique[Excel] Concatener avec sauts de lignes ?
[OpenOffice] Probleme de Tri de données dans un tableur[Excel] comparer deux listes
Comparer deux courbes sous excelComparer & Fusionner 2 Doc Excel
Plus de sujets relatifs à : [EXCEL] Comparer dans excel


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR