Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1370 connectés 

  FORUM HardWare.fr
  Windows & Software
  Logiciels

  [Résolu] [Excel] Comptage d’occurrences complexe

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[Résolu] [Excel] Comptage d’occurrences complexe

n°3203157
Dilat Lara​t
Pseudo débile je sais
Posté le 28-09-2015 à 18:19:21  profilanswer
 

Bonjour, je vous soumets un problème...
Pour un travail de thèse je me retrouve avec un fichier excel issu de la compilation des réponses données à un formulaire Google Forms.
Chaque répondant a ses réponses retranscrites sur une même ligne, chaque colonne correspondant à la réponse à une question.
Admettons que le questionnaire est comme suit :
1/ Réponse : Bleu, Blanc ou Rouge
2/ Réponse : Carré ou Rond
3/ Réponses multiples possibles : Un chien, Une poule, Un coq ou Un renard
 
J'aimerai compter le nombre de fois ou un répondant a répondu à la fois "Bleu" à la question 1, "Carré" à la question 2 et "Renard" à la question 3.  
 
Etant donné que dans la cellule de la 3e question cela peut se présenter sous la forme "Renard" ou "Renard, Poule, Chien" ou encore "Poule, Coq" etc. , il peut avoir répondu "Bleu", "Carré" et "Chien, Renard" : ça doit le compter aussi !
 
J'espère avoir été clair  :)
Merci !
 
le fichier d'illustration :  
http://paf.im/R1kpG


Message édité par Dilat Larat le 29-09-2015 à 19:57:31

---------------
Ma petite galerie photo :)
mood
Publicité
Posté le 28-09-2015 à 18:19:21  profilanswer
 

n°3203173
DjiDji5943​0
Posté le 28-09-2015 à 19:45:12  profilanswer
 

Bonjour,
 
un essai
 
http://www.cjoint.com/c/EICrSXUbLDY
 
Crdmt

n°3203180
Dilat Lara​t
Pseudo débile je sais
Posté le 28-09-2015 à 20:08:07  profilanswer
 

Bonjour, je ne vois pas de modif sur le fichier :??:


---------------
Ma petite galerie photo :)
n°3203188
DjiDji5943​0
Posté le 28-09-2015 à 21:00:31  profilanswer
 

re
excuses  
en E1 en jaune, nada ?
je remets le fichier.
http://www.cjoint.com/c/EICs60aJhIY

n°3203192
Dilat Lara​t
Pseudo débile je sais
Posté le 28-09-2015 à 21:28:25  profilanswer
 

Là je l'ai, mais ça ne fonctionne pas, si on met "coq" à la place de "renard" le résultat est encore égal à 3


---------------
Ma petite galerie photo :)
n°3203229
DjiDji5943​0
Posté le 28-09-2015 à 23:01:55  profilanswer
 

Je regrette, ça fonctionne chez moi.
http://www.cjoint.com/c/EICvaNaC7YY

n°3203234
Dilat Lara​t
Pseudo débile je sais
Posté le 28-09-2015 à 23:34:04  profilanswer
 

:sweat:  
Tout d'abord merci, mais je suis toujours embêté, et je pense que l'erreur vient de moi.
Pour changer le mot recherché, je dois bien modifier directement ce qui est entre parenthèse après CHERCHE, non ?
=SOMMEPROD((A1:A8="bleu" )*(B1:B8="carré" )*(SIERREUR(CHERCHE("renard";C1:C8)<>0;FAUX)))
 
Ou cette façon de faire m'amène t elle à engendrer un bug ?
car je n'arrive pas au bon résultat dès que je veux changer le mot recherché...
Si vous pouviez m'expliquer ça serait super...


---------------
Ma petite galerie photo :)
n°3203324
DjiDji5943​0
Posté le 29-09-2015 à 13:46:03  profilanswer
 

re
Tu n'as pas fait attention que la formule est matricielle.
http://www.cjoint.com/c/EIDlTRxg3dY

n°3203349
Dilat Lara​t
Pseudo débile je sais
Posté le 29-09-2015 à 15:59:37  profilanswer
 

Un immense MERCI :bounce:  
 
Effectivement je ne connaissais pas cette manip et tout s'éclaire !
Vous serez dans les remerciements de ma thèse ;)


---------------
Ma petite galerie photo :)
n°3203363
Benoit6363
Posté le 29-09-2015 à 16:40:05  profilanswer
 

Bonjour,
 
J'ai modifié la formule de djidji59430
pour éviter d'utiliser la formule matricielle.
 

Code :
  1. =SOMMEPROD((A1:A8="bleu" )*(B1:B8="carré" )*(ESTNUM(CHERCHE("renard";C1:C8))))


 
Cordialement


Message édité par Benoit6363 le 29-09-2015 à 16:40:41
mood
Publicité
Posté le 29-09-2015 à 16:40:05  profilanswer
 

n°3203376
Dilat Lara​t
Pseudo débile je sais
Posté le 29-09-2015 à 17:41:23  profilanswer
 

Excellent, merci


---------------
Ma petite galerie photo :)

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Windows & Software
  Logiciels

  [Résolu] [Excel] Comptage d’occurrences complexe

 

Sujets relatifs
[EXCEL] Mise en forme à partir de plusieurs feuillesRegrouper adresses e-mails Excel avec des points virgules
formule [EXCEL] avec datesExcel - graphes secteurs - choix données
[Excel] Retrouver noms dans plusieurs listesExcel ne peut pas terminer cette tâche avec les ressources disponibles
EXCEL : Comment lier une cellule à un nom d'onglet ?XML et Excel
[excel]affichage dans cellule excel
Plus de sujets relatifs à : [Résolu] [Excel] Comptage d’occurrences complexe


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR