Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1362 connectés 

  FORUM HardWare.fr
  Programmation

  [ PHP ]Helpez moi!G un prb a propos d'envoi de donnée sur mysql

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[ PHP ]Helpez moi!G un prb a propos d'envoi de donnée sur mysql

n°105713
sanosuke
JEHUTY
Posté le 27-02-2002 à 19:34:59  profilanswer
 

Salut !!
 
G un gros problème , je suis sur multimania et j'essaye de créer une page qui pourra rajouter des membres à mon site grace à une base de donnée MySQL ... Le problème c'est que quand j'envoi des donnée grâce à ce formulaire :
 
<form method="POST" action="add.php3">
<center>
 Prenom :   <input type="text" name="prenom" size="20" maxlength="35">
</center>
</form>
                    <form method="post" action="add.php3">
                        <p align="center">
Pseudo :    <input type="text" name="pseudo" size="20" maxlength="35"></p>
                        <p align="center">
Password : <input type="password" name="pass" size="20" maxlength="8"> </p>
                        <p align="center"> Email :     <input type="text" name="mail" size="20" maxlength="50"></p>
                        <p align="center"><input type="submit" value="Envoyer" name="envoyer"></p>
            </ul>
                </form>
 
 
et lorsqu'il accede à la page add.php3 qui est celle ci :
 
<?  
 
    {  
    $db = mysql_connect('localhost', 'chaieb', '53667410';);  
    mysql_select_db('chaieb',$db);                  
     
    $sql = "INSERT INTO users_tbl VALUES('','$prenom','
;$pseudo','$pass','$mail&
#039;)";  
     
    mysql_query($sql) or die('Erreur SQL !'.$sql.'<br>'.mysql_error());  
 
    echo 'Vos infos on été ajoutées.';  
 
    mysql_close();  
    }  
?>  
 
il me marque ceci :  
 
Erreur SQL !INSERT INTO users_tbl VALUES('','','sanosu
ke','****'zeombric@caramail.com
';)
Table 'chaieb_db.users_tbl' doesn't exist
 
donc voila ..... La base que multimania m'a donné s'appelle "chaieb" et j'avai créé une table se nommant "users" ... Alors ou est le problème ??? arg help !!!
 
Valaaaaaaaa marci d'avoir tout lu (pour ceux qui en on eu le courage ;) et merci kan mm a ceux qui ont tenté de lire ( je me doute que ca doit etre surement tres chiant de lire ce genre de demande au secour venant d'un newbie :)

mood
Publicité
Posté le 27-02-2002 à 19:34:59  profilanswer
 

n°105716
massanu
Posté le 27-02-2002 à 19:36:41  profilanswer
 

le nom des base sous multimania sont comme ca :
 
login_db


---------------
Oui je sais, je suis une merde en orthographe et alors ? Altcoin list: https://docs.google.com/spreadsheet [...] =286417424
n°105720
sanosuke
JEHUTY
Posté le 27-02-2002 à 19:41:22  profilanswer
 

massanu a écrit a écrit :

le nom des base sous multimania sont comme ca :
 
login_db  




 
euh oui effectivement , j'avais oublié le _db :-p

n°105742
Tentacle
Posté le 27-02-2002 à 20:20:50  profilanswer
 

sanosuke a écrit a écrit :

 
 
euh oui effectivement , j'avais oublié le _db :-p  




 
le problèmes est résolu??
parce que sinon je vois pas pourquoi tu as mis users_tbl alors que tu parles d'une table 'users' ? c une erreur de frappe?
Sinon es-tu sûr d'avoir cette table?

n°105763
sanosuke
JEHUTY
Posté le 27-02-2002 à 21:48:17  profilanswer
 

non je n'ai toujours pas pigé ce k'il fallait marquer ..... qu'est ce ke je dois changer et par quoi ?? :(

n°105766
Tentacle
Posté le 27-02-2002 à 21:53:24  profilanswer
 

sanosuke a écrit a écrit :

non je n'ai toujours pas pigé ce k'il fallait marquer ..... qu'est ce ke je dois changer et par quoi ?? :(  




 
bah déjà as-tu crée la table users??
Si oui, dans ta requête, remplace users_tbl par users.
Sinon, bah crée la via phpmyadmin

n°105775
sanosuke
JEHUTY
Posté le 27-02-2002 à 22:09:43  profilanswer
 

Tentacle a écrit a écrit :

 
 
bah déjà as-tu crée la table users??
Si oui, dans ta requête, remplace users_tbl par users.
Sinon, bah crée la via phpmyadmin  




 
oui je l'ai créé pourtant .... Ca m'enerve :( bon ! y'a pas un problème dans le code ?
 
merci d'avoir essayer de m'aider et encore + merci si qqn trouve le moyen de remedier a ce probleme (marre d'etre un newbie ! )

n°105778
Tentacle
Posté le 27-02-2002 à 22:15:59  profilanswer
 

sanosuke a écrit a écrit :

 
 
oui je l'ai créé pourtant .... Ca m'enerve :( bon ! y'a pas un problème dans le code ?
 
merci d'avoir essayer de m'aider et encore + merci si qqn trouve le moyen de remedier a ce probleme (marre d'etre un newbie ! )  




 
mmm tu peux récapituler ceci:
la requête qui foire,
l'erreur,
le nom de ta base de données,
le nom de ta table
(et vérifie à faire d'erreurs, genre users_tbl et users :)


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation

  [ PHP ]Helpez moi!G un prb a propos d'envoi de donnée sur mysql

 

Sujets relatifs
[PHP] Affichage texte TRONQUER - eXPlication INSIDEOù trouver des scripts PHP tout fait ?
[PHP] générer un nombre aléatoire...[PHP-MY SQL]Requete récupéré champs de la BD
[PHP] graphique et symbole euro[PHP] Perte des variables de sessions
Connexion à MySQL en PHP sous Linux[PHP/MYSQL]Multimania et les SESSIONS
Plus de sujets relatifs à : [ PHP ]Helpez moi!G un prb a propos d'envoi de donnée sur mysql


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR