Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1033 connectés 

  FORUM HardWare.fr
  Programmation
  XML/XSL

  Problème XML et XSL

 


 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Problème XML et XSL

n°2076877
JeanMarcDu​sse
Posté le 18-05-2011 à 16:53:56  profilanswer
 

Salut
 
J'ai un problème depuis plusieurs jours avec ma feuille de style XSL et je trouve pas de solution.
 
 
Dans mon fichier XML, j'ai ce qui suit :  
 
 
<sf>../soundfile1.mp3</sf>  
<sf>../soundfile2.mp3</sf>
<sf>../soundfile3.mp3</sf>
 
et je voudrais qu'avec ma feuille de style XSL, sur la page web finale, on voie une icône par fichier son (icône en png ou jpg représentant un petit haut-parleur, toujours la même image) et que quand on clique sur cette icône, ça lise le fichier son correspondant.
 
Mais je sais pas trop quoi écrire dans ma feuille de style. Jusqu'à présent j'ai ça :
 
<xsl:template match="sf">
 
<img src="../sound-icon.png" onclick="javascript:BatmoAudioPop('<xsl:value-of select="."/>',this.href,'1')"/>
 
</xsl:template>
 
...mais ça marche pas, et je ne sais pas ce que je dois changer pour que ça marche...
 
Quelqu'un peut-il m'aider, en me disant ce que je dois écrire dans ma feuille XSL? J'ai vraiment du mal à trouver la solution, je me casse la tête depuis plusieurs jours.
 
Mille mercis

mood
Publicité
Posté le 18-05-2011 à 16:53:56  profilanswer
 

n°2115954
sensy222
Posté le 10-12-2011 à 22:33:24  profilanswer
 

<<?xmlversion='1.0" ? encoding="utf-8" ?>
<cartevisite>
<nom>ROBERT</nom>
<prenom>Joseph</prenom>
<societe>Societe</societe>
<fonction>Représentant</fonction>
<adresse>Adresse</adresse>
<ville>Fort-de-France</ville>
<codepostal>97200</codepostal>
<rue>BLV Général de Gaulle</rue>
<numtelephone>0596640794</numtelephone>
<numportable>Num Portable</numportable/>
<numfax>Num Fax</numfax>
<email>Email</email>
<cartevisite/>
 
Je sais qu'il faut fermer certaine balise, quand je le fait, je n'est aucun résultat lorsque j'ouvre mon fichier XML avec internet. Pouvez-vous m'aidez SVP  
 
Merci

n°2115991
gilou
Modérateur
Modzilla
Posté le 11-12-2011 à 12:04:10  profilanswer
 

sensy222 a écrit :

<<?xmlversion='1.0" ? encoding="utf-8" ?>
<cartevisite>
<nom>ROBERT</nom>
<prenom>Joseph</prenom>
<societe>Societe</societe>
<fonction>Représentant</fonction>
<adresse>Adresse</adresse>
<ville>Fort-de-France</ville>
<codepostal>97200</codepostal>
<rue>BLV Général de Gaulle</rue>
<numtelephone>0596640794</numtelephone>
<numportable>Num Portable</numportable/>
<numfax>Num Fax</numfax>
<email>Email</email>
<cartevisite/>

[:mike hoksbiger:3]  
Faudrait un minimum se relire avant de poster ici, parce que les erreurs sont évidentes.
A+,


---------------
There's more than what can be linked! --    Iyashikei Anime Forever!    --  AngularJS c'est un framework d'engulé!  --

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  XML/XSL

  Problème XML et XSL

 

Sujets relatifs
[XML/XSL]Problème avec aply template ou autre choseProblème transfo XSL avec API Java 1.5 + SAX + XML avec namespace
problème avec XSL pour générer HTML à partir de XMLXML/XSL Probleme de vitesse d'execution Javascript
[ XML - XSL ] Probleme avec mes Pieds de page...probleme accent php5 avec XML/XSL
Problème XML/XSL sous firefox[XML/XSL]génération d'un XML a partir d'un XML par XSL probleme
[XML/XSL] [WIP] Gestionnaire de liens (1er problème résolu !)[XML/XSL]probleme de lien
Plus de sujets relatifs à : Problème XML et XSL


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR