Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1437 connectés 

  FORUM HardWare.fr
  Programmation
  VB/VBA/VBS

  Recherche tableau

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Recherche tableau

n°1963645
palou26
Posté le 06-02-2010 à 21:11:34  profilanswer
 

Bonjour,  
Je bloque sur un problème de recherche de valeur dans un tableau...  
Je vous mets en lien un fichier excel correspondant exactement à mon problème ( malgré la catégorie j'aimerais résoudre ce problème sans utiliser VBA ):  
http://www.cijoint.fr/cjlink.php?f [...] nHsVWLf.xl sx  
 
Les données correspondant à l'entreprise A, sont disposées mois par mois et horizontalement fonction du temps.  
De même pour l'entreprise B.  
De plus une date choisie par l'utilisateur est fixée, en K1 : Par exemple 12/02/2010.  
Comment afficher en K5, la valeur correspondant pour l'entreprise A, cad G12 et en K6, la valeur correspondante pour l'entreprise B, cad G46 .  
 
J'aimerais que seule la date K1 soit variable, et que les formules utilisées fonctionnent quelque soit le mois choisi autrement dis quelque soit la colonne de date .  
 
Il faut noter aussi que le tableau sera complété par le mois de Mars Avril... et il faut prendre en compte que dans la liste de date il n'a ni les samedi ni les dimanche...  
 
Cela fait longtemps que je cherche et n'aboutis pas...  
Merci de votre aide

mood
Publicité
Posté le 06-02-2010 à 21:11:34  profilanswer
 

n°1963744
satirik
Posté le 07-02-2010 à 18:56:29  profilanswer
 

tu peux utiliser un truc du genre
 
=INDEX(G1:G44;MATCH(K1;E1:E44;0);1)
 
pour chaque colonne des mois, donc t'auras 1 résultat par colonne (match fonctionne pas avec une zone apparamment) et apres tu fais des tests sur chaque colonnes pour prendre celui qui n'a  pas d'erreur
 
=IF(NOT(ERROR.TYPE(K5)=7);K5;IF(ERROR.TYPE(L5)=7;L5;...))
 
sinon tu fais une petite fonction vba de 4 ou 5lignes de code

n°1963775
palou26
Posté le 07-02-2010 à 21:08:46  profilanswer
 

Merci satirik,
j'ai finalement opté pour une fonction DECALER et RECHERCHEV du type
 
=RECHERCHEV($H$1;DECALER($A$51:$K$70;0;(MOIS($K$1)-1)*3);7;FAUX)


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  VB/VBA/VBS

  Recherche tableau

 

Sujets relatifs
Recherche dans tableau et copie de lignesRecherche dans tableau multi dimension Excel
Recherche d'élément dans un tableau[C#] Recherche dans un tableau
Probleme recherche tableau[PHP] Recherche d'un module pour création de tableau du style Excel
Tri et recherche des occurences d'un tableau de données[RESOLU] recherche sql, tableau php
Tableau [ ] [ ] --- recherche des indices (x,y)recherche tableau
Plus de sujets relatifs à : Recherche tableau


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR