Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Shop Recherche
700 connectés 

  FORUM HardWare.fr
  Programmation
  VB/VBA/VBS

  Fonction FormulaR1C1 qu ine marche pas tout les jours

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Fonction FormulaR1C1 qu ine marche pas tout les jours

n°1279733
molarisapa
Posté le 09-01-2006 à 17:58:43  profilanswer
 

Bonjour,
 
je travaille avec Excel et ses macros. Ca ressemble a du VB, c'est pour ca que je suis venu ici  
Je souhaiterai faire une fonction macro qui calcul un total dans un tableau.
 
Pour cela je fais "enregistrer la macro". ensuite a l'ecran je fais les étapes de ma requete. Puis je stope l'enregistrement.  
Excel ma généré une macro de la sorte:
 
Sub Macro1()
'
' Macro1 Macro
' Macro enregistrée le 09/01/2006 par opala
'
    Range("B17" ).Select
    ActiveCell.FormulaR1C1 = "=SUM(R[-12]C:R[-1]C)"
End Sub
 
Quand j'execute cette macro. le calcul se passe tres bien. Malheureusement, si j'insert ce code dans une fonction inclus dans mon fichier globale.xlm, fichié regroupant toutes les fonctions, j'ai une erreur à l'exécution:
'Erreur d'éxécution '1004' Erreur définie par l'application ou par l'objet'
 
Quand je fais un dégogage, l'appli s'arrete sur la formule FormulaR1C1
 
Merci pour vos réponses concernant mon problème
Molarisapa

mood
Publicité
Posté le 09-01-2006 à 17:58:43  profilanswer
 

n°1279748
molarisapa
Posté le 09-01-2006 à 18:34:19  profilanswer
 

c'est bon. j'ai trouvé.
je n'utilise pas Forumula, mais tout simplement:
 
Range("B17" ) = "=SOMME(B5:B16)"
 
par contre j'ai du mettre SOMME au lieu de SUM, donc je me demande si ma macro sera compatible avec une version US de Excel
 
Molarisapa

n°1649804
tuxbleu
renie ses origines
Posté le 27-11-2007 à 18:04:14  profilanswer
 

Je up ce thread car j'ai besoin d'aide pour un problème identique :  
 
Mon but est, dans une macro, d'insérer à chaque ligne à la colone 5 une formule "=rechercheV(mon_numéro_de_ligne:colonne_1 ; zonne_de_recherche;...)"
avec numéro de ligne qui est une variable, puisque cette formule est dans une boucle.
 
J'ai essayé des tonnes de trucs style :
 

Worksheets(famille).Cells(z, 5).Select
ActiveCell.FormulaR1C1Local = "=RECHERCHEV(Cells(z, 1);commentaires!A:B;2;FAUX)"


 
Mais rien n'y fait.
 
Vous pouvez m'aider ?


Message édité par tuxbleu le 27-11-2007 à 18:04:44
n°1650074
tuxbleu
renie ses origines
Posté le 28-11-2007 à 10:31:00  profilanswer
 

:bounce:

n°1650748
devil_k
Posté le 29-11-2007 à 12:11:00  profilanswer
 

voilà
 
ActiveCell.FormulaR1C1Local = "=RECHERCHEV(L" & z & "C1;commentaires!C1:C2;2;FAUX)"
 
 
Dans ton exemple Cells(z, 1)  est considéré comme du texte car entre guillemets
Et A:B est incorrect car tu utilises une fonction qui requiert du L1C1 (FormulaR1C1Local dans ton cas)

n°1650853
tuxbleu
renie ses origines
Posté le 29-11-2007 à 14:47:05  profilanswer
 

merci,
 
J'ai contourné le problème en utilisant la fonction VB qui correspond à rechercheV :  
Application.WorksheetFunction.VLookup()
Et ca marche pas mal :)


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  VB/VBA/VBS

  Fonction FormulaR1C1 qu ine marche pas tout les jours

 

Sujets relatifs
Fonction C/C++ pour gérer la batterieParametre de fonction
Une fonction peut-elle retourner le numéro de la ligne qui l'appelle ?[C] Fonction getopt()
Requete qui marche sur myadmin mais pas en phpL'authentification HTTP : comment ça marche exactement ?
Exécuter des portions de code php différentes en fonction d'un confirm[Résolu] isset qui veut pas marché :(
[resolu]Ma fonction de calcul des fps est-elle bonne ?fonction my_fgetcsv
Plus de sujets relatifs à : Fonction FormulaR1C1 qu ine marche pas tout les jours


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR