Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1373 connectés 

  FORUM HardWare.fr
  Programmation
  VB/VBA/VBS

  Boucle sur excel

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Boucle sur excel

n°1694537
axelandre
Posté le 28-02-2008 à 17:31:18  profilanswer
 

Bonjour,
 
Je souhaiterai (enfin mon patron) faire une comparaison entre deux colonnes d'un tableau excel.
 
Je m'expliqe.
 
La cellule J2 est celle qui est comparée.  
La colonne M contient des libellés qui sont comparés avec les cellules de la colonne J (ici J2).  
La colonne L contient des codes qui concordent avec les libellés de la colonne M.  
En gros, il y a 18 libellé dans la colonne M et 18 codes dans la colonne L où chaque libellé correspond à un code.  
On regarde dans la cellule J2 ce qu'elle contient pour la comparer avec les cellules de la colonne M et dès qu'une cellule de la colonne M correspond avec la cellule J2 alors on insère dans la colonne où est la fonction le code correspondant au libellé. Et on passe à la cellule J3 et cela jusqu'à la fin du tableau!
 
Si quelqu'un pouvait m'aider ce serait super car la je suis dans le merde!
 
Merci d'avance pour votre aide!  

mood
Publicité
Posté le 28-02-2008 à 17:31:18  profilanswer
 

n°1694615
kiki29
Posté le 28-02-2008 à 19:10:19  profilanswer
 

Salut, la chose apparait un peu ,disons confuse, sans échantillon de ton fichier . Passer par exemple par http://cjoint.com/


Message édité par kiki29 le 28-02-2008 à 19:11:01
n°1694776
galopin01
Posté le 28-02-2008 à 22:58:48  profilanswer
 

bonjour,
un petit essai avec ma boule de cristal  :D  (sans VBA)
A+


Message édité par galopin01 le 28-02-2008 à 22:59:04
n°1694893
axelandre
Posté le 29-02-2008 à 09:19:05  profilanswer
 

Bonjour,
 
Tout d'abord merci de votre aide car le je coince vraiment.
 
J'ai bien essayé ton code galopin mais chez moi certains résultat sont faux. C'est-à-dire qu'il ne me met pas le bon champs dans la colonne des résultats.
 
Mon document est trop volumineux pour le mettre sur cjoint.com
 
Mais Le principe est exactement le même que celui donné par galopin.
 
C'est rageant car le code fonctionne bien mais certains résultats sont faux!! GGRRRRR....
 
Merci encore pour votre aide et si quelqu'un a une solution au problème je suis toujours preneur!

n°1694925
axelandre
Posté le 29-02-2008 à 10:25:25  profilanswer
 

C'est bon pour mon problème il a été résolu et voici la réponse :
 
=SI(NB.SI(O$2:O$19;L2)=0;"";INDEX(N$2:N$19;EQUIV(L2;O$2:O$19;0)))
 
Merci pour votre aide à tous
 


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  VB/VBA/VBS

  Boucle sur excel

 

Sujets relatifs
EXCEL VBA - Addition de cellule et de variable !probleme de boucle dans Excel
[VBA EXCEL] Boucle sur plusieur feuille d'un classeurboucle selection condition excel
BOUCLE pour Macro Excel : case:nom prenom ---> case:nom case:prenomVB Excel - Utiliser une variable pour conditionner une boucle
macro excel boucle sur les colonnesVariable dans boucle VBA Excel
excel cellule colonne vbs boucle[VB Excel] Faire une boucle correcte
Plus de sujets relatifs à : Boucle sur excel


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR