Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1274 connectés 

  FORUM HardWare.fr
  Programmation
  Shell/Batch

  problème avec xcopy d'un dossier

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

problème avec xcopy d'un dossier

n°2022064
jejechu90
Posté le 09-09-2010 à 12:32:22  profilanswer
 

Bonjour à tous !
 
J'ai un petit soucis avec la commande xcopy, j'espère que quelqu'un sera en mesure de m'aider.
 
J'aimerai faire un script afin de sauvegarder l'intégralité du dossier de n'importe quel utilisateur (C:\Users\Administrateur par exemple) dans un autre dossier Backup.
 
Voici mon script.
 
@echo off
cls
md "E:\BACKUP
set dossier_backup= "E:\BACKUP\%DATE:/=-%_%USERNAME%_%OS%"
md %dossier_backup%
xcopy "C:\Users\%USERNAME%" %dossier_backup% /s/e/h
 
Tout le script se déroule correctement jusqu'au moment où la copie se fait !
J'ai voulu tester et mettre un lol.txt dans le dossier C:\Users\Administrateur\, et lorsque que le script se lance et que je vérifie dans mon dossier backup, il y a donc bien un dossier de sauvegarde prenant en paramètres la date l'utilisateur et l'os, et seul le fichier lol.txt y est présent. La copie des autres dossiers tels que "Documents" ou "Image" ne s'effectue pas, et je ne comprends pas pourquoi.
 
Si quelqu'un pourrait m'aider ça sera super sympa !
 
Merci d'avance !

mood
Publicité
Posté le 09-09-2010 à 12:32:22  profilanswer
 

n°2022067
roondar
Posté le 09-09-2010 à 13:14:50  profilanswer
 

Il manque pas une guillemet à la ligne 3 ?
et vire le "@echo off" pour voir les erreurs

n°2022336
jejechu90
Posté le 10-09-2010 à 15:57:00  profilanswer
 

ouais merci le guillemet c'était une erreur de copie ;)
 
sinon apparemmen si j'enlève le /h ça marche, mais du coup, ça ne me sauvegardera pas de fichiers systèmes ou fichiers cachés !
 
Sinon je voulais faire un même script de ce genre, mais pour supprimer à chaque fois la sauvegarde plus ancienne.
 
Est ce que tu aurais une idée de la façon dont je devrait le faire ?


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  Shell/Batch

  problème avec xcopy d'un dossier

 

Sujets relatifs
Problème d'insertion d'image sous LaTeXProblème remplissage Form par recordset
AS3 = probleme indicateur chargement d'images multipleprobleme avec easy forum ! 2.5
problème avec la fonction vlookupProbleme avec " Adobe Flash Player "
Problème lecture codes barre 2/5 entrelacésproblème réalisation tableau périodique tkinter
Problème Script AS3 Flash 
Plus de sujets relatifs à : problème avec xcopy d'un dossier


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR