Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Shop Recherche
814 connectés 

  FORUM HardWare.fr
  Programmation
  PHP

  [Résolu] Probleme de résolutin de code html ecrit avec du php par echo

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[Résolu] Probleme de résolutin de code html ecrit avec du php par echo

n°800346
bublu
Posté le 20-07-2004 à 10:30:22  profilanswer
 

Bonjour.
Comment allez vous?
 
Pour un stage, je me suis lancé dans l apprentissage de php et html.
Rencontrant des difficultées, je me pose la question suivante:
     Dans une page html contenant du php, lors de la lecture de la page par le navigateur,le php est bien lu et "incorporé" au html( je veux dire par la inserer du code html avec echo) avant la lecture du code html?
 
Car quand je met du code html compris dans l expression d un if, il n est pas pris en compte.Mais apparait dans la source de la page...
 
Quelqu un à la possibilité de m éclairer?
 
Merci d avance.
 
Bublu


Message édité par bublu le 20-07-2004 à 12:42:21
mood
Publicité
Posté le 20-07-2004 à 10:30:22  profilanswer
 

n°800357
hop le fou
Tu m'en diras tant
Posté le 20-07-2004 à 10:37:36  profilanswer
 

bublu a écrit :

Bonjour.
Comment allez vous?


 
Ca va, ca va  :D  
 
 
Tu peux poster ton code stp ?

n°800374
bublu
Posté le 20-07-2004 à 10:42:41  profilanswer
 

Tu en as de la chance : o)
Voici le code:
 
<HTML>
 <HEAD>
  <TITLE>
   Recherche de produit
  </TITLE>
  <META name='Robots" content="noindex,nofollow">
 <HEAD>
 <BODY bgcolor="#00BFFF">
  <?php
      require("connect.php" );
      require("connection.php" );
 
      //On recupere les information du formulaire
      $e_mail=$_POST['e_mail'];
      $password=$_POST['password'];
 
//on se connecte a la base arch
      $connexion=connection (NOM,PASSE,BASE,SERVEUR);
 
//on verifie si la personne est dans la table des utilisateurs  
      $requete_ident="SELECT *  
                      FROM utilisateur
                      WHERE e_mail='$e_mail'
                        AND password='$password'";
 
      $identification=mysql_query($requete_ident,$connexion);
      $resultat=mysql_num_rows($identification);
      if($resultat == 1 )
      {
 $_SESSION['e_mail']=$e_mail;/*pour garder la session ouverte */
        echo " <BR>
               <BR>  
               <FORM method=\"post\" action=\"affichage.php\" align=\"center\">
               <TABLE align=\"center\">
                <TR>
                 <TD>
                  <INPUT type=\"radio\" name=\"caseradio\" value=\"1\">
                 </TD>
                 <TD>
                  Recherche par reference
                 </TD>
                </TR>
                <TR>
                 <TD>
                  <INPUT type=\"radio\" name=\"caseradio\" value=\"2\">
                 </TD>
                 <TD>
                  Afficher la totalite de vos article
                 </TD>
                </TR>
                <TR>
                 <TD>
                  <INPUT type=\"radio\" name=\"caseradio\" value=\"3\">
                 </TD>
                 <TD>
                  Recherche par mot cle
                 </TD>
                </TR>
               </TABLE>
               <BR>
               <BR>
               <INPUT type=\"text\" name=\"mot\" align=\"center\">
               <BR>
               <BR>
               <INPUT type=\"submit\" value=\"Valider\" align=\"center\">
               <INPUT type=\"reset\" value=\"Annuler\" align=\"center\" >
               <INPUT type=\"hidden\" value=".$_POST['e_mail']."
               </FORM>";
       }
      else
       {
 echo"Non valide";
       }
  ?>
 
  <DIV align="center">
   Pour quitter la session ou retourner a la page d identification cliquez <A href="auth.php">ici</A>
  </DIV>
 </BODY>
</HTML>
 
Le probleme est que quand j ai $resultat=1 , il ecrit bien le code html (enfin il est dans la source) mais j obtiens une page blanche... :??:  
 
Ai je oublié quelque chose?
 
Mici


Message édité par bublu le 20-07-2004 à 10:45:39
n°800377
T509
$job-&gt;GetJob(now)
Posté le 20-07-2004 à 10:46:33  profilanswer
 

c'est quoi ton erreur en fait. Je n'ai pas compris


---------------
fermez vos topics résolus avec le tag [Résolu] en fin de titre. Merci !
n°800403
bublu
Posté le 20-07-2004 à 10:56:49  profilanswer
 

ben mon probleme , c est que rien apparait sur ma page, j obtiens une page blanche dans tous les cas...

n°800409
T509
$job-&gt;GetJob(now)
Posté le 20-07-2004 à 10:58:49  profilanswer
 

ALors c'est que ta condition "if" n'est pas satisfaite et que le script ne rentre pas dedans.


---------------
fermez vos topics résolus avec le tag [Résolu] en fin de titre. Merci !
n°800415
bublu
Posté le 20-07-2004 à 11:01:21  profilanswer
 

Dans ce cas la, je devrais voir "Non valide" apparaitre.Non?
De plus tous le code html ecrit dans le echo du if apparait dans le code source de la page...


Message édité par bublu le 20-07-2004 à 11:05:26
n°800434
T509
$job-&gt;GetJob(now)
Posté le 20-07-2004 à 11:09:27  profilanswer
 

euh exact :??:


---------------
fermez vos topics résolus avec le tag [Résolu] en fin de titre. Merci !
n°800572
hop le fou
Tu m'en diras tant
Posté le 20-07-2004 à 12:24:16  profilanswer
 

Ta balise <HEAD> n'est pas fermée
Fais juste un echo "Nimporte quoi" au début de ta page pour voir
 
EDIT : j'avais pas vu que tu affichais qqchose en bas donc oui ca doit etre ta balise <HEAD> qui fait que rien n'est affiché


Message édité par hop le fou le 20-07-2004 à 12:25:40
n°800583
bublu
Posté le 20-07-2004 à 12:41:42  profilanswer
 

Merci ! :)
J avais aussi une erreur dans ma balise META...
Je ne suis pas doué...
Merci pour votre aide.
 
Bublu


Message édité par bublu le 20-07-2004 à 12:42:46

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  PHP

  [Résolu] Probleme de résolutin de code html ecrit avec du php par echo

 

Sujets relatifs
faceid et code des icones [OK]problème authentification proxy
Problème avec "Redim Preserve"pop up centré passant a travers les anti pop up [résolu]
Création d'un fichier .hlp pour des Userform [RESOLU]n'activer mon lien que pour le pop up [résolu]
Gkt2-perl: problème avec les combobox[résolu, merci][javascript] pb de lancement de formulaire
Problème de pourcentage pour les balises div[résolu] avantages et inconvénients de VB.NET
Plus de sujets relatifs à : [Résolu] Probleme de résolutin de code html ecrit avec du php par echo


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR