Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1212 connectés 

  FORUM HardWare.fr
  Programmation
  PHP

  Problème de lien html -> php

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Problème de lien html -> php

n°2046922
-JoLaFouin​e-
Posté le 06-01-2011 à 15:36:41  profilanswer
 

Salut à tous, j'ai un petit souci avec ma page web.
J'ai un lien qui part d'une page html pour aller vers une page en php, or le navigateur propose de télécharger la page en php plutôt que d'aller vers celle-ci... j'ai rarement vu ça et je ne vois pas quel est le problème. Si vous avez la solution je suis preneur !
 
Merci.
 
Jolaf

mood
Publicité
Posté le 06-01-2011 à 15:36:41  profilanswer
 

n°2046926
esox_ch
Posté le 06-01-2011 à 15:40:14  profilanswer
 

Ta page est pas interprétée par le serveur => Soit ton serveur n'a pas de module PHP activé, soit la page n'est pas au bon endroit sur le serveur


---------------
Si la vérité est découverte par quelqu'un d'autre,elle perd toujours un peu d'attrait
n°2046955
-JoLaFouin​e-
Posté le 06-01-2011 à 16:07:30  profilanswer
 

Ok merci, je vais contacter le service client. ;)

n°2047203
molly_1105
Posté le 07-01-2011 à 12:25:21  profilanswer
 

Bonjour,
je ne sait pas comment poser une question sur ce forum donc je vais la poser ici:
 
j'ai recemment acheté un nom de domaine accentué http://créationsiteinternet.net pour un meilleur referencement , pas mal de site ne prennent pas en charge ce type d'adresse donc backlinking compliqué, il ne prennent pas non plus l'adresse sous la forme www.xn--etc..
Je posséde un autre domaine http://refetudes.com qui redirect sur le domaine accentué.
Ma question : les liens vers refetudes comptent ils pour google comme des liens vers créationsiteinternet.net ou pas du tout???

n°2047238
rufo
Pas me confondre avec Lycos!
Posté le 07-01-2011 à 14:05:52  profilanswer
 

merci de créer un topic pour votre question, molly_1105 ;) On ne squatte pas le topic des autres.


---------------
Astres, outil de help-desk GPL : http://sourceforge.net/projects/astres, ICARE, gestion de conf : http://sourceforge.net/projects/icare, Outil Planeta Calandreta : https://framalibre.org/content/planeta-calandreta
n°2047471
-JoLaFouin​e-
Posté le 07-01-2011 à 20:44:10  profilanswer
 

Bon j'ai un autre problème, ils ont mis à jour ma formule pour que je sois sur un serveur qui prenne en compte le php donc de ce côté tout va bien.  
Or maintenant que j'utilise mes pages php (qui ont très bien fonctionné sur un autre site que j'avais auparavant) et que je fais un test, le navigateur me dit qu'il est impossible d'envoyer les informations.  
C'est possible que cela vienne encore du serveur qui m'héberge ? Ou alors c'est une boulette qui peut venir d'autre part (ça m'étonnerait très fortement que cela vienne du code puisque comme je l'ai dit, j'ai utilisé une page qui était la copie conforme d'un autre site où ça marchait très bien)... y a vraiment un truc que je saisis pas là...

n°2047533
esox_ch
Posté le 08-01-2011 à 11:40:02  profilanswer
 

C'est quoi exactement le message d'erreur?


---------------
Si la vérité est découverte par quelqu'un d'autre,elle perd toujours un peu d'attrait
n°2047534
smaragdus
whores, drugs & J.S. Bach
Posté le 08-01-2011 à 11:50:09  profilanswer
 

Est-ce la même version de PHP ?

n°2047632
-JoLaFouin​e-
Posté le 09-01-2011 à 12:34:06  profilanswer
 

Le message d'erreur c'est "Envoi du formulaire impossible" inscrit tout en haut à gauche de la page entièrement vierge mis à part.
Comment savoir si c'est la même version de PHP, et dans ce cas, que dois-je changer dans la page ?

 

Merci :)

 

Edit: Je viens de vérifier sur le site d'hébergement et il prend en charge la version 5.2.3 de PHP, mais ça change vraiment quelque chose ? :??:

 

Re-edit: Le serveur sur lequel ça marchait avant (qui soit dit en passant est truffé de pubs car gratuit ce qui explique pourquoi je suis sur l'autre) était configuré en php4 mais je viens de le passer en php5 (car il y avait le choix dans la configuration) et cela marche toujours aussi bien... donc c'est sans doute pas une histoire de version...


Message édité par -JoLaFouine- le 09-01-2011 à 12:48:08
n°2047655
esox_ch
Posté le 09-01-2011 à 16:25:42  profilanswer
 

File l'URL de la page


---------------
Si la vérité est découverte par quelqu'un d'autre,elle perd toujours un peu d'attrait
mood
Publicité
Posté le 09-01-2011 à 16:25:42  profilanswer
 

n°2047660
-JoLaFouin​e-
Posté le 09-01-2011 à 17:00:12  profilanswer
 
n°2047661
esox_ch
Posté le 09-01-2011 à 17:03:01  profilanswer
 

Il faut regarder dans ton code PHP, on dirait une erreur générée dans le code ... regarde dans le code dans quel cas est-ce que cette erreur est retournée..


---------------
Si la vérité est découverte par quelqu'un d'autre,elle perd toujours un peu d'attrait
n°2047662
-JoLaFouin​e-
Posté le 09-01-2011 à 17:06:17  profilanswer
 

En effet, c'est d'ici qu'il s'agit :
 
// Send the e-mail
     if (@!mail($email_dest,$sujet,$sortie,$entetes)) {
     echo("Envoi du formulaire impossible" );
     exit();
     } else {
 
Mais je vois pas quel peut être le problème, je ne suis pas un fou du php et je me suis aidé de programmes pour réaliser cette page. Si tu peux m'aider... ;)

n°2047663
esox_ch
Posté le 09-01-2011 à 17:09:54  profilanswer
 

enlève @, ça nous donnera d'autres infos


---------------
Si la vérité est découverte par quelqu'un d'autre,elle perd toujours un peu d'attrait
n°2047665
-JoLaFouin​e-
Posté le 09-01-2011 à 17:11:52  profilanswer
 

Même message d'erreur.
Si je comprends bien la partie que je t'ai envoyé concerne les informations de l'e-mail du destinataire non ? :??:

n°2047668
esox_ch
Posté le 09-01-2011 à 17:19:41  profilanswer
 

C'est qu'il y a un soucis avec la commande mail, donc soit elle est désactivée ( tu peux le tester en écrivant phpinfo(); dans une page php ), soit les variables que tu lui passes sont foireuses, soit il y a un soucis avec leur configuration du serveur mail


---------------
Si la vérité est découverte par quelqu'un d'autre,elle perd toujours un peu d'attrait
n°2047671
-JoLaFouin​e-
Posté le 09-01-2011 à 17:27:37  profilanswer
 

Ok, je l'ai fait : http://www.p2mconseil.com/info.php
Mais je vois pas qu'est-ce qui parle de mail dans les infos...

n°2047674
esox_ch
Posté le 09-01-2011 à 18:00:37  profilanswer
 

non il n'y a rien. Donc soit c'est un soucis avec tes variables (qui contiendraient de la merde), soit c'est la config du serveur qui merde.
Faut que tu débug ça (regarde le contenu de tes variables, essaie avec une page où il y a que la fonction "mail" qui envoie des données que tu sais correctes,...)


---------------
Si la vérité est découverte par quelqu'un d'autre,elle perd toujours un peu d'attrait

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  PHP

  Problème de lien html -> php

 

Sujets relatifs
[Résolu] Problème Commande ZIP UnixPaperVision3D : passer de la 2d a la 3d = problème de coordonnées :-/
Problème mysql fetch array [SOLVED]Balise hidden dans Formulaire Html
Probleme avec pages html et lien sous IE 7 [JS] Problème de value et d'incertion de lien dans inner.HTML
problème lien html dans une iframe svp[HTML] probleme de lien image[resolu]
[JS / HTML] Probleme d'apparence des lien[HTML] probleme de lien
Plus de sujets relatifs à : Problème de lien html -> php


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR