Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
856 connectés 

  FORUM HardWare.fr
  Programmation
  VB/VBA/VBS

  erreur formule excel

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

erreur formule excel

n°2187859
vivinopatc​h
Posté le 28-04-2013 à 11:56:36  profilanswer
 

bonjour à tous,
 
j'ai un soucis avec une formule Excel, j'ai une erreur tel que : ########  
 
il s'agit d'une formule pour calculer les heures sup au dessus de 7h36, "r" c'est pour repos
 
     C           D           E                     K
4   12:11     19:59    7:48              0:12:00
5       r         r           0:00             #####
6    7:36
 
pour E4 j'ai comme formule =SI(C4="r";"0:00";(D4-C4))
pour E5 j'ai comme formule =SI(C5="r";"0:00";(D5-C5))
pour K4 j'ai comme formule =SI(E4>C6;E4-C6;SI(E4<=C6;" " ))
pour K5 j'ai comme formule =SI(E5>C6;E5-C6;SI(E5<=C6;" " ))
 
donc je ne sais pas pourquoi j'ai ##### à la place d'une case vide.


Message édité par gilou le 28-04-2013 à 22:19:40
mood
Publicité
Posté le 28-04-2013 à 11:56:36  profilanswer
 

n°2187896
Arl Guhr
Posté le 28-04-2013 à 21:09:30  profilanswer
 

Essai d’élargir la colonne K pour voir.
Normalement les #### signifient que la colonne n'est pas assez large pour tout afficher.
 
sinon, il me semble que ta formule en K4 pourrai être simplement :
=SI(E4>C6;E4-C6;"" )
 
Edit :Tu n'es pas dans la bonne section il faudrait mieux : VB/VBA/VBS


Message édité par Arl Guhr le 28-04-2013 à 21:13:29

---------------
il s'appel le ronge me doute
n°2187911
Marc L
Posté le 28-04-2013 à 22:58:05  profilanswer
 

 
           vivinopatch, c'est à cause de ton 00:00 entre guillemets, mieux vaut renvoyer un zéro car la cellule est en format heure …
 
                                                        Formule corrigée en E5 (à reporter aussi en E4) :   =SI(C5="r";0;D5-C5)
 
           Plus évidemment la correction de la formule de Arl Guhr en K4 reportée en K5 :   =SI(E5>$C$6;E5-$C$6;"" )
 
           Pour rappel, les formats date & heure ne sont pas des formats textes mais bien numériques …


Message édité par Marc L le 28-04-2013 à 23:04:35
n°2187924
vivinopatc​h
Posté le 29-04-2013 à 08:10:42  profilanswer
 

merci pour ces informations apportées, mais ca ne corrige pas l'erreur, si je cocher l'option calendrier depuis 1904 j'obtiens -7:36:00, je suis donc en négatif et d'après la formule je ne comprends pas pourquoi.
 
on dirait que le calcul réalisé est 0:00-7:36 alors que ce n'est pas du tout ce qui est demandé

n°2187958
Marc L
Posté le 29-04-2013 à 11:21:27  profilanswer
 

 
           En reproduisant les données de la problématique d'origine avec les formules corrigées dans un nouveau classeur,
           aucun souci même en cochant cette option ‼
 
          http://perso.numericable.fr/mpl/Doc/vivinopat1.jpg  
 
           Rappel :   une date / heure dans une cellule au format texte n'est pas considérée par Excel comme telle
                          et n'est donc pas prise en compte dans un calcul, peut même provoquer une erreur !
 
           Ne reproduisant donc pas ce nouveau problème (contrairement à celui exposé à l'origine), sans un maximum de précisions …


Message édité par Marc L le 29-04-2013 à 14:40:40
n°2187961
Arl Guhr
Posté le 29-04-2013 à 11:29:40  profilanswer
 

Techniquement, c'est exactement ce que tu lui demande :  
E5 - C6 -> 0:00-7:36
;)
edit : euhh d’ailleurs il ne devrais rien calculer si E5 < C6 ... :/
edit 2: Je pense que le souci peut venir du " " inséré au lieu de "" ou un simple 0.  
En testant rapidement: " " > 7:00 donc il calcule E5 - C6 ....
Par contre, mon Excel 2010 refuse de calculer " " - 7:00  
 
Ce tableau est dans une feuille avec beaucoup d'enregistrement ou c'est utilisé comme une calculatrice?
 
A la base, ton tableau c'est bien?
première ligne, le temps sur place (heure de départ - heure d'arrivé)
2eme ligne, le temps de repos ( 2 pause de 15 minutes donc une valeur genre 30:00)
Tu veux calculer le temps à prendre en compte (temps sur place - pause(s)) et comparer ce temps avec ta limite de 7h36. Si ce temps est dépassé, tu souhaite savoir de combien.


Message édité par Arl Guhr le 29-04-2013 à 11:57:10

---------------
il s'appel le ronge me doute
n°2188091
vivinopatc​h
Posté le 29-04-2013 à 22:01:15  profilanswer
 

en fait c'est plutôt :
 
heure de prise de service et heure de fin de service.
"r" c'est un repos journalier, donc 0:00 heure
et 7:36 c'est la journée de base, et tout ce qui est au dessus c'est des heures supp.
 
l'idéal serrait lorsqu'il y a "r", c'est d'avoir pour les heures supp une case vide.

n°2188138
vivinopatc​h
Posté le 30-04-2013 à 09:05:24  profilanswer
 

c'est bon j'ai trouvé l'erreur, c'est le 0 dans la formule qui était entre "" et qui faussait le résultat.

 

en tout cas merci encore


Message édité par vivinopatch le 30-04-2013 à 09:05:49
n°2188168
Marc L
Posté le 30-04-2013 à 12:07:19  profilanswer
 

 
           Comme dans ma formule corrigée où il n'y avait pas de guillemet pour le zéro …
 


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  VB/VBA/VBS

  erreur formule excel

 

Sujets relatifs
[VBA-Macros][Excel]Comparaison de deux datesA l'aiiiiide.!! Programation Excel urgent
Transformer x onglets Excel en x pdfExcel : Vlookup et lookup
erreur a supprimerJavascript Erreur NS_ERROR_XPC_BAD_CONVERT
Macro importer des fichiers txt d'un dossier dans des fichiers excelerreur dans php pour formulaire de contact
VBA - EXCel erreur formule à l'éxcécution 
Plus de sujets relatifs à : erreur formule excel


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR