Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1466 connectés 

  FORUM HardWare.fr
  Programmation
  PHP

  Erreur 500 sur serveur Apache

 


 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Erreur 500 sur serveur Apache

n°1915553
jordel
Elven Powaaa
Posté le 17-08-2009 à 00:33:01  profilanswer
 

Bonsoir à tous,
 
J'ai un petit serveur web perso en Fedora 11 avec Mysql/Apache/Php qui tournent dessus. Jusque là... pas de souci.
 
J'ai créé un répertoire Sites dans /var/www/html qui contient 2 sites différents : Le_Site1 et Le_Site2.
 
Lorsque je me connecte sur Le_Site1, aucun problème, tout est OK. Mais lorsque je tente d'accéder au Le_Site2, j'ai une page blanche sous FF et une erreur 500 sous IE.
Et dans les logs Apache j'ai ceci :

Code :
  1. [error][client mon_ip_locale] PHP warning: Unknown: failed to open stream: Permission denied in Unknown on line 0
  2. [error][client mon_ip_locale] PHP Fatal error: Unknown: failed opening required '/var/www/html/Le_Site2/index.php' (include_path=".:/usr/share/pear:/usr/share/php'} in Unknown on line 0


 
J'ai cherché sur pas mal de forums et tous préconisent une vérif des droits sur les répertoires et les fichiers : chose faite.
J'ai réinstallé PEAR qui se trouve bien dans le répertoire nommé par l'erreur. Par contre le /usr/share/php existe mais est vide. Normal ?
 
Et sinon... que faire pour éviter cette erreur ???
(J'ai testé avec index.php avec du PHP et sans PHP : idem, même erreur).
 
Merci d'avance.

mood
Publicité
Posté le 17-08-2009 à 00:33:01  profilanswer
 

n°1915593
PierreC
Posté le 17-08-2009 à 09:26:11  profilanswer
 

je pense la même chose ques les autres forum .... probleme de droit.
 
Montre nous le résultat de :
ls -ld /var/www/html/Le_Site2/
ls -l  /var/www/html/Le_Site2/index.php


---------------
Du tofu en Alsace : www.tofuhong.com
n°1916327
jordel
Elven Powaaa
Posté le 18-08-2009 à 21:56:46  profilanswer
 

Bonsoir, bonsoir,
 
Merci pour la réponse...
 
Voici les infos demandées :

Code :
  1. # ls -ld /var/www/html/Le_Site2
  2. drwxrwxrwx. 7 root root 4096 aout  6 22:41 /var/www/html/Le_Site2
  3. # ls -l /var/www/html/Le_Site2/index.php
  4. -rwxrwxrwx. 1 root root 1693 aout 17 02:24 /var/www/html/Le_Site2/index.php


 
Merci d'avance :)

n°1916949
PierreC
Posté le 20-08-2009 à 10:12:40  profilanswer
 

mouais ....
 
1 / Et la même chose avec Le_Site1 ?
 
 
2/ je voie un point à la fin du "drwxrwxrwx. "  
Je connais pas fedora je serais supris qu'il ai rajouté un point. Tu n'aurais pas des ACL par hasard ?


Message édité par PierreC le 20-08-2009 à 10:12:53

---------------
Du tofu en Alsace : www.tofuhong.com
n°1917253
jordel
Elven Powaaa
Posté le 21-08-2009 à 00:22:38  profilanswer
 

Bonsoir,
 
Voici les résultats des commandes sur Le_Site1 :

Code :
  1. # ls -ld /var/www/html/Le_Site1
  2. drwxrwxrwx. 9 root root 4096 aout  7 00:44 /var/www/html/Le_Site1
  3. # ls -l /var/www/html/Le_Site1/index.php
  4. -rwxrwxrwx. 1 root root 2948 juin 18 11:31 /var/www/html/Le_Site1/index.php


 
Pour ce qui est des ACL... je n'ai rien fait pour en avoir... ou alors si j'ai mis des contrôles d'accès, c'est à l'insu de mon plein gré :)
Y'a un moyen de vérifier si des ACL sont présent(e)s ??? Ou alors c'est à moi de savoir précisément de quoi il s'agit.
 
Merci d'avance.

n°1918815
grosbin
OR die;
Posté le 27-08-2009 à 13:12:45  profilanswer
 

Normalement il doit s'agir de l'user FTP qui ait les droits sur les fichiers, pour ça un petit coup de winscp :)


---------------
Photos Panoramiques Montagnes Haute Savoie
n°1924158
jordel
Elven Powaaa
Posté le 15-09-2009 à 10:46:50  profilanswer
 

Hello,
 
Merci Grosbin pour ta réponse... mais je ne comprends pas trop pour le "petit coup de winscp" ???
 
:)


---------------
------------------------------
n°1924275
ravenX11
Coding is living
Posté le 15-09-2009 à 16:09:43  profilanswer
 

Tu utilises root:root en 777, ce qui est tres mauvais.
 
Fais un
chown -R www-data:www-data /var/www/
 
pour que Apache redevienne proprio des fichiers.

n°1924434
jordel
Elven Powaaa
Posté le 16-09-2009 à 09:53:09  profilanswer
 

Hello,
 
Merci pour la réponse... je teste cela dès ce soir...
En espérant que ça se passe bien :)


---------------
------------------------------
n°1924661
jordel
Elven Powaaa
Posté le 16-09-2009 à 22:56:02  profilanswer
 

Bonsoir,

 

Bon... je viens d'essayer la commande mais Fedora me dit que l'utilisateur est invalide...

 

Je viens de tenter avec chown -R apache:apache /var/www/ mais je n'ai toujours rien !!! :(


Message édité par jordel le 16-09-2009 à 23:04:53
mood
Publicité
Posté le 16-09-2009 à 22:56:02  profilanswer
 

n°1924676
ravenX11
Coding is living
Posté le 16-09-2009 à 23:40:07  profilanswer
 

ps auxwww | grep apache
ou
ps auxwww | grep httpd
 
et donne le resultat de la ligne ;) pour voir qui fait tourner le demon


Message édité par ravenX11 le 16-09-2009 à 23:40:23
n°1925186
jordel
Elven Powaaa
Posté le 18-09-2009 à 23:29:54  profilanswer
 

Hop, voilà un zoli print-screen :
http://img38.imageshack.us/img38/8373/screendv.th.jpg


Message édité par jordel le 18-09-2009 à 23:30:18

---------------
------------------------------
n°1925284
PunkRod
Digital Mohawk
Posté le 19-09-2009 à 22:15:24  profilanswer
 

le site 1 est dans le DirectoryRoot d'apache ?
et pas le 2 c'est ça ? enfin d'après ta description ils "semblent" être dans le même dossier, mais j'ai déjà eu ce genre d'erreur.

 

faut que tu mettes les mêmes privilèges dans le fichier httpd.conf
'AllowFromAll' et trucs du genre je crois bien.

 

Sinon c'est que pour le folder
/www/site1/ tu as une directive
<directory> avec "AllowFromAll" dedans et rien de tel pour le site 2
(cas le plus probable à ce que tu nous dis)

 

Si tu vois pas de quoi je parle, pose tes questions, j'expliquerais plus en détails.
en cas copie ton http.conf qquepart qu'on puisse regarder


Message édité par PunkRod le 19-09-2009 à 22:18:17
n°1925327
sub1
Posté le 20-09-2009 à 13:49:14  profilanswer
 

Hello,
 
SElinux mal configuré ? Tu peux le désactiver temporairement avec
setenforce 0

n°1925683
jordel
Elven Powaaa
Posté le 21-09-2009 à 23:43:47  profilanswer
 

@Sub1 : BINGO... avec un setenfore à 0... ça passe !!!
 
Mais pourquoi donc ???

n°1927280
jordel
Elven Powaaa
Posté le 28-09-2009 à 13:27:34  profilanswer
 

Juste une remarque en passant... je vais devoir laisser ce "setenforce" à 0 donc ???


---------------
------------------------------

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  PHP

  Erreur 500 sur serveur Apache

 

Sujets relatifs
[VBA] erreur de compilation procédure trop grandeAcces serveur de fichier distant
Impossible d'importer org.apache.util et org.apache.webdavErreur sur site qui décale le menu
erreur 91 en vba de accessProbabilité propagation erreur sur un PC
[RESOLU] erreur pendant le chargement un fichier XMLUne sorte de client / serveur sur le net ?
Trouver le certificat envoyé par le serveurErreur 500 sur serveur local apache : .htaccess
Plus de sujets relatifs à : Erreur 500 sur serveur Apache


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR