Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1124 connectés 

  FORUM HardWare.fr
  Programmation
  Java

  [JSP] [résolu] Problème avec les paramètres de l'URL d'un pg:pager

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[JSP] [résolu] Problème avec les paramètres de l'URL d'un pg:pager

n°808301
Xilas
Posté le 28-07-2004 à 09:58:25  profilanswer
 

Bonjour
 
j'ai un pager dans une JSP (je fais du java struts). mon problème est que dans l'URL que je dois donner au pager, il y a des attributs. Et par défaut le pager rajoute à l'URL "?pager.offset=10", ce qui fait que l'URL a deux "?" et ça plante.
 
voici "l'entête" de mon pager

Code :
  1. <pg:pager id="pager"
  2.   url="<%=\"ansListView.do?ansPbId=\"+pbId+\"&\"%>"
  3.   items="<%=answers.length%>"
  4.   maxPageItems="<%=maxPageItems%>"
  5.   maxIndexPages="10"
  6.   export="pageOffset;pageNumber;"
  7.   scope="request">


 
et le lien devient par exemple :

Code :
  1. ansListView.do?ansPbId=1&?pager.offset=10


 
si je tape en dur dans la barre d'adresse ça marche :

Code :
  1. ansListView.do?ansPbId=1&pager.offset=10


 
Quelqu'un sait comment faire pour que le pager ne rajoute pas le "?" ? ou alors une autre proposition ?


Message édité par Xilas le 30-07-2004 à 12:20:49
mood
Publicité
Posté le 28-07-2004 à 09:58:25  profilanswer
 

n°808320
Profil sup​primé
Posté le 28-07-2004 à 10:05:56  answer
 

mauvaise section

n°808325
Xilas
Posté le 28-07-2004 à 10:08:24  profilanswer
 

c'est un problème de HTML, non ? Ou alors dis-moi dans quelle section le mettre !
 
précision : ça ne plante pas ms ça reste sur la première page du pager.


Message édité par Xilas le 28-07-2004 à 10:09:08
n°810803
Xilas
Posté le 30-07-2004 à 10:25:04  profilanswer
 

je ne sais pas si c'est un problème de JSP ou de HTML.

n°810885
Xilas
Posté le 30-07-2004 à 11:14:14  profilanswer
 

apparemment il faut utiliser le tag pg: param. Voici le code sachant que pbId est défini plus haut dans la JSP :  

Code :
  1. <pg:pager
  2. id="pager"
  3. url="ansListView.do"
  4. items="<%=answers.length%>"
  5. maxPageItems="<%=maxPageItems%>"
  6. maxIndexPages="10"
  7. export="pageOffset;pageNumber;"
  8. scope="request">
  9. <pg:param name="ansPbId" value = "<%=pbId%>">


 
mais ça génère une erreur :

Code :
  1. According to TLD, tag pg:param must be empty, but is not


 
Quelqu'un a déjà eu ce genre d'erreur ?


Message édité par Xilas le 30-07-2004 à 11:15:46
n°811019
Xilas
Posté le 30-07-2004 à 12:19:43  profilanswer
 

problème résolu : il manquait le "/" à la fin du tag :

Code :
  1. <pg:param name="ansPbId" value = "<%=pbId%>"/>


et ça marche !


Message édité par Xilas le 30-07-2004 à 12:20:22

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  Java

  [JSP] [résolu] Problème avec les paramètres de l'URL d'un pg:pager

 

Sujets relatifs
JSP m'affiche des "NULL" alors que c'est vide[awt/swing][résolu] listener sur ALT ou CTRL uniquement
redirection selon la date systeme [RESOLU][VBA XL Word] Passer des variables obtenues ss XL dans Word? *RESOLU*
Besoin d'aide en JSP concernant l'affichageProbleme "out of memory"
[resolu]distinct infaisable[CSS] Encore un chtit problème
[CSS] Image de fond dans une zone. Problème de compréhension[VBA Excel] Problème avec les références
Plus de sujets relatifs à : [JSP] [résolu] Problème avec les paramètres de l'URL d'un pg:pager


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR