Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
1846 connectés 

  FORUM HardWare.fr
  Programmation
  HTML/CSS

  Background & Media queries

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Background & Media queries

n°2230036
scorbutic
Posté le 05-06-2014 à 21:00:51  profilanswer
 

Help, j'en peux plus.
 
Je vous explique. J'ai ça en html :  
 

Code :
  1. <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
  2. <html>
  3.   <head>
  4.   <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
  5.   <meta name="viewport" content="width=device-width, user-scalable=no"/>
  6.   <link rel="stylesheet" href="testzombie.css" />
  7.   <title></title>
  8.   </head>
  9.   <body bgcolor="darkgrey">
  10.   <center><div id="mainBG">&nbsp;</div></center>
  11.   </body>
  12. </html>


 
et ça en css :  
 

Code :
  1. .body {
  2.  background-color: darkgrey;
  3. }
  4. #mainBG {
  5.   background: url(images/zombie-pc.jpg) no-repeat scroll !important;
  6.   height:100%;
  7.   width:1050px;
  8. }
  9. @media screen and (min-device-width: 361px) and (max-device-width: 1024px) {
  10. #mainBG {
  11.    background: url(images/zombie-tablet.jpg) no-repeat scroll !important;
  12.  width:540px;
  13.    border:1px solid black;
  14.   }
  15. }
  16. @media screen and (max-device-width: 360px) {
  17. #mainBG {
  18.   background: url(images/zombie-phone.jpg) no-repeat no-scroll !important;
  19.   border:1px solid red;
  20. width:300px;
  21. }
  22. }


 
Mon problème est le suivant : sur ma tablette (nexus 7), j'ai bien le bon tour en noir et la bonne image "tablet". Sur mon écran PC j'ai bien juste l'image "pc"...par contre que ce soit sur mon tel android (M7) ou 3GS, j'ai bien la bordure rouge MAIS l'image ne correspond pas et ne veut absolument pas s'afficher proprement.
 
Du coup, je cale. 3 jours que je galère là dessus alors que je suis quasiment certain que la solution est vraiment simple.
 
Résultat en ligne visible ici : http://www.niceairsoftequipe.fr/testzombie.html
 
Franchement, si quelqu'un arrive à m'expliquer le pourquoi de la chose, j'apprécierais.

mood
Publicité
Posté le 05-06-2014 à 21:00:51  profilanswer
 

n°2230051
ketch_
Posté le 06-06-2014 à 08:17:46  profilanswer
 

1 - degage les !important.
2 - scroll est un parametre par default, tu n'as pas a le specifier.
3 - no-scroll est un parametre invalide, essaye fixed.
 
résultat : http://i58.tinypic.com/2a65b0w.png
 
 
 
 
 
(dsl pour les accents, f*cking clavier qwerty)

n°2230098
scorbutic
Posté le 06-06-2014 à 14:30:29  profilanswer
 

Merci ! Au top !


Message édité par scorbutic le 06-06-2014 à 14:32:03

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  HTML/CSS

  Background & Media queries

 

Sujets relatifs
backgroundfonction less media
background "dynamique"Linq, Expression et Compiled Queries
fichier audio grâce à formulaire Access et Media PlayerBackground plus lent que la page
Medias Queries et Smartphones haute résolutionBackground sur le "coté"
[RESOLU]mettre le background-image en 800x600 tout simplement ! 
Plus de sujets relatifs à : Background & Media queries


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR