Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
583 connectés 

  FORUM HardWare.fr
  Programmation
  Flash/ActionScript

  Problème Lien sur un bouton

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Problème Lien sur un bouton

n°1637230
CharlieSho​w
Posté le 05-11-2007 à 22:06:50  profilanswer
 

Salut à tous,
 
J'ai fait une navigation en flash, je me sui renseigner pour pouvoir attribuer un lien à mes bouton,
j'ai bien vus qu'il suffit de mettre :  
 
on (press) {
getURL("http://www.google.fr", "_self" );
}
 
normalement tout devrais fonctionner normalement mais le problème c'est que j'ai une erreur :  
 
Erreur 1087 Erreur de syntaxe : caractère excédentaire détecter à la fin du programme > on(press) {
 
et aucun lien ne fonctionne  :(  
 
Après mainte et mainte recherche je ne trouve aucunes solutions, HELP ME PLEASE.
 
Cordialement,
Charlie.

mood
Publicité
Posté le 05-11-2007 à 22:06:50  profilanswer
 

n°1637293
Zedlefou
In cabbage we trust !
Posté le 06-11-2007 à 05:05:58  profilanswer
 

Tu peux copier/coller ton code ?


---------------
Jeu de simulation Boursière - Version BETA - https://www.facebook.com/wildstocks
n°1637734
CharlieSho​w
Posté le 06-11-2007 à 16:39:12  profilanswer
 

Merci beaucoup de ta reponse,
 
Voici le code :  
 
on (press) {
getURL("www.mami-wata.com", "_self" );
}
 
Pourtant tout devrais fonctionner correctement ?!

n°1639545
CharlieSho​w
Posté le 08-11-2007 à 20:50:48  profilanswer
 

HELP ME !

n°1639687
Zedlefou
In cabbage we trust !
Posté le 09-11-2007 à 03:39:37  profilanswer
 

Arretes de crier et montres ton .fla


---------------
Jeu de simulation Boursière - Version BETA - https://www.facebook.com/wildstocks
n°1640356
CharlieSho​w
Posté le 09-11-2007 à 16:14:45  profilanswer
 

Autant pour moi veuillez m'éxcuser :  
 
voilà tout est la :  
http://www.charlie-show.fr/stock
 
Et voilà le lien direct vers le .fla :  
 
http://www.charlie-show.fr/stock/nav_mami_wata.fla
 
Merci beaucoup de votre aide à tous.
 
Charlie.
 
 
 

n°1640465
antika
Posté le 09-11-2007 à 19:20:56  profilanswer
 

houlà, je mets pas mes mains là-dedans.

n°1640472
CharlieSho​w
Posté le 09-11-2007 à 19:41:56  profilanswer
 

Pourquoi ?

n°1640486
antika
Posté le 09-11-2007 à 19:52:27  profilanswer
 

je viens de passer 4 jours à coder une merveille, et là j'ouvre ton fichier et j'ai la nausée. C'est du Flash 4 fait sous CS3.
 
-> yazo.net, kirupa.com, flash.media-box.net
 
Après tu reviens.

n°1640535
CharlieSho​w
Posté le 09-11-2007 à 20:48:51  profilanswer
 

Pourquoi ça ! c'est une drôle de façon de m'aider ...
 
Merci ca fait toujours plaisir !

mood
Publicité
Posté le 09-11-2007 à 20:48:51  profilanswer
 

n°1640602
Zedlefou
In cabbage we trust !
Posté le 10-11-2007 à 08:26:04  profilanswer
 


 [:alandon] We've got a winner.
 
Nan, serieux, les on (press) faut les mettre sur les boutons ou les clips.


---------------
Jeu de simulation Boursière - Version BETA - https://www.facebook.com/wildstocks
n°1640758
CharlieSho​w
Posté le 10-11-2007 à 21:11:56  profilanswer
 

Quand je clique sur mon bouton dans ma fenêtre Action Script ça me dit : Aucunes Action de peut être appliquée à la sélection en cours ?!
 
J'ai pourtant bien essayer ?

n°1640822
Zedlefou
In cabbage we trust !
Posté le 11-11-2007 à 03:57:24  profilanswer
 

LEs actions c'est sur les MovieClip


---------------
Jeu de simulation Boursière - Version BETA - https://www.facebook.com/wildstocks
n°1647331
recep
Posté le 22-11-2007 à 15:43:39  profilanswer
 

essais avec ça :  
 
on(press, release){  
 getURL("http://www.google.fr", "_self" );  
}

n°1703409
autograff
Posté le 17-03-2008 à 14:07:32  profilanswer
 

J'ai le même soucis...
Depuis 1 semaine, flash CS3 refuse catégoriquement de mettre mes boutons ou clips dans la fenêtre "action"...
Avant ça, tout fonctionnait a merveille, je mettait mes codes directement sur le bouton ou le clip...
??? Une idée de ce qui se passe?

n°1703618
antika
Posté le 17-03-2008 à 19:03:49  profilanswer
 

- on ne doit pas mettre de code sur les boutons sous CS3, c'est fini depuis Flash MX (CS3 = Flash 9, Flash MX c'était en 1999, il y a donc 8 ans que la réponse a cette question est toujours identique et ne variera pas).
- il existe néanmoins un mode de compatibilité : tu dois régler tes paramètres de publication sur Flash 8 / Actionscript 2.0,
- si ça a marché auparavant et que maintenant ça marche plus, c'est simplement que tu as changé ce réglage par inadvertance.


Message édité par antika le 17-03-2008 à 19:05:05
n°1703887
autograff
Posté le 18-03-2008 à 09:15:23  profilanswer
 

Merci beaucoup, antika, tu as raison, ça fonctionne. Donc, si je comprend bien, si je veux fonctionner en Flash 9, je met le code sur un calque en précisant le nom du bouton et ce que je veut lui faire faire, mais rien sur le bouton lui même?
 
Merci en tout cas!

n°1704242
antika
Posté le 18-03-2008 à 18:51:44  profilanswer
 

Non, ne déforme pas mes propos, j'ai écris "si tu veux fonctionner en Flash quelle-que-soit-la-version-depuis-Flash-6, tu ne mets pas le code sur un symbole".
 
Sous Flash 9, on ne met plus non plus de code en timeline.

n°1705294
autograff
Posté le 20-03-2008 à 12:33:04  profilanswer
 

Désolé d'avoir déformé tes propos, je suis confus.
Mais si sur CS3 on ne doit mettre le code ni sur le symbole, ni sur la timeline(en image clé), ou donc doivent ils être ces fameux codes AS?
 
(promis je ne t'embête plus après!)

n°1705753
antika
Posté le 20-03-2008 à 23:38:28  profilanswer
 

DTC.

n°1706010
autograff
Posté le 21-03-2008 à 13:41:57  profilanswer
 

Bien joué gros malin...
Bon aller, je vais aller perdre mon temps ailleurs!

n°1706136
Zedlefou
In cabbage we trust !
Posté le 21-03-2008 à 15:01:34  profilanswer
 

Tu dois le mettre dans des classes que tu importes depuis ton fla


---------------
Jeu de simulation Boursière - Version BETA - https://www.facebook.com/wildstocks
mood
Publicité
Posté le   profilanswer
 


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  Flash/ActionScript

  Problème Lien sur un bouton

 

Sujets relatifs
[Flash AS2] Problème de preload en XMLProblème de class et d'attribut
Effet pour un lien imageprobleme avec ShellExecute
Probleme bordure tableau! Casse tête![C] Problème avec une fonction récursive
[Debutant] probleme boucleProbleme avec une variable dasn un formulaire
Problème avec un IF/ELSE[Access] Petit problème de requete
Plus de sujets relatifs à : Problème Lien sur un bouton


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR