Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
952 connectés 

  FORUM HardWare.fr
  Programmation
  Flash/ActionScript

  besoin d'aide plz

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

besoin d'aide plz

n°1318335
crtifosi
Posté le 04-03-2006 à 10:13:21  profilanswer
 

Bonjour
 
J'utilise attachMovie pour charger un clip interne a mon animation en utilisant se code :
 
on (release) {
 this.attachMovie("portofolio", "portofolio_mc", this.getNextHighestDepth());

 
mais j'aurais voulu savoir comment faire pour que mon clip portofolio se charge dans un clip vide appeler dropezone, comme sa a chaque chargement de clip je decharge ma dropezone
 
Merci d'avance

mood
Publicité
Posté le 04-03-2006 à 10:13:21  profilanswer
 

n°1318346
mechkurt
Posté le 04-03-2006 à 10:53:17  profilanswer
 

ce que j'ai donné la ne fonctionnne pas ?
http://forum.hardware.fr/hardwaref [...] m#t1317206
c.a.d. dropezone.attachMovie("portofolio", "dropezone", 10);
en utilisant le nom du clip et en specifiant toujours la même depth, il devrait charger toujours dans le même clip...


---------------
D3
n°1318349
crtifosi
Posté le 04-03-2006 à 11:03:18  profilanswer
 

non sa ne marche pas, le clip que j'appel ne se charge pas du tout

n°1318363
mechkurt
Posté le 04-03-2006 à 11:38:15  profilanswer
 

ah oui s'est vrai tu est dans un bouton
et avec _root.dropzone[...] (si dropzone est sur ta scene principale)
ou _parent.dropzone[...]  (si dropzone est un niveau au dessus de ton bouton)
 
tu peux aussi utiliser le bouton ciblage de clip pour trouver le chemin designant dropzone...


---------------
D3
n°1318368
crtifosi
Posté le 04-03-2006 à 11:47:57  profilanswer
 

je marque sa : on (release) {
 _root.site.dropezone.attachMovie("portofolio", "dropezone", 10);

 
sa ne charge tjs rien

n°1318386
mechkurt
Posté le 04-03-2006 à 12:25:27  profilanswer
 

j'ai trouvé un vieux script a moi ou je faisais encore plus simple et ca marchait, essaye:
removeMovieClip("dropezone" );
attachMovie("portofolio", "dropezone", 10);
par contre j'étais dans une frame sur le timeline principal, pour toi il vas peut etre falloir prefixer tous ca avec _root.site.[...]
 [:airforceone]


Message édité par mechkurt le 04-03-2006 à 12:26:20

---------------
D3
n°1318394
crtifosi
Posté le 04-03-2006 à 12:37:14  profilanswer
 

ce que tu viens de m'envoyezr marche sa charge mon clip mais sa le charge n'importe ou pas dans ma dropezone

n°1318419
mechkurt
Posté le 04-03-2006 à 14:08:46  profilanswer
 

As tu essayé en prefixant avec _root.site ?
 
et puis la doc c'est pas fait pour les chiens, tout comme tu peux toi même essayer tel ou tel variante, je vais pas tout te faire non plus...
 
[:sh@rdar] <= removeMovieClip() (y a un exemple avec attachMovie)
[:sh@rdar] <= attachMovie()
 
si tu debut vraiment commence par le debut http://www.yazo.net un forum c'est fait pour aider pas pour faire a la place des autres  [:airforceone]


---------------
D3

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  Flash/ActionScript

  besoin d'aide plz

 

Sujets relatifs
[ Besoin D'AIDE ! ] Quelques lignes de code Svp. ( noob )Besoin d'aide LabView Détection de veines urgent
Besoin d'aide pour un moteur de recherche[Resolu]Jeux2D besoin d aide couleur de transparence
besoin d'aide pour périphérique[Sql] Besoin d'aide pour une requête ( simple pourtant ... ) [résolu]
Besoin d'aide pour création d'interface graphiqueProjet de jeu Servlet/Jsp besoin d'un peu d'aide :/
Besoin d'aide sous php mercibesoin d'aide (rapide) VBS (newbie)
Plus de sujets relatifs à : besoin d'aide plz


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR