Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1384 connectés 

  FORUM HardWare.fr
  Programmation
  Divers

  Problème mise en ligne de mon site, suis je un boulet ???

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Problème mise en ligne de mon site, suis je un boulet ???

n°2181157
nesis21000
Posté le 18-03-2013 à 23:00:45  profilanswer
 

bonjour,
j'ai acheté un nom de domaine chez ovh avec un hebergement d'un an, et je cherche à mettre mon site en ligne (que j'ai créer en local à l'aide de prestashop et wampserver). Et me voilà en galère depuis 3 jours à m'en tirer les cheveux pour pouvoir le mettre en ligne.
voilà ma précédure :
 
- j'ai créer une base de donnée via phpmyadmin chez ovh nommé 'phoneswomysql' {==== Imposé
- j'ai crée une sauvegarde et exporté base de donné depuis mon serveur local que j'ai renommé 'phoneswomysql'  
- je l'ai importé depuis phpmyadmin chez ovh  
 
base de donnée OK
 
- j'ai modifié le fichier setting.inc
_DB_SERVER_ 'mysql51-80.perso'
_DB_NAME_ 'phoneswomysql'
_DB_USER_ '*********'
_DB_PASSWD_ '******'
- et le fichier config.inc
__PS_BASE_URI__ 'prestashop'
 
fichier modifiés OK
 
- Connexion à mon ftp via Filezilla
Serveur ftp : ftp.phones-world.fr  
Login ou utilisateur : *********
Mot de passe : ********
 
Connexion à mon ftp OK
 
- copie du dossier source nommé 'prestashop' dans le dossier 'www' du ftp via filezilla
 
Dossier 'prestashop' OK
 
 
- changement URL sur prestashop
 
URL Prestashop OK
Suppresion du index.html du dossier www du site distant OK
 
Et pourtant lorsque je me connecte à mon site, je tombe sur une page indexof/ avec deux dossier (img et prestashop) que je vois bien depuis mon ftp, quel pourrait-être le problème ?
Je vous remercis d'avance pour vos réponse les amis
Cordialement

mood
Publicité
Posté le 18-03-2013 à 23:00:45  profilanswer
 

n°2181176
x1fr
Posté le 19-03-2013 à 08:50:27  profilanswer
 

et si dans la page indexof/ tu clic sur prestashop, ça fonctionne?
 
Si oui, ce n'est pas le dossier prestashop qu'il faut mettre dans le dossier www, mais le contenu du dossiser
 
En gros à l'heure actuelle le site prestashop se trouve sur www.tonsite.com/prestashop, et tu veux y accéder depuis www.tonsite.com, il faut remonter le contenu d'un niveau.


---------------
Origin / PSN / Steam / Uplay : x1fr - bnet : Fab#2717
n°2181307
nesis21000
Posté le 19-03-2013 à 21:29:18  profilanswer
 

merci pour vos réponse, je commence à devenir fou, j'y ai encore passé la journée je deviens fou  :|  
 
j'ai donc copié le contenu du dossier 'prestashop' directement dans /www/
 
j'ai modifié le fichier setting.inc
__PS_BASE_URI__ '/'
 
j'ai placé mes fichier index.php et .htaccess (avec notepad en asci et modifier via filezilla) dans /www/
 
index.php :
<?PHP  
   header("HTTP/1.1 301 Moved Permanently" );
   header("Location: http://www.Phones-World.fr/index.php" );
   exit;
?>
 
.htaccess :
AuthUserFile /homez.705/login/www/cgi-bin/.htpasswd
AuthGroupFile /dev/null
AuthName "Restricted Access"
AuthType Basic
require valid-user
 
j'ai placé mon fichier .htpasswd (avec notepad en asci et modifier via filezilla) dans dossier /www/cgi-bin/
avec l'aide de http://www.ovh.com/fr/support/outils/crypt_password.pl
 
et toujours rien, impossible d'accepter à mon site 'Internet Explorer ne peut pas afficher cette page Web'

n°2181308
x1fr
Posté le 19-03-2013 à 21:56:06  profilanswer
 

http://www.phones-world.fr/index.php
 
il n'y a pas de fichier index.php


---------------
Origin / PSN / Steam / Uplay : x1fr - bnet : Fab#2717
n°2181383
nesis21000
Posté le 20-03-2013 à 12:25:33  profilanswer
 

bon voilà ou j'en suis, en esperant un jour trouver le problème...
 
-j'ai recopier tout le contenu du dossier d'origine prestashop dans le dossier /www/ via filezilla
- copie de l'ancien fichier fichier setting.inc dans www/config/
_DB_SERVER_ 'mysql51-80.perso'  
_DB_NAME_ 'phoneswomysql'  
_DB_USER_ '*********'  
_DB_PASSWD_ '******'  
 
sans index.php dans /www/, je me connecte à l'url de mon site et je retrouve avec le message Index of/ avec tout mes dossiers listés
 
je met mon index.php dans /www/ :
<?PHP  
         header('HTTP/1.1 301 Moved Permanently');
         header('Location: http://NomdeDomaine.fr/');
?>  
je me connecte à mon site et voici le résultat ''La page n'est pas redirigée correctement''
 
J'ai créé un bonjour.php placer dans /www/ :
<?php
   echo "Bonjour. Nous sommes le ".date ("Y-m-d H:i:s" )."<br>";
?>
et là pas de probleme je vois bien la date
 
j'ai essayé de placer un .htaccess dans /www/ :
AuthUserFile /homez.705/login_ftp/www/abc/.htpasswd
AuthGroupFile /dev/null
AuthName "Restricted Access"
AuthType Basic
require valid-user
 
j'ai créer un dossier /www/abc/ et y est placé le fichier .htpasswd
(mot crypté avec http://www.ovh.com/fr/espaceclient [...] ssword.pl)
 
J'ai bien réecrit les 2 fichiers .htaccess et .htpasswd sous notepad++ que j'ai enregistré en fichiet .txt (txt.htaccess et txt.htpasswd), je l'ai envoyé dans leur dossier respectif via filezilla, et depuis la colonne de droite j'ai renommer en .htaccess et .htpasswd (suppresion du txt)
 
je me connecte à mon site et là :
 
''500 Internal Server Error
 
The server encountered an internal error or misconfiguration and was unable to complete your request.
 
Please contact the server administrator, postmaster@www.NomdeDomaine.fr and inform them of the time the error occurred, and anything you might have done that may have caused the error.
 
More information about this error may be available in the server error log.''
 
à l'aide je tourne en rond, merci à vous

n°2181451
x1fr
Posté le 20-03-2013 à 17:42:58  profilanswer
 

Pronons les problèmes un par un.
 
Pour la redirection, je pige pas trop ce que tu essaye de faire là.
 
Tu sais que quand tu accède à l'adresse http://nomdomaine.fr/ c'est en réalité sur http://nomdomaine.fr/index.php (en général) que tu tombes ? C'est le serveur web qui gère cette redirection qui se configure par l'intermédiaire de DirectoryIndex sur Apache.
 
Prestashop ne contient pas son propre fichier index.php?


---------------
Origin / PSN / Steam / Uplay : x1fr - bnet : Fab#2717
n°2181459
nesis21000
Posté le 20-03-2013 à 19:06:34  profilanswer
 

Merci pour votre aide,
le fichier index.php de prestaqhop ne change rien.
pour le DirectoryIndex quels sont les démarches à faire ?

n°2181461
x1fr
Posté le 20-03-2013 à 19:19:58  profilanswer
 

Quand tu accèdes à ton site prestashop en local sur wamp, quelle est l'adresse exacte saisie dans le navigateur?
 
le DirectoryIndex est géré sur le serveur (ou dans le fichier .htacess), à priori il est déjà réglé comme il faut puisque tu peux lui faire afficher la date


---------------
Origin / PSN / Steam / Uplay : x1fr - bnet : Fab#2717
n°2181463
nesis21000
Posté le 20-03-2013 à 20:01:52  profilanswer
 

voici le lien lorsque je me connecte sur mon serveur local :
 
http://localhost/prestashop/index. [...] r=category

n°2181486
x1fr
Posté le 20-03-2013 à 23:10:49  profilanswer
 

donc si tu as copié le contenu de /prestashop sur ton pc dans le /www/ de ton serveur, il faut qu'il y ait le fichier /www/index.php!
 
Ensuite tu devrais pouvoir accéder à prestashop en utilisant l'adresse :
http://mondomaine.fr/index.php?id_ [...] r=category


---------------
Origin / PSN / Steam / Uplay : x1fr - bnet : Fab#2717

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  Divers

  Problème mise en ligne de mon site, suis je un boulet ???

 

Sujets relatifs
[RESOLU]site extensible+resolution image de fond 1900x1080Problème jointure requête sql.
Problème de validation de formulaireProblème d'affectation ( methode hongroise )
Je recherche un webmaster et un graphiste pour mon site Internetproblème programmation VBA
Problème de rechercheproblème script PHP
Extract de terme entre "et" commerciale dans la lignemise a jour d'un fichier texte
Plus de sujets relatifs à : Problème mise en ligne de mon site, suis je un boulet ???


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR