Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1680 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  réseaux et sécurité

  Samba me refait des misere

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Samba me refait des misere

n°532336
Aurelien62​fr
Posté le 02-08-2004 à 13:02:50  profilanswer
 

Bonjour tous le monde  :hello:  
Bon voila je suis rentrer de vacance, et je m'aperçoi que linux n'est plus sur mon reseau. Dans le tps quand j'aller sous mon poste windows XP dans favoris reseau, je voyait l'ordinateur linux, je cliquer dessus, il me demander un mdp je le mettez et je me retrouvez dans mon repertoire partagé.
Maintenant mon ordinatuer linux ne si trouve plus, donc je vais sur mon pc linux et je tape localhost:901 pour acceder au menu de config samba, et la c'est le drame....
Il me dit impossible d'afifcher cette page. Je ne comprend pas ce qui se passe.
Que pourrais je faire, le pire c'est que sa fonctionner enfin.
 
Merci de votre aide et bonne journée a tous  :hello:  
 
PS : je suis sous linux mandrake 10.0 official

mood
Publicité
Posté le 02-08-2004 à 13:02:50  profilanswer
 

n°532363
farib
Posté le 02-08-2004 à 13:49:21  profilanswer
 

Aurelien62fr a écrit :


Maintenant mon ordinatuer linux ne si trouve plus, donc je vais sur mon pc linux et je tape localhost:901 pour acceder au menu de config samba, et la c'est le drame....

[:totoz]


---------------
Bitcoin, Magical Thinking, and Political Ideology
n°532375
Aurelien62​fr
Posté le 02-08-2004 à 14:02:15  profilanswer
 
n°532382
Dark_Schne​ider
Close the World, Open the Net
Posté le 02-08-2004 à 14:08:03  profilanswer
 

as tu installer swat ?


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°532479
Aurelien62​fr
Posté le 02-08-2004 à 16:06:28  profilanswer
 

Dark_Schneider a écrit :

as tu installer swat ?


 
oui oui, ceux de ma distribution.
Comme on me l'avais dit. D'ailleur il a fonctionné un moment. et maintenant il n'est plus la. J'ai donc été dans le ficher de config de samba, et j'ai coller un exemple qu'il y avait sur ce forum, bien sur en mettant les nom qui corresponde a mon reseau, et pareil, rien ne revient sous windows, je pige pas, pourtant tous les paquetage sont present

n°532521
Dark_Schne​ider
Close the World, Open the Net
Posté le 02-08-2004 à 16:46:02  profilanswer
 

as tu lancé le service samba ?
 
as tu vérifié que swat est activé ( /etc/xinetd.d/swat ) et relancé xinetd ?


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°532647
Aurelien62​fr
Posté le 02-08-2004 à 20:37:31  profilanswer
 

je tape quoi pour lancer le service samba ?

n°532669
Aurelien62​fr
Posté le 02-08-2004 à 21:18:15  profilanswer
 

voila, j'ai verifier, samba est en marche, swat est configurer correctement, bref je vois pas le pb

n°532844
Dark_Schne​ider
Close the World, Open the Net
Posté le 03-08-2004 à 10:38:12  profilanswer
 

service samba restart
service xinetd restart
 
 
puis tu te connectes à cette adresse : 127.0.0.1:901


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°532976
Aurelien62​fr
Posté le 03-08-2004 à 13:25:09  profilanswer
 

Dark_Schneider a écrit :

service samba restart
service xinetd restart
 
 
puis tu te connectes à cette adresse : 127.0.0.1:901


 
Lol, bah y veut tjour pas, je comprend pas, j'ai refait toute le configuration du debut a la fin, j'ai tous verifier, tout est bon. Et il dit encore qu'il n'arrive pas a se connecter a 127.0.0.1:901

mood
Publicité
Posté le 03-08-2004 à 13:25:09  profilanswer
 

n°532997
Dark_Schne​ider
Close the World, Open the Net
Posté le 03-08-2004 à 13:41:40  profilanswer
 

as tu essayé en https ?
https://127.0.0.1:901
 
 
si cela ne marche pas donne le résultat des commandes suivantes :
cat /etc/xinetd.d/swat
cat /etc/hosts.allow
cat /etc/hosts.deny
cat /etc/sysconfig/msec
rpm -qa | grep samba


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°533014
Aurelien62​fr
Posté le 03-08-2004 à 14:01:55  profilanswer
 

Donc en https rien non plus, donc j'ai fait tous ce que tu m'as demandé :
 
[root@localhost aurelien]# cat /etc/xinetd.d/swat
# default: off
# description: SWAT is the Samba Web Admin Tool. Use swat \
#              to configure your Samba server. To use SWAT, \
#              connect to port 901 with your favorite web browser.
service swat
{
        port            = 901
        socket_type     = stream
        wait            = no
        only_from       = 127.0.0.1
        user            = root
        server          = /usr/sbin/swat
        log_on_failure  @= USERID
        disable         =  yes
}
[root@localhost aurelien]# cat /etc/host.allow
cat: /etc/host.allow: No such file or directory
[root@localhost aurelien]# cat /etc/hosts.allow
#
# hosts.allow   This file describes the names of the hosts which are
#               allowed to use the local INET services, as decided
#               by the '/usr/sbin/tcpd' server.
#
 
[root@localhost aurelien]# cat /etc/hosts.deny
#
# hosts.deny    This file describes the names of the hosts which are
#               *not* allowed to use the local INET services, as decided
#               by the '/usr/sbin/tcpd' server.
#
# The portmap line is redundant, but it is left to remind you that
# the new secure portmap uses hosts.deny and hosts.allow.  In particular
# you should know that NFS uses portmap!
 
[root@localhost aurelien]# cat /etc/sysconfig/msec
UMASK_ROOT=022
SECURE_LEVEL=2
UMASK_USER=022
TMOUT=0
[root@localhost aurelien]# rpm -qa | grep samba
samba-common-3.0.2a-3mdk
samba-swat-3.0.2a-3mdk
samba-client-3.0.2a-3mdk
samba-server-3.0.2a-3mdk
[root@localhost aurelien]#[fixed]
 
encore merci pour ton aide
 
PS : Tres bien fais le how to de ton site pour les drviers nvidia, mais le lien que tu donne pour telecharger le driver nvidia est bon, mais n'est pas compatible avec mandrake 10.0, j'ai du le remplacer par le lien du site de nvidia, voila si sa peut t'aider


Message édité par Aurelien62fr le 03-08-2004 à 14:37:36
n°533086
Dark_Schne​ider
Close the World, Open the Net
Posté le 03-08-2004 à 15:38:44  profilanswer
 

dans /etc/xinetd.d/swat :
disable         =  yes  
 
 
à ton avis cela signifie koi ? je te laisse trouvé la réponse


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°533144
Aurelien62​fr
Posté le 03-08-2004 à 16:45:51  profilanswer
 

Dark_Schneider a écrit :

dans /etc/xinetd.d/swat :
disable         =  yes  
 
 
à ton avis cela signifie koi ? je te laisse trouvé la réponse


 
J'ai mit "no", mais sa fonctionne tjour pas

n°533174
Dark_Schne​ider
Close the World, Open the Net
Posté le 03-08-2004 à 17:31:02  profilanswer
 

tu as relancé xinetd après avoir fais cela pour que la modif soit prise en compte ?
 
service xinetd restart


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°533189
Aurelien62​fr
Posté le 03-08-2004 à 17:41:43  profilanswer
 

Dark_Schneider a écrit :

tu as relancé xinetd après avoir fais cela pour que la modif soit prise en compte ?
 
service xinetd restart


 
oui bien sur, mais rien, je vias essayer de voir si rien ne bloque le port 901

n°533205
Dark_Schne​ider
Close the World, Open the Net
Posté le 03-08-2004 à 17:51:29  profilanswer
 

et vérifie bien que tu as disable = no
 
dans le fichier de swat


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°533211
Aurelien62​fr
Posté le 03-08-2004 à 17:58:30  profilanswer
 

Bon et bien voila, j'ai tout verfier, j'ai meme suivi un tuto qui expliquer comment configurer swat a partir d'un autre pc, et rien, sa veu tjour pas. Je pense pas que le probleme vienne de swat, vu qu'avant ma machine apparaissait sur le reseau, et maintenant plus rien

n°533212
Dark_Schne​ider
Close the World, Open the Net
Posté le 03-08-2004 à 18:02:08  profilanswer
 

tu fais bien : https://127.0.0.1:901 ?


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°533214
Aurelien62​fr
Posté le 03-08-2004 à 18:03:54  profilanswer
 

bah oui

n°533224
Dark_Schne​ider
Close the World, Open the Net
Posté le 03-08-2004 à 18:10:06  profilanswer
 

tu le fais depuis l'ordi sur lequel est installé samba ?
 
parce que la ligne "only_from = 127.0.0.1" ne te permet de te connecter que depuis l'ordi faisant tourner swat


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°533226
Aurelien62​fr
Posté le 03-08-2004 à 18:11:49  profilanswer
 

oui j'ai fais dps mon pc avec swat bien sur, pour le faire avec un autre pc, j'avais tous simplement ajouter un "#" avant cette ligne, mias j'ai remit normale vu que sa ne m'avancer en rien. Je vias peut etre essayer de totalement desinstaller samba puis de le remettre, quand dis tu ?

n°533228
Dark_Schne​ider
Close the World, Open the Net
Posté le 03-08-2004 à 18:14:37  profilanswer
 

pkoi pas ...
 
urpme samba-swat samba-common
urpmi samba-swat samba-server samba-client


---------------
Mandriva : parce que nous le valons bien ! http://linux-wizard.net/index.php
n°533325
Aurelien62​fr
Posté le 03-08-2004 à 21:37:48  profilanswer
 

voila sa remarche, il suffisait de desinstaller et reinstaller samba. Merci de ton aide c'est tres sympatique, bonne soirée :hello:

mood
Publicité
Posté le   profilanswer
 


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  réseaux et sécurité

  Samba me refait des misere

 

Sujets relatifs
[migration win2k => samba + ldap + krb][MDK10][Win] Samba
problème avec samba (résolu)Samba, rien ne fonctionne :/
Un pc linux qui fait firewall, routeur, samba, cups, apache + mysqlAccès à distance à un serveur de fichiers Samba
[Samba]Partage de dossier : NT_STATUS_BAD_NETWORK_NAMEserveur WINS / Samba
netbios name et workgroup sambaConnexion sans mot de passe via login AD ou SAMBA
Plus de sujets relatifs à : Samba me refait des misere


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR