Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Shop Recherche
1863 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  réseaux et sécurité

  probleme squid sous debian

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

probleme squid sous debian

n°991346
thierry_b
Posté le 14-12-2007 à 12:41:09  profilanswer
 

Bonjour,
 
J'ai un problème avec squid pour que je puisse utiliser un proxy à partir de mon lieu de travail (qui a une ip fixe).
 
Voila ma config:
 
 
cat /etc/squid/squid.conf | grep -i -n -v "^#"
 
73:http_port zzzzzzzzzz
 
702:hierarchy_stoplist cgi-bin ?
 
714:acl QUERY urlpath_regex cgi-bin \?
715:cache deny QUERY
 
732:acl apache rep_header Server ^Apache
733:broken_vary_encoding allow apache
 
1111:access_log /var/log/squid/access.log squid
 
1416:hosts_file /etc/hosts
 
2427:acl all src 0.0.0.0/0.0.0.0
2428:acl manager proto cache_object
2429:acl localhost src 127.0.0.1/255.255.255.255
2430:acl to_localhost dst 127.0.0.0/8
2431:acl SSL_ports port 443             # https
2432:acl SSL_ports port 563             # snews
2433:acl SSL_ports port 873             # rsync
2434:acl Safe_ports port 80             # http
2435:acl Safe_ports port 21             # ftp
2436:acl Safe_ports port 443            # https
2437:acl Safe_ports port 70             # gopher
2438:acl Safe_ports port 210            # wais
2439:acl Safe_ports port 1025-65535     # unregistered ports
2440:acl Safe_ports port 280            # http-mgmt
2441:acl Safe_ports port 488            # gss-http
2442:acl Safe_ports port 591            # filemaker
2443:acl Safe_ports port 777            # multiling http
2444:acl Safe_ports port 631            # cups
2445:acl Safe_ports port 873            # rsync
2446:acl Safe_ports port 901            # SWAT
2447:acl purge method PURGE
2448:acl CONNECT method CONNECT
 
http_access allow manager localhost
http_access deny manager
 
http_access allow purge localhost
http_access deny purge
 
http_access deny !Safe_ports
http_access deny CONNECT !SSL_ports
 
 
acl our_networks src 192.168.1.0/24
acl yyyy src xxxxxx
http_access allow localhost our_networks xxxxxx
 
http_reply_access allow all
icp_access allow all
cache_effective_group proxy
 
coredump_dir /var/spool/squid
 
--------------------------------------------------
 
 
Par contre, si je mets un "http_access allow all" tout au dessus donc que je dis que tout va passer, ca marche.
 
Pourtant, xxxxxx est bien l'ip publique avec laquelle je me connecte depuis le boulot, vu que j'arrive à la voir dans les logs de squid:
 
----------------------------------------------------------------------------------
 1197637258.392      2 xxxxxx TCP_DENIED/403 1420 GET http://www.mon-ip.com/ - NONE/- text/html
----------------------------------------------------------------------------------------------------------------
 
Une idée?
 
 
Merci :-)

mood
Publicité
Posté le 14-12-2007 à 12:41:09  profilanswer
 

n°991621
THRAK
- THR4K -
Posté le 15-12-2007 à 13:35:37  profilanswer
 

En rajoutant l'adresse ip dans /etc/hosts.allow  ?
 
Plus d'infos : man hosts_access et man hosts_options


---------------
THRAK (def.) : 1) A sudden and precise impact moving from intention, direction and commitment, in service of an aim. 2) 117 guitars almost striking the same chord simultaneously.
n°991994
boobaka
Posté le 17-12-2007 à 09:22:44  profilanswer
 

acl yyyy src xxxxxx
http_access allow localhost our_networks xxxxxx


 
C'est pas xxxxx qu'il faut mettre dans http_access mais le nom de ton acl soit yyyy

n°1121309
shurik84
Posté le 12-03-2009 à 17:32:24  profilanswer
 

bonjour ou re pour certains voila moi j'ai un autre probleme
 
j'ai essayer d'installé squid et je l'ai parametré exactement comme cela
 
http://irp.nain-t.net/doku.php/220squid:020_squid  
 
J'ai voulu tester sur le réseau locale l'authentification avec un utilisateurs locale ! je pense que mon fichier squid.conf est bien configuré mais quand je vais sur le navigateur, je n'ai aucune fenetre d'authentification qui apparait et je ne sais pas pourquoi j'ai l'impression que le navigateur ne charge pas le proxy squid  
 
voici mon fichier de conf :
 

Code :
  1. http_port 3128
  2. icp_port 3130
  3. hierarchy_stoplist cgi-bin ?
  4. acl QUERY urlpath_regex cgi-bin \?
  5. cache deny QUERY
  6. refresh_pattern ^ftp:  1440 20% 10080
  7. refresh_pattern ^gopher: 1440 0% 1440
  8. refresh_pattern .  0 20% 4320
  9. #indique le chemin du module ncsa_auth et du chemin du fichier des utilisateurs
  10. auth_param basic program /usr/lib/squid3/ncsa_auth /etc/squid3/users
  11. auth_param basic children 5
  12. #texte qui apparaîtra dans la fenêtre de demande d'identification
  13. auth_param basic realm Squid proxy-caching web server
  14. #Determine la durée de vie de l'identification
  15. auth_param basic credentialsttl 2 hours
  16. acl all src 0.0.0.0/0.0.0.0
  17. acl manager proto cache_object
  18. acl localhost src 127.0.0.1/255.255.255.255
  19. acl to_localhost dst 127.0.0.0/8
  20. acl SSL_ports port 443
  21. acl Safe_ports port 80  # http
  22. acl Safe_ports port 21  # ftp
  23. acl Safe_ports port 443  # https
  24. acl Safe_ports port 70  # gopher
  25. acl Safe_ports port 210  # wais
  26. acl Safe_ports port 1025-65535 # unregistered ports
  27. acl Safe_ports port 280  # http-mgmt
  28. acl Safe_ports port 488  # gss-http
  29. acl Safe_ports port 591  # filemaker
  30. acl Safe_ports port 777  # multiling http
  31. acl CONNECT method CONNECT
  32. #
  33. #Permet de definir les ip du local
  34. acl Netlocal src 127.0.0.1/255.255.255.255
  35. #acl supplémentaire, pour obliger l'identification
  36. acl Users proxy_auth REQUIRED
  37. #
  38. http_access allow manager localhost
  39. http_access deny manager
  40. http_access deny !Safe_ports
  41. http_access deny CONNECT !SSL_ports
  42. #
  43. #Autorisation au local de passer le proxy
  44. http_access allow Netlocal Users
  45. #
  46. http_access deny all
  47. http_reply_access allow all
  48. icp_access allow all
  49. coredump_dir /var/spool/squid3


 
Quelqu'un pourrait il me dire pourquoi et comment le faire marcher
Je souhaite juste permettre le controle d'authentification du proxy sur le navigateur avec un utilisateur local
 
Thx  :sweat:  de votre aide


Message édité par shurik84 le 12-03-2009 à 17:33:55
n°1121310
o'gure
Modérateur
Multi grognon de B_L
Posté le 12-03-2009 à 17:36:12  profilanswer
 

Juste pour être sûr, as tu configuré le proxy dans le browser Web ?


---------------
Ton Antoine commence à me les briser menus !
n°1121338
shurik84
Posté le 12-03-2009 à 19:32:31  profilanswer
 

o'gure a écrit :

Juste pour être sûr, as tu configuré le proxy dans le browser Web ?


 
 
Oui et Non !! Justement j'ai cherché a le configurer mais j'ai rien trouver sur les 2 navigateurs  web qui sont par default sur debian, il y a un browser qui est l'equivalent de firefox j'ai essayé de le configurer en mettant par default le port 3128 utilisé par squid mais comme adresse de proxy : j'ai pas su quoi mettre étant donné que squid est un proxy local sur mon serveur et que j'ai pas trouvé d'adresse a mettre !
 
Je pense que ca doit être au niveau des modules car mon utilisateur est bien créer et mémorisé par squid mais la fenêtre d'authentification internet n'apparait pas ! ou sinon comme tu le pense au niveau du browser !

Message cité 1 fois
Message édité par shurik84 le 12-03-2009 à 19:39:49
n°1121348
o'gure
Modérateur
Multi grognon de B_L
Posté le 12-03-2009 à 20:39:07  profilanswer
 

shurik84 a écrit :

Oui et Non !! Justement j'ai cherché a le configurer mais j'ai rien trouver sur les 2 navigateurs  web qui sont par default sur debian, il y a un browser qui est l'equivalent de firefox j'ai essayé de le configurer en mettant par default le port 3128 utilisé par squid mais comme adresse de proxy : j'ai pas su quoi mettre étant donné que squid est un proxy local sur mon serveur et que j'ai pas trouvé d'adresse a mettre !


Genre l'adresse IP du serveur ?


---------------
Ton Antoine commence à me les briser menus !
n°1121430
shurik84
Posté le 13-03-2009 à 09:27:40  profilanswer
 

o'gure a écrit :


Genre l'adresse IP du serveur ?


 
Donc voila j'ai tester avec l'adresse ip du serveur et ca ne marche toujours pas !
Dans le doute j'ai essayé avec d'autre interfaces ip = toujours le meme résultat
 
Ce que je trouve bizarre et ce qui n'a pas marché par rapport au lien :
 
Aprés l'installation de squid, aucun blocage du browser
Aprés la configuration de squid, pareil

n°1121437
o'gure
Modérateur
Multi grognon de B_L
Posté le 13-03-2009 à 09:41:37  profilanswer
 

"Ca ne marche" n'est pas une information pertinente. Décrit ce qui se passe.
- un message d'erreur dans le browser (si oui lequel) ;
- tu obtiens les pages web sans authentification ;
- ton browser "tourne" sans rien obtenir (ni page, ni message d'erreur...)
Nous ne sommes malheureusement pas devin.
 
Il va te falloir être un peu plus précis, si tu souhaites une aide correcte.
 
Comme d'habitude, as tu pensé à consulter les logs du logiciel qui te pose problème, en l'occurence squid ?
Il te dira exactement où se situe le problème :
- si le log access.log indique que ton browser utilise le proxy pour récupérer des données sur le web.
- si le log access.log n'indique pas les pages que ton browser consulte alors que tu l'as configuré correctement (le browser, ie. l'adresse IP de ton proxy/squid et le port 3128) c'est qu'en réalité tu l'as mal configuré
- si le log access.log indique des erreurs 403, 404...  
- ...


---------------
Ton Antoine commence à me les briser menus !
n°1121454
shurik84
Posté le 13-03-2009 à 10:18:11  profilanswer
 

o'gure a écrit :

"Ca ne marche" n'est pas une information pertinente. Décrit ce qui se passe.
- un message d'erreur dans le browser (si oui lequel) ;
- tu obtiens les pages web sans authentification ;
- ton browser "tourne" sans rien obtenir (ni page, ni message d'erreur...)
Nous ne sommes malheureusement pas devin.
 
Il va te falloir être un peu plus précis, si tu souhaites une aide correcte.
 
Comme d'habitude, as tu pensé à consulter les logs du logiciel qui te pose problème, en l'occurence squid ?
Il te dira exactement où se situe le problème :
- si le log access.log indique que ton browser utilise le proxy pour récupérer des données sur le web.
- si le log access.log n'indique pas les pages que ton browser consulte alors que tu l'as configuré correctement (le browser, ie. l'adresse IP de ton proxy/squid et le port 3128) c'est qu'en réalité tu l'as mal configuré
- si le log access.log indique des erreurs 403, 404...  
- ...


 
Je sais  :ange:  et pardon mais le probléme est celui ci aprés configuration :
J'obtiens les pages sans authentification et mon browser "tourne" sans message d'erreur
J'y ai pas pensé mais j'obtiens ceci quand je vais y jeter un oeil
 

Code :
  1. 1236932140.580      5 192.168.247.100 TCP_DENIED/403 2228 GET http://www.netvibes.com/favicon.ico - NONE/- text/html
  2. 1236932140.580      5 192.168.247.100 TCP_DENIED/403 2231 GET http://www.bloglines.com/favicon.ico - NONE/- text/html
  3. 1236932140.580      5 192.168.247.100 TCP_DENIED/403 2228 GET http://add.my.yahoo.com/favicon.ico - NONE/- text/html


 
Cette adresse ip est l'adresse de ma derniere interface obtenu par le DHCP sous VMware, celle qui me permet de connecter mon serveur quand j'utilise le NAT pour le filtrage
Aucun filtrage sur mon serveur, j'ai desactiver le FW et mit les polices par default


Message édité par shurik84 le 13-03-2009 à 14:21:11
mood
Publicité
Posté le 13-03-2009 à 10:18:11  profilanswer
 

n°1121629
shurik84
Posté le 13-03-2009 à 15:47:06  profilanswer
 

C'est bon j'ai reussi a le configurer finalement ! Merci de ton aide o'gure :)


Message édité par shurik84 le 13-03-2009 à 15:52:27
n°1186796
shurik84
Posté le 18-12-2009 à 10:23:49  profilanswer
 

Bonjour, je sais que je ne suis pas trop en rapport avec la question initiale mais j'ai un petit doute concernant le fichier access.log de squid

 

voila j'ai un serveur qui tourne sur un réseau et qui me sert de proxy dans une salle de cours, j'ai actuellement pour 2 semaines le fichier access.log d'environ 46,Mo

 

Peut on le supprimer ou le vider sans que cela n' affecte le filtrage ou ne le désactive ( proxy de la salle ) quelle est la manip la plus propre et la plus simple ? pour eviter de saturer mon DD sachant que je récupére a chaque fois le fichier sur mon poste qui est sur site distant !!!

 

PS : ca fait qq mois que j'ai plus touché du linux je m'y remet doucement dans un cadre pro mais j'ai un doute sur le fichier log

 

Mon prédecesseur a apparement configurer ceci dans le fichier squid.conf :

 

cache_mem 128MB (taille du cache 128 MB )
maximum_object_size15MB

 

Merci de vos réponses


Message édité par shurik84 le 18-12-2009 à 11:02:05
n°1186797
black_lord
Modérateur
Truth speaks from peacefulness
Posté le 18-12-2009 à 10:25:30  profilanswer
 

echo "" > /var/log/squid/access.log


---------------
uptime is for lousy system administrators what Viagra is for impotent people - mes unixeries - github me
n°1186798
shurik84
Posté le 18-12-2009 à 10:33:32  profilanswer
 

black_lord a écrit :

echo "" > /var/log/squid/access.log


 
Aprés cette manip qui est censé vider le fichier access.log, ce meme fichier ce régenére t - il par la suite ?

n°1186805
kisscoolz
Posté le 18-12-2009 à 11:13:28  profilanswer
 

Tu dois avoir dans ton fichier de conf squid.conf une directive logfile_rotate à ajuster en foncion du nombre de fichier que tu veux garder.  
 
Ensuite, pour faire tourner ton fichier de log tu lance la commande
 

Code :
  1. squid -k rotate


 
Tu peux automatiser la rotation des logs en ajoutant la commande dans le fichier crontab.
 
Par exemple :

Code :
  1. 0       0       *       *       *       root    /usr/local/sbin/squid -k rotate


 
Pour faire ca tous les jours à minuit.

n°1186811
black_lord
Modérateur
Truth speaks from peacefulness
Posté le 18-12-2009 à 11:26:52  profilanswer
 

shurik84 a écrit :


 
Aprés cette manip qui est censé vider le fichier access.log, ce meme fichier ce régenére t - il par la suite ?


oui :D


---------------
uptime is for lousy system administrators what Viagra is for impotent people - mes unixeries - github me

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  réseaux et sécurité

  probleme squid sous debian

 

Sujets relatifs
[Debian Sid] KDE ne se lance plusProblème extention "provider google calendar" pour ligthning
comment connaitre la version d'une vmware sous linux debian??Problème à l'installation de DEBIAN 4
Problème ethernet sous Kubuntu[Résolut] Partage internet par Linux Debian pour Windows avec un hub
problème ntp sur debian vmwareInstaller GD sur Debian Sarge
[debian] probleme Samba, question Squidsquid/squidguard (debian) -> problème de transfert FTP
Plus de sujets relatifs à : probleme squid sous debian


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR