Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1224 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  réseaux et sécurité

  Problème de bridge -Debian-

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Problème de bridge -Debian-

n°977124
P1511GD
Posté le 10-11-2007 à 19:39:25  profilanswer
 

Bonsoir  :hello:  
 
Je rencontre un petit soucis, mais avant tout, pour vous aider à comprendre, voici le schéma de mon réseau, de ce que je cherche à obtenir :
 

Code :
  1. .                   [Internet]
  2.                        | |
  3.                        | |
  4.                 [Modem - Routeur]
  5.                 [  192.168.0.1  ]
  6.                  /             \
  7.                 /               \
  8.              [PC 1]          [Point d'accès Wifi]
  9.              [DHCP]          [   192.168.0.2    ]
  10.                                "              "
  11.                                "              "
  12.                                "              "
  13.                                "          [Wlan0]----\
  14.                             [PC 2]       [Serveur]    > [Br0 (bridge)] [192.168.0.8]
  15.                             [DHCP]         [Eth0]----/
  16.                                               |
  17.                                               |
  18.                                            [Switch]
  19.                                            /   |   \
  20.                                           /    |    \
  21.                                          /     |     \
  22.                                         /      |      \
  23.                                     [PC 3]   [PC 4]   [PC 5]
  24.                                     [DHCP]   [DHCP]   [DHCP]


 
Je ne sais pas si mon schéma est assez clair, mais voilà ce que je veux faire :
 
J'ai un modem/routeur qui se connecte à internet avec l'ip 192.168.0.1 et dont le serveur DHCP est activé.
Ce modem/routeur est connecté à un point d'accès Wifi. Au réseau Wifi créé se connectent deux PC :
- Un PC classique qui prend son IP grâce au DHCP
- Un Serveur qui tourne avec une Debian lenny :
*** Il se connecte au réseau Wifi avec l'interface réseau Wlan0 : 192.168.0.9
*** Il est relié à un switch ethernet avec l'interface eth0 : 192.168.0.10
 
Ces deux interfaces sont bridgées dans /etc/network/interfaces par le pont br0 dont l'ip est 192.168.0.8
 
Le pont réseau en lui même fonctionne : je peux pinger le serveur sur l'IP 192.168.0.8 depuis le réseau ethernet ou le réseau wifi, en revanche, ces deux réseaux ne communiquent pas entre eux : la partie ethernet est isolée du reste du réseau (impossible d'accéder à internet, au PC 1 sur le schéma, etc... et ce depuis les PC 3/4/5).
 
Aurais-je raté une étape ? Il m'est indispensable de pouvoir faire communiquer ces deux parties de mon réseau je pense pourtant avoir fait le nécéssaire :/
 
Voilà un bout de dmesg :

Citation :


ADDRCONF(NETDEV_UP): wlan0: link is not ready
Bridge firewalling registered
device eth0 entered promiscuous mode
audit(1194719675.923:2): dev=eth0 prom=256 old_prom=0 auid=4294967295
device wlan0 entered promiscuous mode
audit(1194719675.923:3): dev=wlan0 prom=256 old_prom=0 auid=4294967295
br0: port 1(eth0) entering learning state
ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
br0: port 2(wlan0) entering learning state
eth0: no IPv6 routers present
br0: no IPv6 routers present
wlan0: no IPv6 routers present
br0: topology change detected, propagating
br0: port 1(eth0) entering forwarding state
br0: topology change detected, propagating
br0: port 2(wlan0) entering forwarding state


 
Mon /etc/network/interfaces :

Citation :


# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).
 
# The loopback network interface
auto lo
iface lo inet loopback
 
# The primary network interface
allow-hotplug eth0
 
iface eth0 inet static
        address 192.168.0.10
        network 192.160.0.0
        netmask 255.255.255.0
        broadcast 192.168.0.255
        gateway 192.168.0.1
        dns-nameservers 212.27.39.2
        dns-search home
        auto eth0
 
iface wlan0 inet static
        address 192.168.0.9
        network 192.160.0.0
        netmask 255.255.255.0
        broadcast 192.168.0.255
        gateway 192.168.0.1
        dns-nameservers 212.27.39.2
        dns-search home
        wireless_keymode open
        wireless_mode managed
        wireless_nick srvolivier
        wireless-essid SMC2870
        wireless-key [La bonne clée WEP]
        auto wlan0
 
iface br0 inet static
        address 192.168.0.8
        network 192.160.0.0
        netmask 255.255.255.0
        broadcast 192.168.0.255
        gateway 192.168.0.1
        dns-nameservers 212.27.39.2
        dns-search home
        bridge_ports eth0 wlan0
        auto br0


 
 
Si quelqu'un a une idée, merci de m'en faire profiter !
 
Cordialement,

mood
Publicité
Posté le 10-11-2007 à 19:39:25  profilanswer
 

n°977139
dreamer18
CDLM
Posté le 10-11-2007 à 20:38:36  profilanswer
 

si c'est un bridge il faut le même réseau des deux cotés, sinon il faut router entre tes deux réseaux différents :) enfin si j'ai bien compris ton schéma...


---------------
"Parceque toi tu fracasses du migrant à la batte de baseball, c'est ça ?" - Backbone-
n°977157
P1511GD
Posté le 10-11-2007 à 22:48:47  profilanswer
 

Mais quel idiot...  

Citation :

network 192.160.0.0


 
C'etait une erreur de frappe ^^ Je corrige et je test, merci :)


Message édité par P1511GD le 10-11-2007 à 22:50:39
n°977158
P1511GD
Posté le 10-11-2007 à 23:00:03  profilanswer
 

Et bien non hélas cela ne marche pas non plus :(


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  réseaux et sécurité

  Problème de bridge -Debian-

 

Sujets relatifs
Debian apt HS ?Problème Fluxbox avec Debian Lenny
DELL Inspiron 6400 ATI X1400 Probleme de Bureau 3DProbleme pour parametrer un proxy sous red hat.
samba\redhat probleme authentificationprobleme de son ubuntu
[KDE] - Problème de taille de polices[Debian] Renommer les interfaces réseaux
probleme image de boot 
Plus de sujets relatifs à : Problème de bridge -Debian-


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR