Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
2183 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  réseaux et sécurité

  [LAMP local] connexion serveur instable

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[LAMP local] connexion serveur instable

n°889761
Zorro561
Posté le 24-02-2007 à 22:07:30  profilanswer
 

Salut à tous !
 
J'ai monté un serveur LAMP sur une machine que j'ai récupérée, et il est actuellement disponible à l'adresse 192.168.0.2 (j'ai une Freebox HD avec le mode routeur, et j'ai mis des baux DHCP permanents).
Le seul problème, c'est que la connexion vers le serveur est très instable...
 
Par exemple, je ping le serveur à partir de ma station principale (192.168.0.1) et de temps à autres, j'obtiens une réponse au ping de moins d'1ms (normal on est en local). Le problème c'est que les 3/4 du temps, le serveur ne répond tout simplement pas, c'est très variable.
Lorsqu'il répond au ping, et que je peux accéder à mes fichiers situés sur le /var/www distant en tapant son IP, le débit n'est pas optimal (je l'ai remarqué car il met facilement une seconde à charger la liste de 2 fichiers PHP alors qu'avant quand tout allait bien, c'était instantané) et si je vais dans PHPMyAdmin, le ping dépasse les 400,800 voire les 1000 car il met un peu plus de temps à charger la page (PHPMyAdmin n'est pas très léger). Passé le chargement de cette lourde interface, le ping redescend à moins de 1ms.
 
Le problème est apparu depuis que j'ai changé l'alimentation ATX du serveur. En effet elle était vraiment trop bruyante et j'ai décidé de la remplacer par une autre, plus silencieuse. Celle d'origine faisait je crois du 250W et la nouvelle silencieuse fait du 350W. Pas de problème, j'ai effectué le remplacement.
C'est là que les problèmes décrits ci-dessus ont commencé. J'ai fait toute une série de tests en changeant les alimentations, les cartes réseaux et les câbles Ethernet.
Le réglage optimal que j'avais trouvé était le suivant : utiliser la nouvelle alimentation en débranchant le lecteur CD et le lecteur Disquettes (de toutes façons ça m'est inutile car je gère le serveur avec ssh). Là, tout était fluide.
J'ai redémarré le serveur pour bien vérifier mais il ne répondait plus du tout (ping et firefox). J'ai attendu quelques minutes puis je l'ai redémarré...
La connexion était de nouveau présente mais le ping (sans charger PhpMyAdmin) avoisinait les ~1300 (encore une fois ça variait mais c'était vraiment n'importe quoi).
 
Voilà, je vous ai tout dit, je ne sais pas quoi faire étant donné que ça marche quand ça veut. Je ferai sûrement des tests avec un écran branché sur le serveur demain !
 
Aidez-moi et bonne soirée à tous ! Merci encore.

mood
Publicité
Posté le 24-02-2007 à 22:07:30  profilanswer
 

n°889767
zecrazytux
Posté le 24-02-2007 à 22:17:58  profilanswer
 

assez surprenant cette affaire :o
 


---------------
Blog photo/récits activités en montagne http://planetcaravan.net
n°889806
Zorro561
Posté le 25-02-2007 à 10:19:44  profilanswer
 

Je commence la phase de tests  [:angelusdeus] .

n°889809
zecrazytux
Posté le 25-02-2007 à 10:42:23  profilanswer
 

tien nous au jus, ça peu toujours servir à d'autres :jap: :)


---------------
Blog photo/récits activités en montagne http://planetcaravan.net
n°889940
Zorro561
Posté le 25-02-2007 à 19:51:38  profilanswer
 

Bon bah je me suis pas fait chier, j'ai réinstallé Ubuntu Server en mode LAMP sur la machine après avoir changé la carte réseau.
L'installation s'est bien passée (détection automatique du DHCP) et j'ai juste configuré 2,3 trucs (ssh, hosts...). Tout passe bien maintenant, mais  je crois que j'ai confondu les deux alimentations, car là le serveur est un peu bruyant  [:delarue4] . Pas grave pour le moment, je regarderai quand j'aurai du temps à tuer !

n°892078
zecrazytux
Posté le 04-03-2007 à 12:22:13  profilanswer
 

moi mon serveur je l'ai foutu à moitié à poil avec deux ventilos 8cm en 5v, c'est bruyant mais dans le placard, faut vraiment tendre l'oreille :D


---------------
Blog photo/récits activités en montagne http://planetcaravan.net

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  réseaux et sécurité

  [LAMP local] connexion serveur instable

 

Sujets relatifs
Créer son dépot localImpossible de me connecter à mon serveur avec Filezilla
Petit serveur at homeDemande de conseil pour un serveur web
Installer un serveur de fichier linuxTailles des partitions pour un serveur (proxy)
Problème serveur X[Résolu] Partage de connexion ne fonctionne pas
Redirection vers serveur web avec IPTablesCloner un serveur de test en prod?
Plus de sujets relatifs à : [LAMP local] connexion serveur instable


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR