Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Shop Recherche
1831 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  réseaux et sécurité

  [FreeBSD 5.2] Problème Apache: "no listening socket available" résolu

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[FreeBSD 5.2] Problème Apache: "no listening socket available" résolu

n°492665
Saigneurva​dor
Posté le 01-06-2004 à 21:51:52  profilanswer
 

Salut les gens :)
 
J'ai le regret d'avoir à poster ici et de vous déranger pour solliciter un peu de votre aide :
 
1 : je suis un noob (un vrai. Je ne connais que Windows)
2 : J'ai installé une BSD, FreeBSD 5.2. Installation à partir des disquettes, quelques  
problèmes de réseau résolus tout seul comme un grand, puis l'installation de Apache2 par les ports, (make clean && make).
Le fichier /usr/local/etc/rc.d/apache2.sh est bien présent, et à la commande
"./apache2.sh", j'ai la réponse suivante :

Code :
  1. www# ./apache2.sh start
  2. no listening sockets available, shutting down
  3. Unable to open logs


 
Si je jette un oeil à "netstat -A" pour voir les ports ouverts (mais est-ce bien la bonne commande ?) j'ai le résultat suivant
 

Code :
  1. www# netstat -A
  2. Active Internet connections
  3. Socket   Proto Recv-Q Send-Q  Local Address      Foreign Address    (state)
  4. c2ed8730 tcp4       0     20  www.ssh            pc09-126.ddeamc..3 ESTABLISHED
  5. c2ed8b80 tcp4       0      0  localhost.smtp     *.*                LISTEN
  6. Active UNIX domain sockets
  7. Address  Type   Recv-Q Send-Q    Inode     Conn     Refs  Nextref Addr
  8. c2ead348 stream      0      0        0 c2ead3d4        0        0
  9. c2ead3d4 stream      0      0        0 c2ead348        0        0
  10. c2eadd20 dgram       0      0        0 c2eae000        0 c2eaddac
  11. c2eaddac dgram       0      0        0 c2eae000        0        0
  12. c2eae000 dgram       0      0 c2eaa618        0 c2eadd20        0 /var/run/log


 
Pas de port 80 ouvert. (En tout cas, depuis mon réseau un telnet sur le port 80 m'envoie gentiment péter...)
 
Siouplé, est ce que qqn pourrait me dire s'il faut au préalable déclarer l'ouverture d'un port dans un fichier quelconque ?
 
Merci d'avance de toute contribution !


Message édité par Saigneurvador le 01-06-2004 à 22:55:54
mood
Publicité
Posté le 01-06-2004 à 21:51:52  profilanswer
 

n°492678
mikala
Souviens toi du 5 Novembre...
Posté le 01-06-2004 à 22:19:55  profilanswer
 

tu as essayé en précisant le listen ? sur ton ipv4 ?

n°492688
Saigneurva​dor
Posté le 01-06-2004 à 22:25:35  profilanswer
 

mikala a écrit :

tu as essayé en précisant le listen ? sur ton ipv4 ?


 
Non.
A noter que j'avais installé en décembre une FreeBSD 4.9, et que je n'avais pas eu besoin de faire ce genre de chose.
Ca veut dire quoi "préciser le listen sur IPv4" ? Définir le port 80 comme ouvert ?

n°492701
mikala
Souviens toi du 5 Novembre...
Posté le 01-06-2004 à 22:31:27  profilanswer
 

je ne sais pas si c'est pas sous freebsd ou openbsd qu'une appli n'a pas le droit de se binder sur toutes les ips (en v4 et v6) sur un port donné .
donc configures la variable LISTEN de ton apache .(cf la doc d'apache sisi y a une doc :D )

n°492703
Saigneurva​dor
Posté le 01-06-2004 à 22:35:53  profilanswer
 

Ben j'ai déjà configuré Apache (enfin, j'ai fait ça comme j'ai pu ;-), mais le LISTEN apparemment ça ne sert pas à ça :
# Listen: Allows you to bind Apache to specific IP addresses and/or
# ports, instead of the default. See also the <VirtualHost>
# directive.
 
C'est pas ce que je veux ça !?

n°492709
mikala
Souviens toi du 5 Novembre...
Posté le 01-06-2004 à 22:40:53  profilanswer
 

bon j'ai du mal m'exprimé on dirait .
reprenons .
apache permet d'écouter en ipv4 (la classique ip au format 10.0.0.1 & en ipv6 par exemple l'ip  2001:7a8:20a3:1:2e0:18ff:fea9:f998 ) .
Comme dis plus haut il me semble (qu'en fonction des options de compilation de apache probablement ) une application ne puisse se binder sur un port a la fois en ipv6 et en ipv4 . c'est le comportement 'normal' de apache quand on ne spécifie pas le Listen , c'est pour cela que je te dis de *spécifier* le listen .

n°492715
Saigneurva​dor
Posté le 01-06-2004 à 22:48:32  profilanswer
 

Hop, httpd.conf modifié, on verra ça dans quelques instants :)
(qqs secondes passent)
Bon, mon petit Mikala :love: , je crois que je peux te rouler une grosse pelle !
Ca fonctionne, maintenant :bounce:
 
Allez zou, j'enchaine sur Webmin maintenant ! :ange:
 
MERCI !!!


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  réseaux et sécurité

  [FreeBSD 5.2] Problème Apache: "no listening socket available" résolu

 

Sujets relatifs
Probleme aléatoire d'affichage ecran noirProbleme avec WineX lors de lexecution de la commande
[Debian] problème avec XFS (serveur de fontes)[Résolu] downgrade de cooker vers 10.0
Postfix, imap, Squirrelmail : problème d'authentificationdiriver qui pose problème....(résolu :-) )
probleme SCSI : installation de Fedora Core 2 impossibleProblème de débutant avec gnucash / grisbi
Debutant linux cherche a installer apache, Edit: et a configuerer[Debian]Probleme de caractere en console[Résolu]
Plus de sujets relatifs à : [FreeBSD 5.2] Problème Apache: "no listening socket available" résolu


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR