Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
1791 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  réseaux et sécurité

  config de apache-ssl pour utilisation avec squirrelmail

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

config de apache-ssl pour utilisation avec squirrelmail

n°282342
nikosaka
Posté le 24-06-2003 à 16:30:59  profilanswer
 

Je viens d'installer sur mon serveur debian maison un serveur courier-imap, courier-imap-ssl et squirrelmail pour me faire un webmail (voir le topic d'hugo :  http://forum.hardware.fr/forum2.ph [...] h=&subcat=  
tout fonctionne très bien avec apache, mais comme je voulais crypté les mots de passe de mes comptes mail (quand j'y accède depuis mon école, on ne sait jamais qui s'amuse à sniffer), j'essaye de configurer apache-ssl (je précise que je ne connais pas trop apache et encore quand on n'y rajoute le ssl  :pt1cable: ), mais à chaque fois que je tapes une adresse, mozilla veut me téléchargé le fichier au lieu de l'afficher  :heink: (index.html, login.php,...)
c'est surement un paramètre tout con à ajouter dans httpd.conf mais là je trouve pas  :??:  
 
PS : apache et apache-ssl n'ont pas la même racine

mood
Publicité
Posté le 24-06-2003 à 16:30:59  profilanswer
 

n°282350
Aragorn_1e​r
Le jihad butlérian est proche
Posté le 24-06-2003 à 16:40:11  profilanswer
 

C'est trés bizzare quand meme si il te propose de telecharger des .html ...
 
Pour php, il faut ca dans httpd.conf :
 
AddType application/x-httpd-php .php
 
A+

n°282361
nikosaka
Posté le 24-06-2003 à 17:04:25  profilanswer
 

Aragorn_1er a écrit :

C'est trés bizzare quand meme si il te propose de telecharger des .html ...
 
Pour php, il faut ca dans httpd.conf :
 
AddType application/x-httpd-php .php
 
A+


ça va un peu mieux.
lorsque je tapais https://127.0.0.1 il me proposait de telechargé la page (c'est le page d'index de debian apache)
maintenant pour cela c'est résolu, mais c'est bizzare car je n'avais pas de AddType application/x-httpd-php .php dans mon httpd.conf de apache normal et ça marchait pourtant  :heink:  
mais maintenant (pour https://localhost/squirrelmail/) au lieu de me proposer une fenetre de login, il ouvre plein de fenetre mozilla (comme ouvrir le lien dans une nouvelle fenetre) et je suis obligé de le killer  :fou:


Message édité par nikosaka le 24-06-2003 à 17:05:29
n°282367
Aragorn_1e​r
Le jihad butlérian est proche
Posté le 24-06-2003 à 17:26:57  profilanswer
 

Bah là sa viendrai plustot de ta page ...
 
Et sur tout les fenetres qu'ils ouvrent il y a kelkechose de marquer dedans ?
 
A+


Message édité par Aragorn_1er le 24-06-2003 à 17:30:14
n°282421
nikosaka
Posté le 24-06-2003 à 19:02:41  profilanswer
 

Aragorn_1er a écrit :

Bah là sa viendrai plustot de ta page ...
 
Et sur tout les fenetres qu'ils ouvrent il y a kelkechose de marquer dedans ?
 
A+


c'est pas ma page, j'ai juste index.html par défaut de Debian et squirrelmail
avec phoenix, https://127.0.0.1/squirrelmail/ me propose de télécharger le lien  :sweat:  
et avec apache tout fonctionne bien, c'est juste apache-ssl qui m'emm**de  :fou:  
 :sweat:

n°282469
the_fireba​ll
I must fight this sickness
Posté le 24-06-2003 à 20:28:15  profilanswer
 

bizarre ton pb. J'ai la meme chose sur ma Sid (imap-ssl, apache + mod-ssl, squirrelmail) et je viens juste de finir la conf et ça marche impec la lecture des mails (je ne suis pas allé plus loin encore)
 
rien dans les logs d'apache ?


---------------
Two thousand years of misery, of torture in my name, hypocrisy made paramount, paranoia the law, my name is called religion, sadistic, sacred whore.
n°282523
Aragorn_1e​r
Le jihad butlérian est proche
Posté le 24-06-2003 à 21:25:18  profilanswer
 

nikosaka a écrit :


c'est pas ma page, j'ai juste index.html par défaut de Debian et squirrelmail
avec phoenix, https://127.0.0.1/squirrelmail/ me propose de télécharger le lien  :sweat:  
et avec apache tout fonctionne bien, c'est juste apache-ssl qui m'emm**de  :fou:  
 :sweat:  


 
Je ne comprends pas trop ...  
 
A+

n°282559
nikosaka
Posté le 24-06-2003 à 22:25:25  profilanswer
 

Aragorn_1er a écrit :


 
Je ne comprends pas trop ...  
 
A+  


j'ai 2 fois le même site (site qui se résume juste à un webmail)
un avec apache dans /var/www/http
l'autre avec apache-ssl dans /var/www/https
ils sont strictement identiques
quand j'accede à mon site par http://127.0.0.1/squirremail/ tout marche à merveille
si je veux y accéder avec SSL : https://127.0.0.1/squirrelmail/ là à chaque j'ai la fenêtre de téléchargement de phoenix qui me demande si je veux ouvrir ou enregistrer le fichier (qui est juste login.php)
si je le browse avec mozilla c'est encore pire, il m'ouvre des fenetres en cascade à l'infini
 

n°282578
nikosaka
Posté le 24-06-2003 à 22:50:29  profilanswer
 

The_Fireball a écrit :

bizarre ton pb. J'ai la meme chose sur ma Sid (imap-ssl, apache + mod-ssl, squirrelmail) et je viens juste de finir la conf et ça marche impec la lecture des mails (je ne suis pas allé plus loin encore)
 
rien dans les logs d'apache ?


y a ça dans error.log :
[Tue Jun 24 18:45:14 2003] /usr/lib/apache-ssl/gcache started
[Tue Jun 24 18:45:15 2003] [error] (2)No such file or directory: mod_mime_magic: can't read magic file /usr/share/misc/magic
[Tue Jun 24 18:45:15 2003] [notice] Apache configured -- resuming normal operations
[Tue Jun 24 18:45:15 2003] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache-ssl/suexec)
[Tue Jun 24 18:45:15 2003] [notice] Accept mutex: sysvsem (Default: sysvsem)
 
je pense pas que ce soit important, mais bon ...

n°282675
Aragorn_1e​r
Le jihad butlérian est proche
Posté le 25-06-2003 à 09:15:28  profilanswer
 

Question bete : as tu bien mis AddType application/x-httpd-php .php  
Dans /etc/apache-ssl/httpd.conf ?
 
Sinon, pour magic apparement ca n'a pas d'importance.
 
Et la question subsidiaire le module php et bien charger dans /etc/apache-ssl/httpd.conf ?
 
A+

mood
Publicité
Posté le 25-06-2003 à 09:15:28  profilanswer
 

n°282706
nikosaka
Posté le 25-06-2003 à 10:59:01  profilanswer
 

Aragorn_1er a écrit :

Question bete : as tu bien mis AddType application/x-httpd-php .php  
Dans /etc/apache-ssl/httpd.conf ?
 
Sinon, pour magic apparement ca n'a pas d'importance.
 
Et la question subsidiaire le module php et bien charger dans /etc/apache-ssl/httpd.conf ?
 
A+


le module php4 n'était pas chargé  :whistle:  
Merci aragorn  :)


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  réseaux et sécurité

  config de apache-ssl pour utilisation avec squirrelmail

 

Sujets relatifs
empecher l'utilisation de msn messenger sur un firewallApache et DirectoryIndex...
securiser apache[probleme apache et libmm]
Comment utiliser le ssl avec Apache v2.0 sous mendrake 9.1?[squirrelmail] Help ! il ne m'affiche pas la bonne inbox
protection d'apache[apache] bug???
freebsd : apache : mod_define.soProxy Apache : Une sombre merde, il sait meme pas gerer le SSL
Plus de sujets relatifs à : config de apache-ssl pour utilisation avec squirrelmail


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR