Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
507 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  réseaux et sécurité

  autoriser connexion entrante telnet sur Linux/Ubuntu

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

autoriser connexion entrante telnet sur Linux/Ubuntu

n°946965
damien3470​0
Posté le 26-08-2007 à 12:25:37  profilanswer
 

Déjà, je n'ai pas trouvé à priori de post résolu sur ce sujet. Je souhaite (dans le cadre d'une "recherche" ) installer une connexion telnet entre deux postes (je sais c'est pas sécurisé comme ssh et pas prévu par défaut sur ubuntu !).
 
Voila ce que j'ai :
- telnet et inetutils-inetd installés (le processus inetutils-inetd tourne)
- mon inetd.conf parait normal : telnet stream tcp nowait telnetd.telnetd /usr/sbin/tcpd /usr/sbin/in.telnetd
- j'ai renseigné par sécurité mes fichiers hosts.allow hosts. deny pour faire un test en localhost d'abord
in.telnetd      : 127.0.0.1 proftpd : 127.0.0.1 sur hosts.allow
et all:ALL sur hosts.deny
- dans /etc/services j'ai la ligne "telnet 23/tcp"
 
et quand je teste (en root ou en user normal) cela donne
damien@maison:~$ telnet 127.0.0.1
Trying 127.0.0.1...
telnet: Unable to connect to remote host: Connection refused
 
J'avoue ne plus savoir quoi faire, est-ce une histoire de ports faut-il aller mettre une règle dans iptables (j'ai essayé mais sans succès aussi) ? Mon fichier /var/log/auth.log ne me signale rien de spécial non plus ...
Pour info voila le résultat de la commande sudo netstat -taupe |grep LISTEN (j'ai un partage nfs et une imprimante partagée avec cups)
tcp        0      0 *:nfs                   *:*                     LISTEN     root       11563      -
tcp        0      0 *:37698                 *:*                     LISTEN     root       11574      -
tcp        0      0 *:679                   *:*                     LISTEN     root       11621      4740/rpc.mountd
tcp        0      0 localhost:45065         *:*                     LISTEN     hplip      11318      4589/python
tcp        0      0 *:747                   *:*                     LISTEN     root       11715      4805/rpc.statd
tcp        0      0 *:sunrpc                *:*                     LISTEN     root       9477       3690/portmap
tcp        0      0 *:ipp                   *:*                     LISTEN     root       11440      4652/cupsd
tcp        0      0 localhost:39261         *:*                     LISTEN     hplip      11293      4583/hpiod
tcp6       0      0 *:ipp                   *:*                     LISTEN     root       11439      4652/cupsd
 
Merci par avance des renseignements que vous pourrez me fournir

mood
Publicité
Posté le 26-08-2007 à 12:25:37  profilanswer
 

n°947042
_p1c0_
Posté le 26-08-2007 à 20:20:23  profilanswer
 

t'as bien un service qui tourne sur le port où tu te connectes?


---------------
-_- http://www.scienceshopping.com -_-
n°947147
damien3470​0
Posté le 27-08-2007 à 09:29:46  profilanswer
 

Dans mon /etc/services je n'ai que telnet avec le port 23 mais cela ne veut pas dire qu'il tourne, non ? Il n'est pas dans la liste des services visibles dans le menu système/adminstration/services ni avec netstat -atu. Et cela ne marche pas non plus quand je lance /usr/sbin/in.telnetd dans un terminal ??

n°947150
_p1c0_
Posté le 27-08-2007 à 09:32:22  profilanswer
 

non c'est pas parce qu'il est dans /Etc/services qu'il tourne.
 
vérifies qu'il tourne avec ps par exemple et puis vérifies aussi dans la config qu'il écoute bien sur 127.0.0.1 aussi...


---------------
-_- http://www.scienceshopping.com -_-
n°947378
damien3470​0
Posté le 27-08-2007 à 17:33:20  profilanswer
 

il ne tourne pas ! J'ai essayé les deux configs dans hosts.allow et hosts.deny : celle précisée au début du post (auorisant 127.0.0.1 pour les tests) et une avec rien de renseigné (comme c'était avant) : dans les deux cas rien ! Il y a un autre fichier de conf à trouver ? (je suis avec inetd et non pas xinetd).
 
D'autre part j'ai essayé aussi avec ssh et la ça connecte sans problème ! c'est pas lié à la config de ubuntu-dapper ?

n°947379
P-Y
Posté le 27-08-2007 à 17:34:36  profilanswer
 

si c'est pas indiscret, pourquoi tu as absolument besoin d'un telnet et que ssh ne peut pas faire l'affaire?  :??:

n°947380
damien3470​0
Posté le 27-08-2007 à 17:36:30  profilanswer
 

Parce que je cherche à comprendre comment marchent les protocoles et que j'ai lu qu'avec telnet on pouvait lancer des applicatifs à distance.

n°947384
P-Y
Posté le 27-08-2007 à 17:41:11  profilanswer
 

damien34700 a écrit :

Parce que je cherche à comprendre comment marchent les protocoles et que j'ai lu qu'avec telnet on pouvait lancer des applicatifs à distance.


 :heink: je suis pas sur d'avoir bien compris ce que tu veux faire, mais si c'est juste pour lancer un programme sur une autre machine, ca peut tres bien se faire avec ssh...

n°947385
_p1c0_
Posté le 27-08-2007 à 17:42:46  profilanswer
 

damien34700 a écrit :

il ne tourne pas ! J'ai essayé les deux configs dans hosts.allow et hosts.deny : celle précisée au début du post (auorisant 127.0.0.1 pour les tests) et une avec rien de renseigné (comme c'était avant) : dans les deux cas rien ! Il y a un autre fichier de conf à trouver ? (je suis avec inetd et non pas xinetd).
 
D'autre part j'ai essayé aussi avec ssh et la ça connecte sans problème ! c'est pas lié à la config de ubuntu-dapper ?


 
c'est certainement lié au fait que sur le port ssh (donc 22), y a un service qui tourne (le serveur ssh) et pas sur le port 23 du telnet...


---------------
-_- http://www.scienceshopping.com -_-
n°947388
damien3470​0
Posté le 27-08-2007 à 17:58:51  profilanswer
 

la je suis perdu - désolé ;-(( - mais je croyais que ssh occupait le 22 et telnet le 23 donc pas de conflit.
 
C'est pas le cas ?

mood
Publicité
Posté le 27-08-2007 à 17:58:51  profilanswer
 

n°947389
_p1c0_
Posté le 27-08-2007 à 18:02:02  profilanswer
 

damien34700 a écrit :

la je suis perdu - désolé ;-(( - mais je croyais que ssh occupait le 22 et telnet le 23 donc pas de conflit.
 
C'est pas le cas ?


 
si c'est bien ca, mais c'est pas parce que ton serveur ssh tourne sur le port 22 qu'il ya obligatoirement un telnet sur le port 23... Tu as vérifié que ton serveur telnet tourne bien ?


---------------
-_- http://www.scienceshopping.com -_-
n°947617
damien3470​0
Posté le 28-08-2007 à 13:33:19  profilanswer
 

Eh bien non justement je n'arrive pas à le lancer !
j'ai essayé les deux paquets inetutils-telnetd et telnetd (in.telnetd) mais sans succès. Avec telnetd par exemple, cela installe un exécutif /usr/sbin/in.telnetd et quand je le lance manuellement voila ce que cela donne
>/usr/sbin/in.telnetd
>telnetd: getpeername: Socket operation on non-socket
>.
 
Cela ne me dit rien

n°947625
_p1c0_
Posté le 28-08-2007 à 13:57:03  profilanswer
 

t'as essayé ce genre de manip par exemple:
 
http://www.commentcamarche.net/for [...] t-mandrake


---------------
-_- http://www.scienceshopping.com -_-
n°947645
damien3470​0
Posté le 28-08-2007 à 14:27:19  profilanswer
 

le gars a exactement le même problème que moi et pas trouvé de solution. Il faut peut-être passé de inetd à xinetd mais je vois pas pourquoi..
Il ya 3 couples de paquets possibles
- inetutils-telnet client et serveur
- telnet /telnetd
- telnet-ssl telnetd-ssl
 
Par défaut sur ma distribution telnet est installé, il me parait logique de compléter avec telnetd
 
Donc ????

n°947646
_p1c0_
Posté le 28-08-2007 à 14:29:13  profilanswer
 

il se lance pas en mode debug le serveur telnet ? faut que tu cherches dans les logs...


---------------
-_- http://www.scienceshopping.com -_-
n°947648
memaster62
just do turbo S and tux
Posté le 28-08-2007 à 14:34:32  profilanswer
 

ssh permets égalment de lancer des applicatifs a distance, tu te prendrais moins la tete
avec ton pb de telnet...
puisque ton serveur ssh tourne déjà proprement. ;)


---------------
ma conduite intérieure .:R
n°947652
Mjules
Modérateur
Parle dans le vide
Posté le 28-08-2007 à 14:38:58  profilanswer
 

damien34700 a écrit :

Eh bien non justement je n'arrive pas à le lancer !
j'ai essayé les deux paquets inetutils-telnetd et telnetd (in.telnetd) mais sans succès. Avec telnetd par exemple, cela installe un exécutif /usr/sbin/in.telnetd et quand je le lance manuellement voila ce que cela donne
>/usr/sbin/in.telnetd
>telnetd: getpeername: Socket operation on non-socket
>.
 
Cela ne me dit rien


 
c'est un peu normal vu qu'il doit être lancé par (x)inetd
 
sinon, juste pour tester, je viens d'installe et configurer un serveur telnet. ça m'a pris moins de 10'  (sur mandriva, mais c'est kifkif avec ubuntu) :

  • urpmi telnetd
  • créer le fichier telnet dans /etc/xinetd.d avec le contenu trouvé en lien  

    service telnet

    {
            disable         = no
            flags           = REUSE
            socket_type     = stream
            wait            = no
            user            = root
            server          = /usr/sbin/telnetd
            log_on_failure  += USERID
    }


     

    • redémarrer xinetd
    • c'est tout


    Message édité par Mjules le 28-08-2007 à 14:42:21

    ---------------
    Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°947686
damien3470​0
Posté le 28-08-2007 à 15:52:28  profilanswer
 

Bien vu vos messages et notamment celui de Mjules, cela signifie-t-il que je dois passer à xinetd ??? ce qui ne me parait pas logique. inetd de vrait très bien faire l'affaire (avec les lignes telnet et in.telnetd pas commentées)
 
Cela vient-il de mon parefeu-livebox car dans la suite des choses irrésolues (l'intérêt est toujours de chercher à comprendre ;-))) je n'arrive pas à rediriger mon port 22 pour faire du ssh à distance et la commande ssh damien@moi.dyndns.org ne fonctionne pas (alors qu'elle marche en local : ssh damien@192.168.1.10)
 
Je livre encore une fois à votre sagacité ce pb, sachant que le réglage de "serveur lan" (port 22, protocole tco, ID dest. 192.168.1.10) ne marche pas et que le client/serveur amule a fait lui le réglage suivant  
http://dsmagghe.free.fr/config-4720_ok.png
je ne sais pas s'il faut que j'active d'autres interfaces nat et tout le toutim
 

n°947694
damien3470​0
Posté le 28-08-2007 à 16:00:33  profilanswer
 

encore une question sur (x)inetd, quelle différence entre inetd et inetutils-inetd ? j'ai peut-être mis la pagaille dans mes paquets ? Auquel cas il faut que je supprime l'inutile et reparte sur de bonnes bases...
 
Pas toujours facile la bidouille

n°947695
franceso
Posté le 28-08-2007 à 16:02:57  profilanswer
 

Déjà, est-ce que tu as un serveur (x)inetd qui tourne ?


---------------
MAIOT : thésards du CEA Saclay --  GeoGallery : Gallerie de photos géolocalisées -- Home (Debian et Zenega S100)
n°947698
memaster62
just do turbo S and tux
Posté le 28-08-2007 à 16:07:03  profilanswer
 

damien34700 a écrit :



Cela vient-il de mon parefeu-livebox
car dans la suite des choses irrésolues (l'intérêt est toujours de chercher à comprendre ;-))) je n'arrive pas à rediriger mon port 22 pour faire du ssh à distance et la commande ssh damien@moi.dyndns.org ne fonctionne pas (alors qu'elle marche en local : ssh damien@192.168.1.10)

 



en effet, il faut que tu créer un "pont" de routage depuis l'adresse ip-WAN : port22 de ta livebox vers l'ip-LAN : port22 de ta machine
qui fait office de serveur ssh. c'est apelé : serveur virtuel en bon français.


Message édité par memaster62 le 28-08-2007 à 16:07:24

---------------
ma conduite intérieure .:R
n°947740
damien3470​0
Posté le 28-08-2007 à 17:56:13  profilanswer
 

J'ai inetd qui fonctionne (du moins je suppose j'ai un inetd.conf) : comment je vérifie car il n'est pas dans systeme/adminstration/services (ou j'ai cupsys, nfs, ssh) ?
 
Poru le pont de routage je suppose que c'est la "redirection" ? Ceci dit encore plus étonnant dans mes histoires un scan de port (outil d'adminstration proposé par ubuntu) me donne le port 22 ouvert sur mon serveur et le 23 sur la livebox !!!!
ports de la live box http://dsmagghe.free.fr/scan_ports.png
ports du serveur ssh http://dsmagghe.free.fr/scan_port_serveur.png

mood
Publicité
Posté le   profilanswer
 


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  réseaux et sécurité

  autoriser connexion entrante telnet sur Linux/Ubuntu

 

Sujets relatifs
video HD saccade sous UbuntuBoot UBUNTU live par PXE - PROBLEME
Connexion instable (avec debian uniquement) qui me rends fou !Problème de compilation de noyau UBUNTU [ABANDON]
partage connexion pc <> macMontez mes partitions Linux sous FreeBSD
LINUXfaire fonctionner une base de donnée access sous linux
Chipset pleinement compatible LinuxEst ce que cet UPC est compatible linux ?
Plus de sujets relatifs à : autoriser connexion entrante telnet sur Linux/Ubuntu


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR