Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
1973 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs

  Probleme pour eteindre le pc avec HALT

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Probleme pour eteindre le pc avec HALT

n°185588
SyNoK
Posté le 07-11-2002 à 21:55:39  profilanswer
 

Salut a tous,
Ce que j'ai essaye de faire est de compiler noyau 2.4.19 avec le .config d'un ami et que j'ai adapte a ma machine. Ce que j'ai modifie, c'est juste par rapport a mon modem adsl, ma carte son. Le reste marche nickel ... apparement. Mais ce qui ne marche toujours pas, c le "halt", que ce soit avec le noyau precompile 2.4.18 de slackware 8.1, ou le 2.4.19 compile.
Ca me rappel windows 95 qui affiche un message indiquant qu'on pouvait eteindre le pc. :p  
Aussi, suis un newbie :sol:
 
Voila , je crois que j'ai assez detaillé mon probleme.
 
Merci d'avance pour vos reponses.
 
SyNoK

mood
Publicité
Posté le 07-11-2002 à 21:55:39  profilanswer
 

n°185589
Mjules
Modérateur
Parle dans le vide
Posté le 07-11-2002 à 21:56:37  profilanswer
 

donc en fait, ton PC s'éteint pas après le shutdown, c'est ça ?


---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°185590
SyNoK
Posté le 07-11-2002 à 21:57:53  profilanswer
 

c'est exactement ca !!!

n°185591
vrossi1
Posté le 07-11-2002 à 21:59:07  profilanswer
 

il faut que tu rajoutes les options suivantes:
 
General Setup >> Advanced Power Management support <*> et Use real mode APM BIOS to power off <*>

n°185595
kuroineko
je mamgerais bien un truc la..
Posté le 07-11-2002 à 22:00:48  profilanswer
 

APMD est necessaire pour gerer les fonctions energie des machines.
 
verifies qu'il tourne...et lis en la man page pour voir comment l'installer si tu ne l'as pas....
 
si il tourne deja verifies aussi que ton bios a active ces fonctions hardware....
 
il faut les 2 pour que ca fonctionne...
 
c'est souvent aussi simple que ca...(enfin simple,...on ne peut pas tout deviner....lol)...


---------------
[:kuroineko] Francois.P tel: (+33)617230820 http://www.ifrance.com/fpussault  fpussault@caramail.com
n°185599
Mjules
Modérateur
Parle dans le vide
Posté le 07-11-2002 à 22:03:12  profilanswer
 

euh, apmd est désactivé chez moi et le système s'éteint sans pb


---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°185601
SyNoK
Posté le 07-11-2002 à 22:05:21  profilanswer
 

Justement c'est fait. Voila la partie correspondante a mon .config :
CONFIG_PM=y
CONFIG_ACPI=y
CONFIG_ACPI_DEBUG=y
CONFIG_ACPI_BUSMGR=y
CONFIG_ACPI_SYS=y
CONFIG_ACPI_CPU=y
CONFIG_ACPI_BUTTON=y
CONFIG_ACPI_AC=y
CONFIG_ACPI_EC=y
CONFIG_ACPI_CMBATT=y
CONFIG_ACPI_THERMAL=y
CONFIG_APM=y
CONFIG_APM_IGNORE_USER_SUSPEND=y
CONFIG_APM_DO_ENABLE=y
CONFIG_APM_CPU_IDLE=y
CONFIG_APM_DISPLAY_BLANK=y
CONFIG_APM_RTC_IS_GMT=y
CONFIG_APM_ALLOW_INTS=y
CONFIG_APM_REAL_MODE_POWER_OFF=y
 
J'ai aussi oublier de dire que j'ai XP1800+ avec une GA-7VRXP/KT333. Avec le KT266, ca marche nikel. Avec un i845, il y a le meme probleme.

n°185604
BMOTheKill​er
Posté le 07-11-2002 à 22:09:12  profilanswer
 

autrement il y a moyen de compiler avec le support ACPI en mettant bus manager, system et processor en modules (le reste est pour les portables), il faut les charger au démarrage en ajoutant ces lignes à rc.local par exemple :
 
modprobe ospm_busmgr
modprobe ospm_system
modprobe ospm_processor
 
ensuite aucun problème et il n'y a pas besoin d'apmd, de toutes façons si apm est aussi compilé, celui-ci sera ignoré pour utiliser acpi à la place...

n°185608
BMOTheKill​er
Posté le 07-11-2002 à 22:11:26  profilanswer
 

SyNoK a écrit a écrit :

Justement c'est fait. Voila la partie correspondante a mon .config :
CONFIG_PM=y
CONFIG_ACPI=y
CONFIG_ACPI_DEBUG=y
CONFIG_ACPI_BUSMGR=y
CONFIG_ACPI_SYS=y
CONFIG_ACPI_CPU=y
CONFIG_ACPI_BUTTON=y
CONFIG_ACPI_AC=y
CONFIG_ACPI_EC=y
CONFIG_ACPI_CMBATT=y
CONFIG_ACPI_THERMAL=y
CONFIG_APM=y
CONFIG_APM_IGNORE_USER_SUSPEND=y
CONFIG_APM_DO_ENABLE=y
CONFIG_APM_CPU_IDLE=y
CONFIG_APM_DISPLAY_BLANK=y
CONFIG_APM_RTC_IS_GMT=y
CONFIG_APM_ALLOW_INTS=y
CONFIG_APM_REAL_MODE_POWER_OFF=y
 
J'ai aussi oublier de dire que j'ai XP1800+ avec une GA-7VRXP/KT333. Avec le KT266, ca marche nikel. Avec un i845, il y a le meme probleme.




 
bah cherche pas plus loin pourquoi ta machine ne se coupe pas, tu n'utilises pas apm mais acpi à la place et tu n'as pas mis les commandes pour charger les modules, donc ben ça ne se coupe pas...
regarde mon post ci-dessus

n°185609
SyNoK
Posté le 07-11-2002 à 22:11:43  profilanswer
 

Merci beaucoup pour votre aide. Je vais essayer tout ca et je vous tiendrai au courant :)
 
SyNoK

mood
Publicité
Posté le 07-11-2002 à 22:11:43  profilanswer
 

n°185611
SyNoK
Posté le 07-11-2002 à 22:13:14  profilanswer
 

bmothekiller, justement, je vais essayer ta solution.

n°185648
matafan
Posté le 07-11-2002 à 22:39:33  profilanswer
 

"Use real mode APM BIOS call to power off" (CONFIG_APM_REAL_MODE_POWER_OFF) n'est à utiliser que si ta machine plante au lieu de s'éteindre, ce qui n'est pas le cas chez toi. Pour permettre à ta machine de s'éteindre toute seule, il suffit d'activer l'option "Advanced Power Management BIOS support" (CONFIG_APM), et peut-être "Enable PM at boot time" (CONFIG_APM_DO_ENABLE).
 
apmd n'a rien à voir là dedans non plus. C'est juste pour l'économie d'énergie sur les laptops.

n°185800
SyNoK
Posté le 08-11-2002 à 14:20:33  profilanswer
 

bmothekiller ta solution ne marche pas chez moi. :( J'ai vire le APMD et maintenant je peux eteindre :)
Maintenant, je voudrais savoir si j'aurai des problemes plus tard sans l'APMD.
 
Merci a tous pour vos reponses !!!
 
SyNoK

n°194149
kyo54
Posté le 24-11-2002 à 11:40:09  profilanswer
 

SyNoK a écrit a écrit :

Justement c'est fait. Voila la partie correspondante a mon .config :
CONFIG_PM=y
CONFIG_ACPI=y
CONFIG_ACPI_DEBUG=y
CONFIG_ACPI_BUSMGR=y
CONFIG_ACPI_SYS=y
CONFIG_ACPI_CPU=y
CONFIG_ACPI_BUTTON=y
CONFIG_ACPI_AC=y
CONFIG_ACPI_EC=y
CONFIG_ACPI_CMBATT=y
CONFIG_ACPI_THERMAL=y
CONFIG_APM=y
CONFIG_APM_IGNORE_USER_SUSPEND=y
CONFIG_APM_DO_ENABLE=y
CONFIG_APM_CPU_IDLE=y
CONFIG_APM_DISPLAY_BLANK=y
CONFIG_APM_RTC_IS_GMT=y
CONFIG_APM_ALLOW_INTS=y
CONFIG_APM_REAL_MODE_POWER_OFF=y
 
J'ai aussi oublier de dire que j'ai XP1800+ avec une GA-7VRXP/KT333. Avec le KT266, ca marche nikel. Avec un i845, il y a le meme probleme.




j'ai le même problème sur mon PC principal. Tu l'as trouvé où ce fichier de configuration?


---------------
.
n°194340
SyNoK
Posté le 24-11-2002 à 18:16:27  profilanswer
 

Salut c'est ma configuration.
 
SyNoK

n°194342
SyNoK
Posté le 24-11-2002 à 18:17:14  profilanswer
 

Tu vas dans le dossier ou se trouve ton kernel : linux-2.4.x et c le fichier .config

n°194376
kyo54
Posté le 24-11-2002 à 19:14:51  profilanswer
 

tu parles de /usr/src/linux-2.4.18-14/configs et du fichier athlon-smp config?
 
 


---------------
.
n°194377
BMOTheKill​er
Posté le 24-11-2002 à 19:16:38  profilanswer
 

kyo54 a écrit a écrit :

tu parles de /usr/src/linux-2.4.18-14/configs et du fichier athlon-smp config?
 
 
 




 
/usr/src/linux-2.4.18-14/.config (fichier caché)
 
ls -al /usr/src/linux-2.4.18-14/.config

n°194401
kyo54
Posté le 24-11-2002 à 20:25:55  profilanswer
 

BMOTheKiller a écrit a écrit :

 
 
/usr/src/linux-2.4.18-14/.config (fichier caché)
 
ls -al /usr/src/linux-2.4.18-14/.config




heu j'ai pas ça...


---------------
.
n°194407
BMOTheKill​er
Posté le 24-11-2002 à 20:32:23  profilanswer
 

kyo54 a écrit a écrit :

 
heu j'ai pas ça...




 
bah t'as pas encore enregistré de config pour ton noyau alors... change la version, t'as peut-être pas la même non plus hein  :ange:
 
faut avoir un make menuconfig déjà et enregistré la config du noyau en sortant


Message édité par BMOTheKiller le 24-11-2002 à 20:33:19
n°194513
kyo54
Posté le 24-11-2002 à 23:00:55  profilanswer
 

BMOTheKiller a écrit a écrit :

 
 
bah t'as pas encore enregistré de config pour ton noyau alors... change la version, t'as peut-être pas la même non plus hein  :ange:
 
faut avoir un make menuconfig déjà et enregistré la config du noyau en sortant




y'a un truc aussi: au boot y'a un message qui dit grosso-modo que l'APM n'est pas bien pour les solutions SMP. D'ailleurs je n'ai pas d'options APM dans le bios de la carte mêre. Il semble donc que le seul moyen de faire éteindre mon PC vienne de l'ACPI. Je vais faire des recherches en ce sens.
 
Au passage, les logs du démarrage sont-ils enrengistrés quelque part?


---------------
.
n°194518
BMOTheKill​er
Posté le 24-11-2002 à 23:11:51  profilanswer
 

kyo54 a écrit a écrit :

 
y'a un truc aussi: au boot y'a un message qui dit grosso-modo que l'APM n'est pas bien pour les solutions SMP. D'ailleurs je n'ai pas d'options APM dans le bios de la carte mêre. Il semble donc que le seul moyen de faire éteindre mon PC vienne de l'ACPI. Je vais faire des recherches en ce sens.
 
Au passage, les logs du démarrage sont-ils enrengistrés quelque part?




 
dmesg

mood
Publicité
Posté le   profilanswer
 


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs

  Probleme pour eteindre le pc avec HALT

 

Sujets relatifs
Probleme de login en rootProblème réseau avec RH8. Des experts?
probleme de kernelProblème avec Samba sous Mandrake 8.2
probleme avec la derniere version mldonkey....probleme de configuration son
probleme de partitionprobleme de config son
[Gentoo] (& [Debian]) Probleme au debut de l'installationProbleme de connection root
Plus de sujets relatifs à : Probleme pour eteindre le pc avec HALT


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR