Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1362 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs

  installer les sources d'un ancien noyau

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

installer les sources d'un ancien noyau

n°702537
gitigfake
sugar and spice
Posté le 05-07-2005 à 20:37:39  profilanswer
 

Salut à tous
J'ai besoin d'installer les sources de mon ancien noyau un 2.4.22-28.mm.
Or

Code :
  1. rpm -ivh kernel-multimedia-source-2.4.22-28mm.2mdk.i586.rpm
  2. Préparation...              ########################################### [100%]
  3.        
  4.         le paquetage kernel-multimedia-source-2.6.10-1.mm.18mdk (plus récent que kernel-multimedia-source-2.4.22-28mm.2mdk) est déjà installé


 :??:  
Je suis actuellement sur le 2.4.22-28
Je casse tout si je le force ?


Message édité par gitigfake le 05-07-2005 à 20:54:57

---------------
Merci pour vos réponses ...
mood
Publicité
Posté le 05-07-2005 à 20:37:39  profilanswer
 

n°702540
sebchap
Share the knowledge
Posté le 05-07-2005 à 20:39:01  profilanswer
 

Vas sur kernel.org pur telecharger les sources, ensuite tu applique ton patch -mm :)

n°702557
gitigfake
sugar and spice
Posté le 05-07-2005 à 20:50:01  profilanswer
 

D'accord ,ce serait plus propre ....
Mais je ne pense pas que cela resoudrait mon petit probleme ...
 
C'est ,en fait, pour essayer d'avoir l'acceleration nvidia sur les 2 noyaux suivant choix au boot ....


---------------
Merci pour vos réponses ...
n°702578
sebchap
Share the knowledge
Posté le 05-07-2005 à 20:56:18  profilanswer
 

Regarde a FAQ des drivers, je me souvien qu'il y a une options pour installer les drivers pour plusieurs noyau ;)

n°702598
gitigfake
sugar and spice
Posté le 05-07-2005 à 21:06:04  profilanswer
 

sans lire le FAQ (nepastapezsvp)  
Il me semble qu'il faut les sources des differents noyaux (surtout entre un 2.4 et un 2.6) pour compiler le driver.
j'ai bien un driver compilé sous 2.4.22-28 mais X ne se lance pas ...
(pas trouver le copier-collé sans X et avec X)
 

Code :
  1. Error:API mismatch .... Nvidia kernel is version 6.1.0 but X module is version 1.0.7167.please be sure that kernel and driver have same driver version...



Message édité par gitigfake le 05-07-2005 à 21:30:58

---------------
Merci pour vos réponses ...
n°702600
sebchap
Share the knowledge
Posté le 05-07-2005 à 21:08:33  profilanswer
 

Avec les sources telchargées sur kernel.org, tu n'auras aucun probleme pour installer les drivers (au besoin, specifie le chemin avec l'option qui va bien)

n°702606
gitigfake
sugar and spice
Posté le 05-07-2005 à 21:11:19  profilanswer
 

En tarball ? (tar.gz ....)


---------------
Merci pour vos réponses ...
n°702611
sebchap
Share the knowledge
Posté le 05-07-2005 à 21:14:17  profilanswer
 

oui, il n'y a pas de package sur kernel?org, c'est des vanilla (sans patch, sans rien).

n°702622
gitigfake
sugar and spice
Posté le 05-07-2005 à 21:21:43  profilanswer
 

Aprés un recherche (peut etre) trop rapide ,pas trouvé de 2.4.22-28.
 
Le patch 28 +la version mdk +le mm = le RPM non  :??:  
 
Je me vois pas appliquer ces patchs l'un aprés l'autre sur des sources installées..  :pt1cable:


Message édité par gitigfake le 05-07-2005 à 21:22:11

---------------
Merci pour vos réponses ...
n°702665
sebchap
Share the knowledge
Posté le 05-07-2005 à 21:46:33  profilanswer
 

http://rpm.pbone.net/index.php3/st [...] d+hardware
 
il y en a pas mal la dessus, apres, je ne sais pas lequel il te faut exactement. Ca me parait un peu bordelique :/
Sinon tu prefere pas changer de kernel :D ?

mood
Publicité
Posté le 05-07-2005 à 21:46:33  profilanswer
 

n°702724
gitigfake
sugar and spice
Posté le 05-07-2005 à 22:14:33  profilanswer
 

Merci pour le lien mais .....
C'est des .rpm ...
 
Retour au 1er post
Conflit de rpm...
 
J'ai deja un 2.6.10-1.mm.18mdkcustomKD7A qui tourne mais ....
Pas de fb au demarrage = ecran noir ! :(  
Obliger de passer à lilo.conf

Code :
  1. vga=normal


pour avoir de l'affichage (les lignes [OK] ...
 
Mais (plus grave) mplayer me renvoie un segmentation fault alors que le 2.4 non. ...


---------------
Merci pour vos réponses ...
n°702742
sebchap
Share the knowledge
Posté le 05-07-2005 à 22:19:36  profilanswer
 

A mon avis, tu te debarassera plus facilement des problemes en passant a un noyau superieur plutot que de redescendre en 2.4

n°702761
gitigfake
sugar and spice
Posté le 05-07-2005 à 22:34:31  profilanswer
 

je recapitule ...
 
j'ai 2 noyaux fonctionnels  
-2.4.22-28mm et
-2.6.10-1mm mais ...
l'acceleration graphique (nvidia) n'est que pour le 2.6  :(  
 
Sous le 2.4 je modprobe le 'nvidia.o' du 2.4 mais

Code :
  1. Error:API mismatch .... Nvidia kernel is version 6.1.0 but X module is version 1.0.7167.please be sure that kernel and driver have same driver version...


suite a l'erreur de compiler le nouveau driver (nvidia.ko) sous le 2.6....
Pour appiquer la compilation pour differents noyaux ,faut les sources,d'ou mon probleme  :pt1cable:  :pt1cable:  


---------------
Merci pour vos réponses ...
n°702863
arghbis
salops de dauphins
Posté le 06-07-2005 à 05:25:49  profilanswer
 

ben a priori, tu dois pouvoir forcer l'install du paquet, sans trop de danger


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs

  installer les sources d'un ancien noyau

 

Sujets relatifs
Mettre à jour le noyauInstaller linux avec lecteur CD externe (et sans disquette)
installer linux sur dd branche a controleur ide PCI[FC4] possible d'installer la version anglaise de Firefox ?
Grub : ne veut plus s'installer sur le mbrInstaller un thème Firefox sous linux
[Mdk LE2005 || Debian] Installer sur un DD IDE en USB ??Problème après compilation du noyau
impossible d'installer xine-win32 
Plus de sujets relatifs à : installer les sources d'un ancien noyau


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR