Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
2153 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs

  installation de driver ATI sur SUSE 10 [resolu]

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

installation de driver ATI sur SUSE 10 [resolu]

n°756072
lucaskywal​ker
Posté le 25-11-2005 à 22:10:32  profilanswer
 

bonjour,
j'essais depuis une semaine de metre ces drivers.Mais vu que je debarque sur linux, je ne comprend rien a la maniere de les installer.
 
je vous explique les differentes tentatives que j ai faite:
 
1: sur le site ATI il y a un fichier .run . Ce fichier est dit "installer", dans le fichier d aide il demande ceci:
"Enter the command ./ati-driver-installer-8.19.10.run to launch the ATI Proprietary Linux driver installer"
quand je tape la comande il m affiche "Permission denied"
 
2: dans un autre fichier de doc j ai vu qu il etait possible de creer fichier un rpm a partir du fichier .run
en tapant cette commande avec la commande --buildpkg , mais la, il me ressort le message "Permission denied"
 
3: finalement sur le site d ATI il y a aussi des fichiers .rpm .
J'ai alors essayer rpm -Uh --force ./fglrx_4_3_0-8.19.10-1.i386.rpm
 
ca marche pas non plus, voila l erreur apres deux barres de progression:  
"make.sh: line 39: gcc: command not found
make.sh: line 45: [: !=: unary operator expected"
 
4:j ai vue que quand je cliquais sur un des .rpm avec conqueror je pouvais l executer avec "yast" ce que je fait...
il copie des fichiers...
Apres ca je fais fglrxconfig, tout a l air de marcher.Je configure ma carte d apres les questions qu il me pose.
A la fin il me demande si je veux ecrir le fichier soit "xorg.conf" soit "XF86Config-4" ca depend du .rpm installer avant.
 
apres ca je fais un fglrxinfo et je vois que je suis toujours en soft  
 
 :sweat:
 
j ai tenter tout ca en root comme en utilisateur...
je vois vraiment plus quoi fair.Si qq un a le courage de m expliquer la bonne manipulation...
Merci


Message édité par lucaskywalker le 09-12-2005 à 17:08:53
mood
Publicité
Posté le 25-11-2005 à 22:10:32  profilanswer
 

n°756205
lucaskywal​ker
Posté le 26-11-2005 à 13:31:17  profilanswer
 

personne pour me donner un petit coup de main? :hello:

n°758618
gd87
Posté le 03-12-2005 à 07:28:38  profilanswer
 

Vas voir là,
http://linux.wordpress.com/2005/10 [...] tallation/
si ça marche tu me le dis merci.....

n°758824
kao_chen
Posté le 03-12-2005 à 22:29:44  profilanswer
 

Moi j'ai poster un tutos sur le xorg.conf et les drivers ati pour Mandriva mais tu devrai trouver ton bonheur ou presque.

n°758825
kao_chen
Posté le 03-12-2005 à 22:30:20  profilanswer
 

oups j'avais oublié l'adresse
http://astuceslinux.neuf.fr

n°758897
gd87
Posté le 04-12-2005 à 06:55:41  profilanswer
 

kao_chen a écrit :

oups j'avais oublié l'adresse
http://astuceslinux.neuf.fr


 :love: bravo pour les explications !!!

n°758986
Joseph Des​ire
Posté le 04-12-2005 à 13:47:13  profilanswer
 

kao_chen a écrit :

oups j'avais oublié l'adresse
http://astuceslinux.neuf.fr


 
 
Tres bon tuto, ca aide énormement, car c'est pas comprehensible du tout ce que demande le .run .....  
Petit probleme apres la configuration de mon ATI Radeon 9800 Pro, je n'ai plus le scroll sur le troisieme bouton de la souris, quelle modif dois je faire ? :
 
EDIT : oooopppps.... me manquait la ligne Emulate3Buttons
 
    Option "Emulate3Buttons"       "true"
    Option "ZAxisMapping"          "4 5"  
 
 
Ca marcheeeee :)


Message édité par Joseph Desire le 04-12-2005 à 14:36:17
n°759336
lucaskywal​ker
Posté le 05-12-2005 à 12:38:35  profilanswer
 

Merci beaucoup gb87 j' ai beaucoup avance grace a ton tuto... :jap:  
tout a l air de fonctionner...
fglrxinfo me dit bien que les drivers ATI sont la...
glxgears tourne bien...
mais un problem subsiste, lorsque je tape 3Ddiag il me dit qu il n y a pas de carte acceleratrice installe...
Et shake 4 (la raison de mon passage sous linux) ne semble pas avoir d acceleration non plus.
 
merci pour ta page kao_chen , j y suis aller hier, et la plus rien... domage je n est pas eu le temp de l etudier.
 
j y suis presque....si qq un peu m aider pour le reste (pourquoi 3Ddiag me dit ca et pourquoi shake n est pas accelere) ce serai genial... :hello:

n°759348
kao_chen
Posté le 05-12-2005 à 12:58:55  profilanswer
 

Neuf telecom c pas terrible ....
je suis un peu enervé
il viennent de perdre tout mes fichiers
ca c pas cool
je vais essayer de les remettres en places le plus vite possible
 
Pour la souris je pense qu'il ne faut pas Choisir l'option "Emulate3buttons"
il faut choisir la souris de type PS/2 wheels mouse
Wheels=roue
Je me depeche pour le site

n°759352
kao_chen
Posté le 05-12-2005 à 13:04:46  profilanswer
 

le serveur neuf à l'air d'avoir un probleme....
je sais pas encore qd je vais pouvoir retablir lle site
......
 
 

mood
Publicité
Posté le 05-12-2005 à 13:04:46  profilanswer
 

n°759382
Joseph Des​ire
Posté le 05-12-2005 à 13:38:46  profilanswer
 

lucaskywalker > pendant qu'on y est :  
 

Citation :

bash-3.00$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9800 Pro Generic
OpenGL version string: 1.3.5461 (X4.3.0-8.19.10)
 
bash-3.00$ glxgears
21407 frames in 5.0 seconds = 4281.400 FPS
22808 frames in 5.0 seconds = 4561.600 FPS
Broken pipe


 
Chez moi les jeux en 3D (tux racer, Vega Strike) rament comme c'est pas permis, c'est inutilisable, la souris lague. T'as le meme probleme ?

n°759390
lucaskywal​ker
Posté le 05-12-2005 à 14:21:22  profilanswer
 

Juste pour info ,il repond quoi quand vous tapez 3Ddiag dans un terminal....

n°759392
lucaskywal​ker
Posté le 05-12-2005 à 14:24:20  profilanswer
 

je testerais les jeux ce soir c une bonne idee, chui au boulot la...

n°759395
Joseph Des​ire
Posté le 05-12-2005 à 14:43:00  profilanswer
 

Ya que des paquets pour SuSE... étant sous Mandriva.....

n°760031
lucaskywal​ker
Posté le 07-12-2005 à 10:52:57  profilanswer
 

desole, la j ai vraiment pas le temp. Je testerai les jeux ce week end.

n°760351
lucaskywal​ker
Posté le 08-12-2005 à 11:01:51  profilanswer
 

voila j ai teste, les jeux fonctionnent bien chez moi.
Et je viens de reussir a faire fonctionner shake. Je suis aller faire un petit tour dans le xorg.conf , j au vu que le openGL overlay etait off par defaut avec les profils que l'on copie avec la methode d installation de cette page http://linux.wordpress.com/2005/10 [...] allation/.
Je les mis en "on" et ca marche....
 
Shake 4.0 utilise donc opengl overlay
 
merci pour votre aide je n y serai pas arrive sans vous :jap:  
 
PS: pour ce qui est de 3Ddiag, la commande me dit toujours que je n ai pas acceleration.


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs

  installation de driver ATI sur SUSE 10 [resolu]

 

Sujets relatifs
pb graphique sous Suse 10.0 avec ATI Radeon 9600 ProInstallation de webmin
Probleme d'installation Ubuntu : "booting the kernel"[résolu] Ghost d'une partition Mandriva2006 ne boote pas
erreur installation : invalid compressed format err=1installation kernel source Ubuntu
proftpd.conf, je suis à bout !! [résolu][mdk10.0] compil driver wifi MA521 rtl8180???
[Résolu] [script shell AIX] 
Plus de sujets relatifs à : installation de driver ATI sur SUSE 10 [resolu]


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR