Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1566 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Logiciels

  Paramétrage du clavier sous Linux (Ubuntu, Fedora, Suse)

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Paramétrage du clavier sous Linux (Ubuntu, Fedora, Suse)

n°1107724
runesone
Aide-toi le ciel t'aidera !
Posté le 27-01-2009 à 01:17:00  profilanswer
 

Bonjour,  
 
Je rencontre un problème de paramétrage du clavier sous Linux -Ubuntu (et également avec les distributions Suse et Fedora 7)  
 
Il y a une différence entre Windows et Linux sur certains points concernant les touches Verr.Maj (Caps lock) et Maj (Shift) et la frappe du point d’interrogation.  
 
1/Touches Verr.Maj (Cpas lock) et Maj (Shift) :  
Habituellement, lorsqu’on active la touche Verr.Maj (indiquée par un cadenas), un voyant lumineux s’allume au dessus du pavé numérique (Caps lock). Cette fonction permet d’écrire un texte en majuscule.  
 
Sous Windows, cette touche peut être désactivée, afin d’écrire en minuscules, de deux façons :  
-sous Win 98 en appuyant soit sur la touche Maj (Shift) soit sur la touche Verr.Maj (Caps lock) ;  
-sous XP en appuyant une deuxième fois sur la touche Verr.Maj (Caps lock).  
Mais ce réglage peut être modifié en allant dans le panneau de configuration.  
 
Sous Linux, c’est différent : pour écrire tout un texte en majuscule on appuie sur la touche Verr.Maj (Caps lock) et pour écrire tout en minuscule on appuie une nouvelle fois sur Verr.Maj (Caps lock).  
 
Pour ceux qui font journellement du traitement de texte sur leur lieu de travail, où les machines sont paramétrées depuis des années avec la désactivation de la touche Verr.Maj (Caps lock) par la touche Maj (Shift), il est très perturbant de se retrouver chez soi avec un système d’exploitation tel Linux (Ubuntu, Suse, Fedora, etc…) qui ne permet pas le même déverrouillage. On se retrouve ensuite avec des fautes de frappe à cause des automatismes !
 
2/Frappe du point d’interrogation sous Linux.  
Cette fonction (parmi d’autres comme la virgule) est également problématique avec Linux-Ubuntu car il faut faire une manipulation spéciale pour arriver à dactylographier un point d’interrogation.  
 
Qui peut m’indiquer les solutions à ces problèmes ? Je signale que l’accès aux modifications dans UBUNTU par : Menu Système->Préférences->Clavier->onglet agencement->bouton autre options->option Comportement de la touche majuscule…ne donne rien. Puisqu'il s'agit d'un produit "libre", il doit être possible pour un informaticien chevronné, d'aller modifier les lignes de commande. Merci d'avance à tous.

mood
Publicité
Posté le 27-01-2009 à 01:17:00  profilanswer
 

n°1107731
mikala
Souviens toi du 5 Novembre...
Posté le 27-01-2009 à 02:35:22  profilanswer
 

je ne sais pas ce qu'il en est sous gnome  mais sous kde (4.1.x au moins) il est possible de modifier ce comportement dans la configuration du clavier (au niveau de la localisation région/langue dans les options avancées )
Cela revient a modifier la ligne de configuration de xkb en un
setxkbmap -option shift:breaks_cap si il y avait besoin réellement du ligne de commande... ( http://www.littleboboy.net/~mikala/xkb.png)
 
 


---------------
Intermittent du GNU
n°1202560
basile238
Posté le 04-03-2010 à 00:08:04  profilanswer
 

Bonjour,
 
je remonte ce sujet car j'ai un problème similaire sous Fedora et impossible de le résoudre.
Sur tous mes claviers depuis que je suis petit, capslock agit comme s'il verouillait la touche shift sur l'ensemble des touches, y compris les 4 touches de ponctuations en bas à droite.
Suite à un des mes premiers jobs étudiant où j'avais beaucoup de saisie à faire, j'ai pris l'habitude de ne jamais me servir de la touche shift, et de tout faire avec caps lock. Ainsi, je n'ai jamais à garder un doigt enfoncé sur une touche, ce qui évite les douleurs (la saisie est entièrement fluide), et je n'utilise jamais deux touches simultanément.
 
Pour taper un point, j'utilise donc la séquence "caps lock, point, caps lock", au lieu de maintenir shift en tapant sur la touche point.
 
Le problème est que quelque-soit la manière dont je paramètre le clavier sous Linux, la séquence "caps lock, point" me donne un point virgule. Autrement dit, linux refuse de prendre en compte le caps lock pour les touches de ponctuations comme le point.
 
Avez-vous une solution, un soft, un truc à faire en ligne de commande, une invocation voodoo ?
Au pire une version de Linux ou ça marche (je peux me refaire une install vu que je viens juste d'installer Fedora).
C'est bizarre de ne pas trouver un paramétrage du clavier qui soit comme sur mes anciens PC. J'ai eu 5 ou 6 ordinateurs, une bonne dizaine de systèmes d'exploitation (Windows il est vrai) et ils marchaient tous de la même façon pour la touche caps lock. Et là je n'arrive à reparamétrer mon clavier normalement.
 
Merci à tous pour votre aide.

n°1202569
Fork Bomb
Obsédé textuel
Posté le 04-03-2010 à 06:55:30  profilanswer
 

grep XkbModel /etc/X11/xorg.conf
grep XkbLayout /etc/X11/xorg.conf
grep XkbVariant /etc/X11/xorg.conf


---------------
Décentralisons Internet-Bépo-Troll Bingo - "Pour adoucir le mélange, pressez trois quartiers d’orange !"

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Logiciels

  Paramétrage du clavier sous Linux (Ubuntu, Fedora, Suse)

 

Sujets relatifs
Dossié partégé sur linux, droit en utilisant compte AD ?Migration SCSI raid 5 a IDE (redhat - linux)
SMB ou NFS entre Windows et Linux ?Distribution linux qui se rapproche le plus d'une RedHat ?
Linux + LightScribeProblème de clavier sur Gnu/Linux debian etch 4.0r3
migration linuxInstaller Linux sur ps3 pour jouer à fligh gear
pulse audio sous ubuntu: vade-retros ! 
Plus de sujets relatifs à : Paramétrage du clavier sous Linux (Ubuntu, Fedora, Suse)


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR