Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
2138 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Logiciels

  [Apache2/Debian Lenny] problème d'encodage

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[Apache2/Debian Lenny] problème d'encodage

n°1128336
Burps
Posté le 15-04-2009 à 16:09:35  profilanswer
 

Bonjour
 
Apache 2, mediawiki, nagios sont sur un bateau sur une lenny.
 
Mediawiki affiche parfaitement les caractères accentués, mais nagios me sort des trucs chelous, genre "Décalage".
 
J'ai la config suivante :  

Code :
  1. $ locale
  2. LANG=fr_FR.UTF-8
  3. LC_CTYPE="fr_FR.UTF-8"
  4. LC_NUMERIC="fr_FR.UTF-8"
  5. LC_TIME="fr_FR.UTF-8"
  6. LC_COLLATE="fr_FR.UTF-8"
  7. LC_MONETARY="fr_FR.UTF-8"
  8. LC_MESSAGES="fr_FR.UTF-8"
  9. LC_PAPER="fr_FR.UTF-8"
  10. LC_NAME="fr_FR.UTF-8"
  11. LC_ADDRESS="fr_FR.UTF-8"
  12. LC_TELEPHONE="fr_FR.UTF-8"
  13. LC_MEASUREMENT="fr_FR.UTF-8"
  14. LC_IDENTIFICATION="fr_FR.UTF-8"
  15. LC_ALL=
  16. $ locale -a
  17. C
  18. en_US
  19. en_US.iso88591
  20. en_US.iso885915
  21. en_US.utf8
  22. français
  23. french
  24. fr_FR
  25. fr_FR@euro
  26. fr_FR.iso88591
  27. fr_FR.iso885915@euro
  28. fr_FR.utf8
  29. POSIX


 
les vhosts sont similaires (seules les definition des DocumentRoot, ServerName, etc diffèrent) ...
 
Si vous avez une piste, je suis preneur...
 
Merci

mood
Publicité
Posté le 15-04-2009 à 16:09:35  profilanswer
 

n°1128381
arghbis
salops de dauphins
Posté le 15-04-2009 à 20:27:24  profilanswer
 

le defaultCharset d'apache?

n°1128382
d@kn1ko
Posté le 15-04-2009 à 20:30:40  profilanswer
 

header("Content-Type:text/html; charset=utf-8" );
 
j ai deja eu ce prob qui ne se produisait pas sur toute les pages va savoir pourquoi..


Message édité par d@kn1ko le 15-04-2009 à 20:31:17
n°1128461
Burps
Posté le 16-04-2009 à 09:41:20  profilanswer
 

d@kn1ko : ca voudrait dire que je dois aller changer qqch sur CHAQUE page envoyée par nagios ?
 
Sinon, arghbis, je le changerais où ce "defaultCharset" ?

n°1128906
arghbis
salops de dauphins
Posté le 17-04-2009 à 18:17:26  profilanswer
 

/etc/apache2/conf.d/charset

n°1130141
Burps
Posté le 23-04-2009 à 09:57:08  profilanswer
 

Pour info : (je n'ai pas encore trouvé la solution...)
J'ai installé un 3eme virtualhost sur la machine, j'ai récupéré une page web d'un autre serveur : cette page s'affichait avec des caractères : j'ai passé le fichier en UTF-8 avec iconv, les fochiers se sont correctement affichés.
 
J'en déduis que sur le vhost nagios, les fichiers sont mal encodés : sauf qu'ils ont été installés par le package debian : dois-je tous les convertir a la main ? comment ?

n°1130389
arghbis
salops de dauphins
Posté le 23-04-2009 à 19:35:00  profilanswer
 

quel encodage détecte le navigateur. Si iso, essaye de forcer en utf8, si utf8, force en iso.
 
Dans le premier cas, ça veut dire que ton site envoie le mauvais encoding, dans le second, probablement le pb apache que j'ai mentionné

n°1130758
splurf
Rm -Rf / && oops :o
Posté le 25-04-2009 à 11:09:44  profilanswer
 

-> changer l'encoding dans le vhost


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Logiciels

  [Apache2/Debian Lenny] problème d'encodage

 

Sujets relatifs
webmail simple et légé (sous debian), squirrelmail ?Hdd cheetah SAS non reconnu sous debian lenny
Gros problème XenOpenVPN sous Debian
[Debian] - Monitoring (daemon)Installer Debian à partir d'un support non CD
probleme boot vista apres installe linux[GRUB] Probleme boot de ubuntu
[Linux] Problème réseau bizarre sur mon serveur Linux 
Plus de sujets relatifs à : [Apache2/Debian Lenny] problème d'encodage


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR